Package Details: vim-command-t 4.0-1

Git Clone URL: (read-only)
Package Base: vim-command-t
Description: an extremely fast, intuitive mechanism for opening files and buffers with a minimal number of keystrokes
Upstream URL:
Licenses: BSD
Groups: vim-plugins
Submitter: vlan
Maintainer: sleduc
Last Packager: sleduc
Votes: 27
Popularity: 0.000508
First Submitted: 2011-02-25 09:50
Last Updated: 2016-08-16 08:05

Latest Comments

EdwardXXIV commented on 2016-05-22 12:15

It looks like the most recent version is broken, I get exceptions when trying to use it. Upgrading to the latest version and adding missing files results in:

sleduc commented on 2014-08-25 11:31

Bumped to 1.11, thanks for your message.

cameel commented on 2014-08-25 11:20

I'm getting an error:

/tmp/vim-command-t/PKGBUILD: line 19: cd: /tmp/vim-command-t/src/Command-T-1.10/ruby/command-t: No such file or directory
==> ERROR: A failure occurred in build().

Replacing Command-T with command-t in paths fixes it.

Also checksum for 1.10 seems to be wrong. Maybe they have replaced the package upstream? Anyway, 1.11 is out.

sleduc commented on 2014-03-22 10:05

It should work better now, thanks for your message and sorry I missed that during the last update.

EdwardXXIV commented on 2014-03-22 09:53

Hi there, thanks for maintaining this package!

Unfortunately, the current version introduced some additional files that are not copied in the PKGBUILD. Here's an updated version:

# Maintainer: Sebastien Leduc <>
# Contributor: Andrey Vlasovskikh <>

pkgdesc="an extremely fast, intuitive mechanism for opening files and buffers with a minimal number of keystrokes"
arch=("i686" "x86_64")
depends=("vim" "ruby")


build() {
cd "$srcdir/Command-T-$pkgver/ruby/command-t"

ruby "extconf.rb"

package() {
local _gitname="command-t"
cd "$srcdir/Command-T-$pkgver/"

local _installprefix="${pkgdir}/usr/share/vim/vimfiles"
install -m755 -d "${_installprefix}"/{doc,plugin,"ruby/${_gitname}"/{vim,finder,scanner{,/file_scanner}}}
install -m644 -t "${_installprefix}/doc" "doc"/*.txt
install -m644 -t "${_installprefix}/plugin" "plugin"/*.vim
install -m644 -t "${_installprefix}/ruby/${_gitname}" "ruby/${_gitname}"/*.{rb,so}
install -m644 -t "${_installprefix}/ruby/${_gitname}/vim" "ruby/${_gitname}/vim"/*.rb
install -m644 -t "${_installprefix}/ruby/${_gitname}/finder" "ruby/${_gitname}/finder"/*.rb
install -m644 -t "${_installprefix}/ruby/${_gitname}/scanner" "ruby/${_gitname}/scanner"/*.rb
install -m644 -t "${_installprefix}/ruby/${_gitname}/scanner/file_scanner" "ruby/${_gitname}/scanner/file_scanner"/*.rb

# install license files
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE

# vim:set ts=2 sw=2 et:

pizzapill commented on 2013-12-12 19:56

@sleduc: Thanks for your good & quick maintenance work!

sleduc commented on 2013-12-11 21:25

Thanks for the notification.
I updated the package to use the "released" version ( instead of the git version, there is no need to clone a git repository if a simple tar.gz is available.

pizzapill commented on 2013-12-11 19:58

I'm getting a 'connection reset by peer' error for the original repo 'git://'. As a workaround I replaced it with the mirror 'git://' in the PKGBUILD.

sleduc commented on 2013-10-05 19:08

Thanks for the updated PKBUILD, I have just updated the package.

orbisvicis commented on 2013-10-05 18:44

For 1.5.1:

New install script:

vlan commented on 2012-07-12 23:37

I've dropped maintaining this package. Command-T for vim is wonderful, please adopt the package! :)

vlan commented on 2011-09-22 20:33

@Runiq thanks!

Runiq commented on 2011-07-14 09:51

Here's an updated PKGBUILD for the new version:

Needed to add the ruby/vim/{finder,scanner} directories and files.