Package Details: vim-latexsuite-git 1:0.r835.ae5a9cb-1

Git Clone URL: https://aur.archlinux.org/vim-latexsuite-git.git (read-only)
Package Base: vim-latexsuite-git
Description: Provides a comprehensive set of tools to view, edit, and compile LaTeX documents within Vim. Also provides macros to speed up the creation of LaTeX documents.
Upstream URL: http://vim-latex.sourceforge.net
Licenses: custom:vim
Groups: vim-plugins
Conflicts: vim-latexsuite
Provides: vim-latexsuite
Submitter: None
Maintainer: jnbek
Last Packager: jnbek
Votes: 171
Popularity: 0.120045
First Submitted: 2011-02-15 23:21
Last Updated: 2015-08-18 22:15

Required by (0)

Sources (1)

Latest Comments

sekret commented on 2014-10-06 20:09

It has been a makedependency, but it didn't appear here because there was no .AURINFO file included.

I adopted and updated the package, changed the pkgver function to the "standard" for git repos with no tags and pushed the epoch so you get the update in your AUR manager.

Dasonk commented on 2014-10-06 00:01

You should add git as a make dependency

sekret commented on 2014-08-04 07:46

I think this package should depend on vim-runtime rather than vim, so e.g. users of neovim, who want to use it, don't have to install vim.

What do you think?

gtmanfred commented on 2012-09-26 23:16

I am going to move this package into community and take snapshots of the git every so often

Anonymous comment on 2012-07-15 15:15

I have no () in the install line

gtmanfred commented on 2012-07-15 05:26

in a pkgbuild, install= is not an array remove the ()

Anonymous comment on 2012-04-10 10:54

No that's not necessary. This package always gets the newest version. So if you make a makepkg now, you'll get everything which was changed after january 2012 as well.

Anonymous comment on 2012-04-10 02:58

Hi,
new here, so don't be too harsh.
I'm wondering if this should be flagged as out-of-date.
http://sourceforge.net/projects/vim-latex/files/snapshots/
lists a new snapshot from January 2012.

Anonymous comment on 2012-04-08 08:35

It's already included as a makedependency. I don't think that the vim-latexsuite uses git for anything. Or am I missing something?

tpavlic commented on 2012-04-07 21:34

@Army: Git should be added as a dependency of this package.

tpavlic commented on 2012-04-07 21:33

@asch -- As mentioned several times in the comments, you should be using the vim-latexsuite-git package:

vim-latexsuite-git: http://aur.archlinux.org/packages.php?ID=46559

The vim-latex suite package is out of date. Moreover, it would be pointless it maintain it as vim-latexsuite is primarily distributed via git these days. You shouldn't hold your breath for official "releases" that might be associated with this non-git version.

So use the git version.

asch commented on 2012-04-07 21:08

Broken package:
==> ERROR: install file (('vim-latexsuite.install')) does not exist.

Fix it or pass the package on someone else.

tpavlic commented on 2012-02-24 16:32

Revelation60 -- Why are you not using vim-latexsuite-git? Try that package instead of this one.

Revelation60 commented on 2012-02-24 16:29

Please fix this!

mortzu commented on 2012-02-05 16:53

==> ERROR: install file (('vim-latexsuite.install')) does not exist.
==> ERROR: Makepkg was unable to build vim-latexsuite.

ferda commented on 2012-02-04 08:17

The line

install=('vim-latexsuite.install')

in the PKGBUILD has to be replaced by

install=vim-latexsuite.install
.

Anonymous comment on 2012-01-15 22:12

Thanks Runiq!

Runiq commented on 2012-01-15 17:28

Quoth the user manual, "Latex-Suite is released under the Vim charityware license. For license and conditions of use look at |copyright|. Replace all occurrences of ``Vim'' with ``Latex-Suite''. The current copyright holders of Latex-Suite are Srinath Avadhanula and Mikolaj Machowski."

So using Vim's license was right all along. Just thought I'd mention this in case you hadn't found it already. :)

Anonymous comment on 2011-09-07 06:35

Thanks man! Made it much simpler for me to update the package.

However, there are still some things I'd like to improve. For example, I don't know about the license, I just used the one which was provided in vim-latexsuite-svn, but I don't find evidence that this is the right license. There's nothing about it in the sources afaics.

Anonymous comment on 2011-09-07 00:54

I managed to figure out how to fix it. This is the diff between the PKGBUILD I used and the one on here:
http://pastie.org/private/eobadwkr1hklrg8yoq

Anonymous comment on 2011-09-07 00:10

The directory structure of the repo seems to have changed such that there is no longer a "vimfiles" directory in the root of the repo. The contents of "vimfile" appear to have been moved to the root directory when they split the repo into vim-latex and htdocs. I am not sure how exactly the files should be installed so I haven't managed to make a corrected PKGBUILD yet.

tpavlic commented on 2011-08-25 15:03

steabert: You should see the git package instead:

vim-latexsuite-git: http://aur.archlinux.org/packages.php?ID=46559

It has python2 as an optdepends, has an any architecture, and has a cleaner description. More importantly, it's tied to the git repository that is actually being used with vim-latexsuite.

steabert commented on 2011-08-25 12:46

Hi, thanks for packaging this!
I did notice the following (with the help op namcap):
- architecture should be 'any'
- there seems to be a dependency on python2 which is missing?
- description shouldn't contain package name (namcap complaint)

steabert commented on 2011-08-25 12:46

Hi, thanks for packaging this!
I did notice the following (with the help op namcap):
- architecture should be 'any'
- there seems to be a dependency on python2 which is missing?
- description shouldn't contain package name (namcap complaint)

steabert commented on 2011-08-25 12:46

Hi, thanks for packaging this!
I did notice the following (with the help op namcap):
- architecture should be 'any'
- there seems to be a dependency on python2 which is missing?
- description shouldn't contain package name (namcap complaint)

steabert commented on 2011-08-25 12:45

Hi, thanks for packaging this!
I did notice the following (with the help op namcap):
- architecture should be 'any'
- there seems to be a dependency on python2 which is missing?
- description shouldn't contain package name (namcap complaint)

csslayer commented on 2011-03-31 07:30

gvim provides vim, so there is no problem.

Anonymous comment on 2011-03-30 19:12

I had to change the PKGBUILD. I changed the depends from "vim" to "gvim".

igor commented on 2011-02-26 07:28

sed -i 's|/usr/bin/python|/usr/bin/python2|g'
looks readable than
sed -i 's/\/usr\/bin\/python/\/usr\/bin\/python2/g'


Anonymous comment on 2011-02-16 20:25

As far as I know replaces is for e.g. projects which replace their name, e.g. gaim became pidgin, so pidgin replaces gaim. So my vim-latexsuite-git only conflicts with and provides vim-latexsuite-svn, because it contains the same files.

petelewis commented on 2011-02-16 11:02

Suggestion: Maybe add a replaces=(vim-latexsuite-svn).

Thanks.

tpavlic commented on 2011-02-16 01:08

See the new

vim-latexsuite-git

package instead.

tpavlic commented on 2011-02-14 21:17

vim-latex SCM is now done through git:

http://vim-latex.git.sourceforge.net/git/gitweb.cgi?p=vim-latex/vim-latex;a=summary