Package Details: vim-rust-git 20200918-1

Git Clone URL: https://aur.archlinux.org/vim-rust-git.git (read-only, click to copy)
Package Base: vim-rust-git
Description: Rust language support for Vim
Upstream URL: https://github.com/rust-lang/rust.vim
Licenses: MIT, Apache
Conflicts: vim-rust
Provides: vim-rust
Submitter: paigeruten
Maintainer: lilydjwg
Last Packager: lilydjwg
Votes: 29
Popularity: 0.196380
First Submitted: 2014-08-03 13:01 (UTC)
Last Updated: 2020-09-29 05:28 (UTC)

Dependencies (4)

Required by (1)

Sources (1)

Latest Comments

1 2 Next › Last »

lilydjwg commented on 2021-07-30 16:24 (UTC)

@theguy147: There is an issue adding the group: since I also provide this package in an unofficial repo, adding packages to groups that exist in the official repos will disrupt users who try to install the whole group but actually mean only the packages in the official repos.

Instead, you can query your vim plugins by pacman -Qo /usr/share/vim/vimfiles/, maybe filtering with | grep vim-.

theguy147 commented on 2021-07-30 15:50 (UTC)

can you add groups=('vim-plugins') to the PKGBUILD. It makes it easier to find all installed vim-plugins with <YOUR AUR HELPER> -Qg vim-plugins

thanks!

Morganamilo commented on 2019-12-01 01:36 (UTC)

Please add the cargo syntax checker

diff --git a/PKGBUILD b/PKGBUILD
index 30a523d..132d372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Jeremy Ruten <jeremy.ruten@gmail.com>
 pkgname=vim-rust-git
-pkgver=r337.fc11d02
+pkgver=r548.b7176e7
 pkgrel=1
 pkgdesc="Syntax and supporting functionality for the Rust filetype"
 arch=('any')
@@ -32,6 +32,7 @@ package() {
   install -D -m644 after/syntax/rust.vim "${vimfiles}/after/syntax/rust.vim"
   install -D -m644 autoload/rustfmt.vim "${vimfiles}/autoload/rustfmt.vim"
   install -D -m644 autoload/rust.vim "${vimfiles}/autoload/rust.vim"
+  install -D -m644 autoload/cargo.vim "${vimfiles}/autoload/cargo.vim"
   install -D -m644 compiler/rustc.vim "${vimfiles}/compiler/rustc.vim"
   install -D -m644 compiler/cargo.vim "${vimfiles}/compiler/cargo.vim"
   install -D -m644 doc/rust.txt "${vimfiles}/doc/rust.txt"
@@ -41,6 +42,7 @@ package() {
   install -D -m644 plugin/rust.vim "${vimfiles}/plugin/rust.vim"
   install -D -m644 syntax/rust.vim "${vimfiles}/syntax/rust.vim"
   install -D -m644 syntax_checkers/rust/rustc.vim "${vimfiles}/syntax_checkers/rust/rustc.vim"
+  install -D -m644 syntax_checkers/rust/cargo.vim "${vimfiles}/syntax_checkers/rust/cargo.vim"

   # Produce a warning if new files get added to the repo in the future.
   if ! find . | grep -v "./.git" | sort | diff - "${srcdir}/git-manifest.txt"

kpcyrd commented on 2017-01-07 23:50 (UTC)

==> Starting pkgver()... /tmp/yaourt-tmp-user/aur-vim-rust-git/./PKGBUILD: line 19: cd: /tmp/yaourt-tmp-user/aur-vim-rust-git/src/rust.vim: No such file or directory ==> ERROR: pkgver is not allowed to be empty. ==> ERROR: pkgver() generated an invalid version: ==> ERROR: Makepkg was unable to build vim-rust-git. ==> Restart building vim-rust-git ? [y/N] Can you please fix this. Also, don't use git:// as source, there is no checksum verification and you're installing unauthenticated files from the network as root.

<deleted-account> commented on 2016-04-24 16:58 (UTC)

I can't use the rustfmt command, since /autoload/rustfmt.vim and /plugin/rustfmt.vim are not included.

paigeruten commented on 2015-02-01 05:06 (UTC)

@lilydjwg: done!

lilydjwg commented on 2015-02-01 04:25 (UTC)

I guess it's time to switch upstream to https://github.com/rust-lang/rust.vim

paigeruten commented on 2014-10-03 04:18 (UTC)

Package updated to install the new ${vimfiles}/compiler/cargo.vim file.

paigeruten commented on 2014-09-13 21:49 (UTC)

I guess I can't make vim-rust-git conflict with rust, because rust-nightly-bin provides rust. And this package is specifically for rust-nightly-bin users, because it's the only rust package that doesn't install the vimfiles.

paigeruten commented on 2014-09-13 21:30 (UTC)

@emanueLczirai: Thanks for letting me know, I guess some rust packages include the vim stuff, and others don't, like rust-nightly-bin. I'll add the conflicting ones to the PKGBUILD.