Package Details: vim-x11 8.2.5037-2

Git Clone URL: https://aur.archlinux.org/vim-x11.git (read-only, click to copy)
Package Base: vim-x11
Description: Vi Improved, a highly configurable, improved version of the vi text editor (X11 support, no GUI)
Upstream URL: http://www.vim.org
Licenses: custom:vim
Conflicts: gvim, gvim-python3, vim, vim-minimal, vim-python3
Provides: vim, xxd
Submitter: kuroneko
Maintainer: Thrawn
Last Packager: Thrawn
Votes: 9
Popularity: 0.000000
First Submitted: 2014-09-03 01:39 (UTC)
Last Updated: 2022-05-31 17:36 (UTC)

Dependencies (17)

Required by (458)

Sources (3)

Latest Comments

OhadEytan commented on 2020-10-10 18:34 (UTC) (edited on 2020-10-12 11:17 (UTC) by OhadEytan)

Same here:

 -> Could not find all required packages:
    vim-runtime=8.2.1684-1 (Wanted by: vim-x11)

[Solved with the update. Thanks!]

rdbeni0 commented on 2020-09-15 19:06 (UTC) (edited on 2020-09-15 19:07 (UTC) by rdbeni0)

Hi, the same as previosly:

-> Could not find all required packages: vim-runtime=8.2.0914-0 (Wanted by: vim-x11)

yay -Q |grep vim-runtime

vim-runtime 8.2.1684-1

can you pls update pkg?

Thrawn commented on 2018-05-13 12:33 (UTC) (edited on 2018-05-13 12:43 (UTC) by Thrawn)

vim-runtime got 3 updates in the last 3 days. I've pushed a new version for 8.0.1826, hopefully it should be up-to-date now. Sorry for the trouble!!

@dmos: somehow I missed your comment about the armv7h architecture, should be fixed too now!!

OhadEytan commented on 2018-05-13 10:51 (UTC) (edited on 2018-05-13 10:54 (UTC) by OhadEytan)

vim-runtime version should be updated, currentlly I got:

error: failed to prepare transaction (could not satisfy dependencies)

:: vim-x11: installing vim-runtime (8.0.1826-1) breaks dependency 'vim-runtime=8.0.1542-2'

dmos commented on 2018-02-28 10:14 (UTC)

Hi @Thrawn, please pull in these changes [0]. They add armv7h architecture support and increment _upstream_pkgrel, because the current vim-runtime version is 8.0.1542-2. These are separate commits.

[0] https://notabug.org/dmos/aur-vim-x11/commits/master

Thrawn commented on 2016-11-12 03:34 (UTC)

@kuroneko: I've "adopted" this orphan package. @Purgator: I had the same problem, so I've updated the PKGBUILD, hopefully it should be fixed now. Tell me if it works!

kuroneko commented on 2016-10-09 06:03 (UTC)

I have disowned this package since I no longer use Vim very much. Apologies for the inconvenience.

Purgator commented on 2016-10-06 13:04 (UTC)

Hello, I'm trying to install vim from aur, here is what I'm doing : git clone https://aur.archlinux.org/vim-x11.git cd vim-x11 makepkg -s PKGBUILD But I got the following error : ==> Making package: vim-x11 7.4.2334-1 (Thu Oct 6 15:02:28 CEST 2016) ==> Checking runtime dependencies... ==> Installing missing dependencies... error: target not found: vim-runtime=7.4.2334-1 ==> ERROR: 'pacman' failed to install missing dependencies. Ok of course there is no vim-runtime=7.4.2334-1 in database but there is vim-runtime. Should I just edit by myself. I would like to understand cause it's very strange to me. Thx

kuroneko commented on 2015-10-13 01:10 (UTC)

With regard to this package getting out of date: I'll try to keep it up to date, but I cannot be monitoring it 24/7. Please mark this as out of date as needed. In the meantime, you can edit the PKGBUILD and bump the version yourself. The relevant lines are "pkgver=" and "_upstream_pkgrel". This will work 99% of the time, but it is possible that Arch will make changes to the official vim-runtime that breaks this package.

kuroneko commented on 2015-10-11 23:46 (UTC)

@lordmocha Should be fixed now. Make sure to read https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages

lordmocha commented on 2015-10-11 11:32 (UTC)

So how do i actually install this? arch:~$ sudo aura -A vim-x11 aura >>= Determining dependencies... aura >>= Dependency checking failed for these reasons: The dependency `vim-runtime` demands version `=7.4.854-1`, but the most recent version is `7.4.884-1`.

kuroneko commented on 2015-05-22 02:20 (UTC)

@shemz Nope. At least two reasons: 1) The official Arch repository uses = and not >= 2) Can you guarantee that this package will work with vim-runtime 7.4.713? 7.4.720? 7.5? 8.0? If not, then = is better.

smahs commented on 2015-05-20 14:46 (UTC)

I wasn't being sarcastic. I do not use Arch that much these days to follow all the changes. There is still something to optimize here. It might be a good idea to depend on vim_runtime >= pkgver as the version of stock vim_runtime which will always be >= pkgver.

psi-jack commented on 2015-04-30 04:23 (UTC)

Upstream version is 7.4.663

kuroneko commented on 2015-04-10 14:21 (UTC)

@shemz Fixed. No need to be sarcastic about it.

smahs commented on 2015-04-10 06:29 (UTC)

In the old days, ABS used to have a tag for "provides" to enable dependencies identify alternate builds as a replacement for the corresponding repo package; in this case vim-x11 should provide vim. Can you check if it is still possible?

kuroneko commented on 2015-01-12 23:16 (UTC)

7.4.567 will probably hit the repos in a bit, you just have to tweak the patch level in the PKGBUILD if you don't want to wait for me to update.

scorpp commented on 2015-01-12 17:43 (UTC)

7.4.560 is in repos

kuroneko commented on 2014-11-16 23:55 (UTC)

@onodera Fixed.

onodera commented on 2014-11-15 23:43 (UTC)

hg is missing as a build dependency. Thanks for making thise pkgbuild btw!

kuroneko commented on 2014-09-03 01:42 (UTC)

This is compiled with X11 support, but without the GUI. The key difference between this and vim in the repos is that Xorg clipboards are supported ("* and "+ registers). GUI is not compiled in. (It's only about 0.15 MB smaller than gvim, and is specifically for people who want X11 clipboard support but not the GUI for some reason).