Package Details: vim-x11 8.0.0851-1

Git Clone URL: https://aur.archlinux.org/vim-x11.git (read-only)
Package Base: vim-x11
Description: Vi Improved, a highly configurable, improved version of the vi text editor (X11 support, no GUI)
Upstream URL: http://www.vim.org
Licenses: custom:vim
Conflicts: gvim, gvim-python3, vim, vim-minimal, vim-python3
Provides: vim=8.0.0851-1, xxd
Submitter: kuroneko
Maintainer: Thrawn
Last Packager: Thrawn
Votes: 4
Popularity: 0.233337
First Submitted: 2014-09-03 01:39
Last Updated: 2017-08-13 10:14

Dependencies (17)

Required by (298)

Sources (3)

Latest Comments

Thrawn commented on 2016-11-12 03:34

@kuroneko: I've "adopted" this orphan package.
@Purgator: I had the same problem, so I've updated the PKGBUILD, hopefully it should be fixed now. Tell me if it works!

kuroneko commented on 2016-10-09 06:03

I have disowned this package since I no longer use Vim very much.

Apologies for the inconvenience.

Purgator commented on 2016-10-06 13:04

Hello,

I'm trying to install vim from aur, here is what I'm doing :

git clone https://aur.archlinux.org/vim-x11.git
cd vim-x11
makepkg -s PKGBUILD

But I got the following error :

==> Making package: vim-x11 7.4.2334-1 (Thu Oct 6 15:02:28 CEST 2016)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: vim-runtime=7.4.2334-1
==> ERROR: 'pacman' failed to install missing dependencies.


Ok of course there is no vim-runtime=7.4.2334-1 in database but there is vim-runtime. Should I just edit by myself. I would like to understand cause it's very strange to me.

Thx

kuroneko commented on 2015-10-13 01:10

With regard to this package getting out of date:

I'll try to keep it up to date, but I cannot be monitoring it 24/7. Please mark this as out of date as needed.

In the meantime, you can edit the PKGBUILD and bump the version yourself. The relevant lines are "pkgver=" and "_upstream_pkgrel". This will work 99% of the time, but it is possible that Arch will make changes to the official vim-runtime that breaks this package.

kuroneko commented on 2015-10-11 23:46

@lordmocha
Should be fixed now. Make sure to read https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages

lordmocha commented on 2015-10-11 11:32

So how do i actually install this?

arch:~$ sudo aura -A vim-x11
aura >>= Determining dependencies...
aura >>= Dependency checking failed for these reasons:
The dependency `vim-runtime` demands version `=7.4.854-1`, but the most recent version is `7.4.884-1`.

kuroneko commented on 2015-05-22 02:20

@shemz
Nope. At least two reasons:
1) The official Arch repository uses = and not >=
2) Can you guarantee that this package will work with vim-runtime 7.4.713? 7.4.720? 7.5? 8.0? If not, then = is better.

smahs commented on 2015-05-20 14:46

I wasn't being sarcastic. I do not use Arch that much these days to follow all the changes.
There is still something to optimize here. It might be a good idea to depend on vim_runtime >= pkgver as the version of stock vim_runtime which will always be >= pkgver.

psi-jack commented on 2015-04-30 04:23

Upstream version is 7.4.663

psi-jack commented on 2015-04-30 04:22

Upstream version if 7.4.663

All comments