Package Details: vimprobable2-git 2014.12.26.ga514968-2

Git Clone URL: https://aur.archlinux.org/vimprobable2-git.git (read-only)
Package Base: vimprobable2-git
Description: Lightweight, keyboard-driven, WebKit based browser with Vim keybinds.
Upstream URL: http://www.yllr.net/vimprobable/
Licenses: MIT
Conflicts: vimprobable2
Provides: vimprobable2
Submitter: totoloco
Maintainer: jasonwryan
Last Packager: jasonwryan
Votes: 68
Popularity: 0.000044
First Submitted: 2010-01-19 19:28
Last Updated: 2015-06-08 10:01

Required by (0)

Sources (3)

Latest Comments

jasonwryan commented on 2013-11-04 20:02

Thanks Kyrias: updated.

Kyrias commented on 2013-11-04 19:39

Some random notes:

1) `depends` is an array and shouldn't be a single string. ;)

2) All of the functions start in $srcdir, no reason to include it when cd'ing.

3) The URL won't change so there's no reason to use the variable instead of hardcoding it.

4) And you can just use $pkgname as the folder so you don't need another unnecessary variable at all.

4) I'd suggest changing the protocol to git+http so that people behind firewalls can use the PKGBUILD as-is, too.

jasonwryan commented on 2013-04-12 10:26

I've updated the PKGBUILD to comply with pacman 4.1 standards: http://sprunge.us/XLdQ

totoloco commented on 2011-12-14 13:11

Fixed, thx jasonwryan :D

jasonwryan commented on 2011-12-13 08:22

Build is failing because of javascriptcoregtk link. This PKGBUILD fixes the issue for me: http://codepad.org/1jKWulMC

totoloco commented on 2011-10-03 10:19

Updated, thx jasonwryan :D

jasonwryan commented on 2011-10-03 01:26

Current PKGBUILD is pulling an older version. I cloned current with this:
git clone --depth=1 $_gitroot $_gitname

totoloco commented on 2011-08-30 14:12

Thx chneukirchen :)
Updated.

chneukirchen commented on 2011-08-30 13:57

Should be

git clone -b ${_gitbranch} ${_gitroot} vimprobable

totoloco commented on 2011-08-28 20:24

Updated to sourceforge git repo

Raziel23 commented on 2011-08-28 17:31

The repository has been moved to sourceforge. Previous hosting has been lost, and below is link to more comprehensive explanation:
http://www.vimprobable.org/mailman/archives/vimprobable-users/2011-August/000864.html

Here is my working PKGBUILD with new repository:
http://pastebin.com/7ghz6dhv

totoloco commented on 2010-08-22 14:38

updated pkgbuild :D

skottish commented on 2010-08-22 14:24

The 'keys' section of config.h has moved to it's own file, keymap.h.

totoloco commented on 2010-07-23 21:21

updated. thx david_a :D

*david_a* commented on 2010-07-23 20:44

Install fails due to PKGBUILD lines 48 and 49 being mismatched.
Line 48 uses ${pkgname} - Line 49 uses ${_gitname}2
Both should use ${_gitname}2

quark commented on 2010-04-21 07:48

conflict with ibus input method. This is serious...

totoloco commented on 2010-04-09 12:34

updated, thx nikel.
salU

Anonymous comment on 2010-04-08 23:29

Here the patch: http://aur.pastebin.com/8YcU1wgZ
Work fine on i686 for me.

P.S.: -Wl,--as-need cause only problems and bring almost no benefits.

Anonymous comment on 2010-04-08 23:19

Hi. I think the problem is only with LDFLAGS and it is -Wl,--as-need.
Please don't clean CFLAGS and try this to filter LDFLAGS:
LDFLAGS=$(for i in $LDFLAGS; do echo "$i" | grep -v -- -Wl,--as-need ; done )

totoloco commented on 2010-04-08 11:04

... to compile it in 64 bits.
please check in 32 bits :D
salU

totoloco commented on 2010-04-08 11:04

updated.
I clean LDFLAGS and CFLAGS to compile it :s
thx nikel.

Anonymous comment on 2010-04-08 00:48

There are new Makefile. Here a patch for PKGBUILD: http://aur.pastebin.com/ZeiTYG2H