Package Details: virtaal 0.7.1-6

Git Clone URL: https://aur.archlinux.org/virtaal.git (read-only)
Package Base: virtaal
Description: A tool to create program translations.
Upstream URL: http://translate.sourceforge.net/wiki/virtaal/index
Keywords: gettext l10n localization po
Licenses: GPL
Submitter: leonardof
Maintainer: amiad
Last Packager: amiad
Votes: 27
Popularity: 0.003655
First Submitted: 2008-11-22 20:32
Last Updated: 2017-04-30 10:13

Dependencies (14)

Required by (0)

Sources (1)

Latest Comments

rafaelff commented on 2017-05-14 22:36

@amiad: Sorry for the delay, I didn't enabled notifications of this package before; now I enabled it.

A tarball for beta is not available, however you can easily git-clone a specific commit, or download a zip archive file of a specific commit from GitHub. See e.g. 'jhbuild' package (which I maintain). Feel free to contact me if you need more detailed info.

btw, if you plan to create another package, I suggest you to go ahead with "-git" (to dynamically update the version) instead of a -beta/-dev (newer, unreleased), as this software don't have (currently) much development activity; if some development happen in the git-repo, then there would be a git-package ready to get it. Just my 2 cents on the subject.

amiad commented on 2017-04-30 10:17

@rafaelff: I update the deps.
Where the beta? Maybe I will create new package for its.

rafaelff commented on 2017-04-29 21:02

@amiad: Please replace 'translate-toolkit' with 'python2-translate-toolkit-lib', as it provides all translate API built with python2.

By the way, could you please update Virtaal to the unreleased 1.0.0 beta1 version? I've been using it for some time and it looks stable enough, and also fix some bugs from 0.7.1.

rafaelff commented on 2017-04-29 15:34

MazeChazer: the reason is that translate-toolkit is now built with python3, which is incompatible with virtaal as it requires python2. This is easily solved providing a translate-toolkit's libs built against python2. I'm working on a AUR package for that. Please wait a bit.

MazeChaZer commented on 2017-03-29 06:30

I can't even build this package anymore:

Traceback (most recent call last):
File "./setup.py", line 64, in <module>
from translate.tools.pocompile import convertmo
ImportError: No module named translate.tools.pocompile

simon04 commented on 2017-02-27 12:08

This package is incompatible with translate-toolkit 2.0.0 since the latter no longer provides Python 2 libs.

$ pacman -Qs virtaal
local/virtaal 0.7.1-5
A tool to create program translations.

$ virtaal
Traceback (most recent call last):
File "/usr/bin/virtaal", line 23, in <module>
from virtaal.common import pan_app
File "/usr/lib/python2.7/site-packages/virtaal/common/__init__.py", line 21, in <module>
import pan_app
File "/usr/lib/python2.7/site-packages/virtaal/common/pan_app.py", line 27, in <module>
from translate.misc import file_discovery
ImportError: No module named translate.misc

rafaelff commented on 2016-08-17 19:23

Since a couple of days ago, Virtaal is freezing on startup. It doesn't matter if I open it with or without an existing PO file: the main window opens, I see the header of the window, but nothing more is displayed.

Is it just me?

American_Jesus commented on 2016-01-25 23:10

Virtaal has a new home http://virtaal.translatehouse.org/

tarakbumba commented on 2013-03-13 06:13

Changelog:
- Added package() function. See:
https://mailman.archlinux.org/pipermail/pacman-dev/2010-April/010620.html

rafaelff commented on 2012-12-09 18:19

Here is a up-to-date PKGBUILD, including dependencies: http://pastebin.com/ZP9zFbj5

All comments