Package Details: vivaldi-widevine 1:4.10.1303.2-1

Git Clone URL: https://aur.archlinux.org/vivaldi-widevine.git (read-only)
Package Base: vivaldi-widevine
Description: A browser plugin designed for the viewing of premium video content, standalone for vivaldi
Upstream URL: https://www.widevine.com/
Keywords: amazon netflix prime vivaldi
Licenses: custom
Conflicts: chromium-widevine, google-chrome
Submitter: pheerai
Maintainer: Musikolo
Last Packager: Musikolo
Votes: 36
Popularity: 1.658034
First Submitted: 2016-05-26 08:41
Last Updated: 2019-03-28 02:01

Pinned Comments

pheerai commented on 2017-08-14 08:33

Please note that you won't need this package if you have google-chrome installed, vivaldi will find the plugin from that package as well.

You can check if you need this package here: https://bitmovin.com/mpeg-dash-hls-drm-test-player/ If the video plays, you're already set regarding widevine, even though you might still need the vivaldi-ffmpeg-codecs.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Musikolo commented on 2018-08-28 03:03

@Scimmia, yes, I see know. Sorry for the confusion.

I've googled a bit about it, and I've found this: - https://forum.vivaldi.net/topic/29247/widevine-cdm-not-detected-despite-having-chrome-and-the-plugin-setting-enabled-ubuntu-18-04/12

I hope it's helpful!

Scimmia commented on 2018-08-28 02:42

You missed my point. The pinned comment says that vivaldi will find and use the plugin installed by google-chrome, that doesn't appear to be true at this time if it can't use the current version.

As for chromium-widevine, check who the submitter and maintainer is on that.

Musikolo commented on 2018-08-28 01:32

@Scimmia, Google Chrome comes with this plugin embedded, so there is no need of external plugin installation. In addition, this package is only for Vivaldi browser. If you need it for Chromium, you should use https://aur.archlinux.org/packages/chromium-widevine/ instead.

I hope this clarifies everything.

Thank you!

Scimmia commented on 2018-08-27 04:43

So a google-chrome install will no longer work, either. I hope this is just a one-time change in how the plugin is handled upstream and not an ongoing problem.

Musikolo commented on 2018-08-27 03:34

@Scimmia, version 4.10.1146.0 requires Chromium 68 which is not shipped in Vivaldi yet. I tried that version of widevine some weeks ago, and it didn't work for me. As soon as a Vivaldi-compatible version is released, I'll update widevine.

Thank you!

Musikolo commented on 2018-08-11 02:09

@yuu-syss, thanks for the heads up. The issue is fixed.

I don't know what's going on with the Google guys changing the EULA license every other day...

Thank you!

yuu-syss commented on 2018-08-11 00:42

Still having issues. Isn't the eula sha256sum f6aa8b7920d20c874deabc745517e0486e88fe9de667ad3d5fe6f61665ec725c instead of 8a0e9057c2a27bfcc74e210b848e6824e3c6c8f41232ca034362bcddfb95acbd ?

Musikolo commented on 2018-08-09 01:49

@ot8, thanks for the heads up. The issue should be solved!

Thank you!

ot8 commented on 2018-08-08 14:32

Still broken for me ==> Validating source files with sha256sums...
chrome-eula_text.html ... FAILED

Musikolo commented on 2018-07-14 03:50

@zacky, the issue was fixed:

[musikolo@MyPC vivaldi-widevine]$ makepkg
==> Making package: vivaldi-widevine 1:1.4.9.1088-2 (Fri Jul 13 22:47:41 2018)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading chrome-eula_text.html...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   257  100   257    0     0   1647      0 --:--:-- --:--:-- --:--:--  1647
100 47707    0 47707    0     0   203k      0 --:--:-- --:--:-- --:--:--  203k
  -> Downloading google-chrome-stable_67.0.3396.99-1_amd64.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 50.0M  100 50.0M    0     0  21.2M      0  0:00:02  0:00:02 --:--:-- 21.3M
==> Validating source files with sha256sums...
    chrome-eula_text.html ... Passed
    google-chrome-stable_67.0.3396.99-1_amd64.deb ... Passed
==> Extracting sources...
  -> Extracting google-chrome-stable_67.0.3396.99-1_amd64.deb with bsdtar
==> Starting prepare()...
==> Starting pkgver()...
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "vivaldi-widevine"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: vivaldi-widevine 1:1.4.9.1088-2 (Fri Jul 13 22:47:51 2018)
[musikolo@MyPC vivaldi-widevine]$ 

Please, make sure you get the latest version I pushed a while ago.

Thank you!