Package Details: vlmc-git 1:0.4358.9ad256c1-1

Git Clone URL: https://aur.archlinux.org/vlmc-git.git (read-only, click to copy)
Package Base: vlmc-git
Description: VideoLAN Movie Creator, a simple and user-friendly video editor
Upstream URL: http://vlmc.org/
Licenses: GPL
Conflicts: vlmc
Provides: vlmc
Submitter: AsA
Maintainer: Un1Gfn
Last Packager: migrev
Votes: 71
Popularity: 0.000000
First Submitted: 2009-12-23 16:51
Last Updated: 2017-01-16 11:07

Latest Comments

1 2 3 4 Next › Last »

bkb commented on 2020-04-03 21:46

It's funny because as soon as I posted an error message, the package maintainer has directly dismissed his maintainer role

So for now, we're on our own

@Kppqju77 Le français, c'est le mal, essaies de modifier tes locales parce que les gens vont pas avoir envie de lire. T'facon le principal soucis de ce paquetage c'est qu'il as pas été mis à jour depuis 3 ans, donc faut pas espérer de correction sur le paquet avant une mise à jour de celui-ci

Kppqju77 commented on 2020-04-03 15:24

@bkb I guess mlt is missing as a make dependency, but even with this I get the following error:

./src/Library/Library.h:87:18: erreur: « virtual void Library::onMediaModified(std::vector<long int>) » est marqué « override » mais il ne surcharge rien
   87 |     virtual void onMediaModified( std::vector<int64_t> media ) override;

when compiling the following:

CXX      src/Commands/vlmc-Commands.o

bkb commented on 2020-03-30 13:39

configure: error: Package requirements (mlt-framework >= 6.3) were not met:

Package 'mlt-framework', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MLT_CFLAGS
and MLT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: vlmc-git

sergey.orloff commented on 2016-12-10 14:14

Hello! does anyone know what is the reason for this build failure?

...
src/Main/Core.cpp: В конструкторе «Core::Core()»:
src/Main/Core.cpp:50:71: ошибка: invalid new-expression of abstract class type «Library»
m_library = new Library( m_settings, m_currentProject->settings() );
^
In file included from src/Main/Core.cpp:36:0:
./src/Library/Library.h:51:7: замечание: поскольку следующие виртуальные функции являются чистыми в пределах «Library»:
class Library : public QObject, private medialibrary::IMediaLibraryCb
^~~~~~~
In file included from ./src/Library/Library.h:37:0,
from src/Main/Core.cpp:36:
/usr/include/medialibrary/IMediaLibrary.h:106:18: замечание: virtual void medialibrary::IMediaLibraryCb::onPlaylistsAdded(std::vector<std::shared_ptr<medialibrary::IPlaylist> >)
virtual void onPlaylistsAdded( std::vector<PlaylistPtr> playlists ) = 0;
^~~~~~~~~~~~~~~~
/usr/include/medialibrary/IMediaLibrary.h:107:18: замечание: virtual void medialibrary::IMediaLibraryCb::onPlaylistsModified(std::vector<std::shared_ptr<medialibrary::IPlaylist> >)
virtual void onPlaylistsModified( std::vector<PlaylistPtr> playlists ) = 0;
^~~~~~~~~~~~~~~~~~~
/usr/include/medialibrary/IMediaLibrary.h:108:18: замечание: virtual void medialibrary::IMediaLibraryCb::onPlaylistsDeleted(std::vector<long int>)
virtual void onPlaylistsDeleted( std::vector<int64_t> playlistIds ) = 0;
^~~~~~~~~~~~~~~~~~
make[1]: *** [Makefile:2088: src/Main/vlmc-Core.o] Ошибка 1
make[1]: выход из каталога «/build/vlmc-git/src/vlmc»
make: *** [Makefile:982: all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Прерывание...

migrev commented on 2016-09-05 09:33

@ArnaudNux: You need to install vlc-git instead of vlc for this to compile. Or wait until vlc 3 is stable and released.

ArnaudNux commented on 2016-09-04 22:09

checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether g++ supports C++11 features by default... yes
checking whether C++ compiler accepts -fPIC... yes
checking for an Android system... no
checking for 3rd party libraries path... not usable
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for QT... yes
checking for moc-qt5... /usr/bin/moc-qt5
checking for rcc-qt5... /usr/bin/rcc-qt5
checking for uic-qt5... /usr/bin/uic-qt5
checking for VLC... no
configure: error: Package requirements (libvlc >= 3.0) were not met:

Requested 'libvlc >= 3.0' but version of LibVLC control API is 2.2.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables VLC_CFLAGS
and VLC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build vlmc-git.
==> Restart building vlmc-git ? [y/N]

astro commented on 2016-08-02 14:15

error on build :

build()...
CMake Error: The source directory "/tmp/yaourt-tmp/aur-vlmc-git/src/vlmc" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

Anonymous comment on 2016-04-17 21:53

@mahoff, thanks for the reminder. There has been considerable upstream changes after a long period of nothing. I'll do my best to update accordingly.

mahoff commented on 2016-04-17 18:09

There are the following commands needed in build():

git submodule init
git submodule update

alexandre-mbm commented on 2016-01-05 04:33

Yes, it worked. Thanks. But I can not use the software; I do not know how make cuts. Or there is a bug (more probably).