Package Details: vlmc-git 1:0.4187.8162cfd-1

Git Clone URL: https://aur.archlinux.org/vlmc-git.git (read-only)
Package Base: vlmc-git
Description: VideoLAN Movie Creator, a simple and user-friendly video editor
Upstream URL: http://vlmc.org/
Licenses: GPL
Conflicts: vlmc
Provides: vlmc
Submitter: AsA
Maintainer: migrev
Last Packager: migrev
Votes: 71
Popularity: 0.904916
First Submitted: 2009-12-23 16:51
Last Updated: 2016-08-25 09:25

Latest Comments

migrev commented on 2016-09-05 09:33

@ArnaudNux: You need to install vlc-git instead of vlc for this to compile. Or wait until vlc 3 is stable and released.

ArnaudNux commented on 2016-09-04 22:09

checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether g++ supports C++11 features by default... yes
checking whether C++ compiler accepts -fPIC... yes
checking for an Android system... no
checking for 3rd party libraries path... not usable
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for QT... yes
checking for moc-qt5... /usr/bin/moc-qt5
checking for rcc-qt5... /usr/bin/rcc-qt5
checking for uic-qt5... /usr/bin/uic-qt5
checking for VLC... no
configure: error: Package requirements (libvlc >= 3.0) were not met:

Requested 'libvlc >= 3.0' but version of LibVLC control API is 2.2.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables VLC_CFLAGS
and VLC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build vlmc-git.
==> Restart building vlmc-git ? [y/N]

ritchy commented on 2016-08-02 14:15

error on build :

build()...
CMake Error: The source directory "/tmp/yaourt-tmp/aur-vlmc-git/src/vlmc" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

shaggytwodope commented on 2016-04-17 21:53

@mahoff, thanks for the reminder. There has been considerable upstream changes after a long period of nothing. I'll do my best to update accordingly.

mahoff commented on 2016-04-17 18:09

There are the following commands needed in build():

git submodule init
git submodule update

alexandre-mbm commented on 2016-01-05 04:33

Yes, it worked. Thanks. But I can not use the software; I do not know how make cuts. Or there is a bug (more probably).

shaggytwodope commented on 2016-01-05 00:54

@alexandre-mbm Seems a new upstream for the git now, https://code.videolan.org/videolan/vlmc I changed it and it should fully work now. If you have any package cache stuff setup, remove the vlmc bits.

alexandre-mbm commented on 2016-01-05 00:38

See https://github.com/VLMC/vlmc/issues/3

alexandre-mbm commented on 2016-01-05 00:34

==> Obtendo fontes...
-> Clonando repositório vlmc do tipo git...
Cloning into bare repository '/tmp/yaourt-tmp-alexandre/aur-vlmc-git/vlmc'...
fatal: remote error: access denied or repository not exported: /vlmc.git
==> ERRO: Falha ao baixar o repositório vlmc do tipo git
Abortando...
==> ERRO: Makepkg não conseguiu compilar vlmc-git.
==> Reiniciar a compilação de vlmc-git ? [s/N]

shaggytwodope commented on 2014-12-08 13:35

Fixed and adopted by me, installed lasted commit.Any issues email in pkgbuild.

cookies commented on 2014-08-13 19:15

I'm orphaning this package as I'm not using it anymore. Feel free to adopt.

assimilat commented on 2014-02-25 18:49

Had to remove all references to resources-ts.qrc by deleting these lines:
>>>ts/CMakeLists.txt:76:SET(TS_QRC ${CMAKE_SOURCE_DIR}/ts/resources-ts.qrc)
>>>src/CMakeLists.txt:8: ../ts/resources-ts.qrc
otherwise it failed with:
CMake Error in src/CMakeLists.txt:
Cannot find source file:
/tmp/vlmc-git/src/vlmc-build/ts/resources-ts.qrc
Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
.hxx .in .txx

cookies commented on 2013-05-11 21:37

Update to v1:0.3304.38c77f5, fixed dependencies and the PKGBUILD is now using pacman 4.1 VCS sources.

ShyPixie commented on 2013-03-05 20:24

vlc already depends on qt4. The most correct is to remove the dependency 'qt'.

felixonmars commented on 2013-02-28 02:40

Please replace `qt` with `qt4` from the depends array.
There's no more a 'qt' package in [testing] (and in the next days in [extra])

Anonymous comment on 2012-04-15 12:04

Thanks for including the patch, shackra!

shackra commented on 2012-04-15 01:24

my patched version of this PKGBUILD solved the problem http://pastie.org/private/rkepvvx0t9hgf1kvnk1vkq
cheers!

shackra commented on 2012-04-15 01:24

my patched version of this PKGBUILD solved the problem http://pastie.org/private/rkepvvx0t9hgf1kvnk1vkq
cheers!

martvefun commented on 2012-04-12 08:31

It fails to build on my machine
[ 46%] Building CXX object src/CMakeFiles/vlmc.dir/Metadata/MetaDataManager.cpp.o
[ 46%] Building CXX object src/CMakeFiles/vlmc.dir/Metadata/MetaDataWorker.cpp.o
/tmp/yaourt-tmp-mart/aur-vlmc-git/src/vlmc-build/src/Metadata/MetaDataWorker.cpp: In member function ‘void MetaDataWorker::metaDataAvailable()’:
/tmp/yaourt-tmp-mart/aur-vlmc-git/src/vlmc-build/src/Metadata/MetaDataWorker.cpp:118:13: error: ‘usleep’ was not declared in this scope
make[2]: *** [src/CMakeFiles/vlmc.dir/Metadata/MetaDataWorker.cpp.o] Error 1
make[1]: *** [src/CMakeFiles/vlmc.dir/all] Error 2
make: *** [all] Error 2

Anonymous comment on 2010-10-02 13:20

I think vlmc does not need the git version of vlc anymore, but I am not sure about it. So if you get errors from that or any other information, please give me a hint so that I can change it to depend again on vlc-git.

hgabreu commented on 2010-09-14 13:07

I confirmed that frei0r-plugins is needed now
and the PKGBUILD does not have dgellow suggestion
I also had the same problem and it solved, but with this warning:
==> WARNING: Package contains reference to $srcdir

AlexP commented on 2010-08-29 20:00

Seems to need "frei0r-plugins" now too.

AsA commented on 2010-08-12 17:48

added cmake to makedepends, thank for reporting

aberkoke commented on 2010-07-20 12:12

Please add cmake to makedepends

AsA commented on 2010-06-28 09:12

dgellow, I trust you on the word, I updated the PKGBUILD corrected (haven't tested it)

dgellow commented on 2010-06-28 08:34

During compilation I had an error with "images/vlmc.png".
Just change "install -Dm 644 images/vlmc.png" in PKGBUILD to "install -Dm 644 $srcdir/vlmc-build/resources/images/vlmc.png" to finish the compilation.

Anonymous comment on 2010-04-05 07:42

Git source has changed over to: git://git.videolan.org/vlmc.git