Package Details: vmware-vsphere-web-client-plugin 5.5.0.1896274-2

Git Clone URL: https://aur.archlinux.org/vmware-vsphere-web-client-plugin.git (read-only)
Package Base: vmware-vsphere-web-client-plugin
Description: Firefox and Chromium plugin, to access virtual machines console from vSphere Web Client. For make package, place VMware-ClientIntegrationPlugin-5.5.0.{your_arch}.bundle to PKGBUILD directory.
Upstream URL: http://www.vmware.com/
Licenses: custom:vmware
Submitter: ReNoM
Maintainer: ReNoM
Last Packager: ReNoM
Votes: 11
Popularity: 0.000051
First Submitted: 2013-04-19 10:26
Last Updated: 2015-06-08 17:17

Dependencies (5)

Required by (0)

Sources (0)

Latest Comments

jtyr commented on 2016-08-04 11:17

The link to the latest bundle was taken from this page:

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2145401

It looks like the CIP (Client Integration Plug-In) component is in the version 6.0.0 and the VMware Remote Console (VMRC) component is in the version 5.5.1. So it should be backward compatible with vSphere 5.5.

I tried to install version 5.5, 6.0 and 6.2 but neither of them works (the black window opens but no login prompt is visible, nor the keyboard/mouse is captured in the window). I'm running Firefox v47.0.1 (from extra/firefox 47.0.1-1) and Java plugin v1.8.0_102 (from extra/icedtea-web 1.6.2-2). Am I missing something?

jtyr commented on 2016-08-03 10:29

Even more recent bundle:

http://vsphereclient.vmware.com/vsphereclient/3/8/6/3/8/4/6/VMware-ClientIntegrationPlugin-6.2.0.x86_64.bundle

ReNoM commented on 2016-06-09 06:38

Does this version of the bundle is backward compatible with version 5.5? If not, I think it would be better to make two separate packages for 5.5 and 6 versions.

infinityz commented on 2016-06-08 18:04

You can download the latest bundle from here:

http://vsphereclient.vmware.com/vsphereclient/1/8/8/7/2/7/0/VMware-ClientIntegrationPlugin-6.0.0.x86_64.bundle

ReNoM commented on 2016-03-28 13:45

Somebody has VMware vSphere version 6.0? Our company uses 5.5 version and I can't update package.

fuero commented on 2015-09-22 15:08

Remote Console doesn't work:
GTK_MODULES="" GTKPATH=/usr/lib/vmware-vmrc/5.5/libconf/lib/gtk-2.0 firefox

(process:6132): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
[fresh] [warning] failed to parse configuration file /home/fuero/.config/freshwrapper.conf, trying /etc/freshwrapper.conf
[fresh] [warning] failed to parse configuration file /etc/freshwrapper.conf
2015-09-22 17:06:32.486 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/VmrcDelegateImpl.cc:268]: startup called
2015-09-22 17:06:32.486 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/VmrcDelegateImpl.cc:285]: VmrcDelegateImpl::Startup(2, 2, advancedConfiguration: )
2015-09-22 17:06:32.486 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/../../plugin-common/utils.h:145]: Advanced config parsed into the features: 0
2015-09-22 17:06:32.486 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/VmrcDelegateImpl.cc:1309]: Forked process for /usr/lib/vmware-vmrc/5.5/vmware-vmrc: 6195
2015-09-22 17:06:32.486 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/VmrcDelegateImpl.cc:1309]: Forked process for /usr/lib/vmware-vmrc/5.5/vmware-vmrc: 0
2015-09-22 17:06:32.995 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/VmrcDelegateImpl.cc:1573]: ReceiveVmrcCommand(initComplete, 0)
2015-09-22 17:06:32.995 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/linux/VmrcDelegateImpl.cc:340]: startup succeeded
2015-09-22 17:06:33.022 [/build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/common/ScriptableObject.cc:580]: Incorrect type passed to Connect as argument 3: 1 instead of 5; at /build/mts/release/bora-2867619/bora/apps/vmplayer/npplugin/common/VmrcPlugin.cc[640]

FF-Jan commented on 2015-09-10 07:42

I have also the issues, that i need the Bundle File.

tmoore commented on 2015-05-15 15:18

==> Continue building vmware-vsphere-web-client-plugin ? [Y/n]
==> ----------------------------------------------------------
==>
==> Building and installing package
==> Making package: vmware-vsphere-web-client-plugin 5.5.0.1896274-2 (Fri May 15 11:17:32 EDT 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> ERROR: VMware-ClientIntegrationPlugin-5.5.0.x86_64.bundle was not found in the build directory and is not a URL.
==> ERROR: Makepkg was unable to build vmware-vsphere-web-client-plugin.
==> Restart building vmware-vsphere-web-client-plugin ? [y/N]

ReNoM commented on 2015-04-10 07:14

I have updated vmware vCenter to last version. Now I don't see "download client integration plug-in" url. When I use old plugin I'm see "The server name could not be resolved" at "launch console" url. I think that this feature were removed :(. Adobe Flash Linux deprecation is the reason?

Ba7a7chy commented on 2015-02-22 08:18

Can someone send me a download link for the bundle file ? I have issues downloading it from our VC.

All comments