Package Details: vmware-workstation14 14.1.7-1

Git Clone URL: https://aur.archlinux.org/vmware-workstation14.git (read-only)
Package Base: vmware-workstation14
Description: The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
Upstream URL: https://www.vmware.com/products/workstation-for-linux.html
Licenses: custom
Conflicts: vmware-modules-dkms, vmware-ovftool, vmware-patch, vmware-systemd-services, vmware-workstation
Provides: vmware-ovftool, vmware-workstation=14.1.7
Submitter: jihem
Maintainer: jihem
Last Packager: jihem
Votes: 1
Popularity: 0.007460
First Submitted: 2018-09-29 14:03
Last Updated: 2019-03-30 15:18

Required by (3)

Sources (25)

Pinned Comments

jihem commented on 2019-03-16 15:23

When you update to version 14.1.6-1, you should see an error telling that some files already exist. This is normal, the reason is that some files previously included in this package are now provided by another package (vmware-keymaps) which is now a dependency.

One solution is to install vmware-keymaps with the option --overwrite usr/lib/vmware/xkeymap/\* before updating vmware-workstation. Another solution is to uninstall your current version of vmware-workstation, then build and install the new version (with vmware-keymaps dependency).

jihem commented on 2018-11-09 18:11

After the first installation, please:

1) reboot or load vmw_vmci and vmmon kernel modules (modprobe -a vmw_vmci vmmon)

2) Enable the services you need:

  • vmware-networks.service: to have network access inside VMs

  • vmware-usbarbitrator.service: to connect USB devices inside VMs

  • vmware-hostd.service: to share VMs on the network

Latest Comments

AngryNapkin commented on 2019-03-23 15:22

Hi, I running a current version of arch, fully updated - kernel 5.0.3-arch1-1-ARCH

I have some issues when installing this and I hope someone here can help. I installed vmware-keymap first (vmware has been removed prior to this install) Then I installed vmware-workstation, let makepkg get all the required dependencies, everything seemed to install just fine. I seem many "warnings" scroll past about permissions ( warning: directory permissions differ on /usr/share/mime/packages/ filesystem: 755 package: 750 ) Many like this one, but different directories. Not sure if this is part of the problem. But then when trying to start vmware I get this:

(process:10329): Gtk-WARNING **: 08:13:22.579: Locale not supported by C library. Using the fallback 'C' locale. cat: /usr/lib/vmware/modules/modules.xml: Permission denied /usr/bin/vmware: line 105: /usr/lib/vmware/bin/vmware: Permission denied

I am able to run as root, but I would rather not.

jihem commented on 2019-03-16 15:23

When you update to version 14.1.6-1, you should see an error telling that some files already exist. This is normal, the reason is that some files previously included in this package are now provided by another package (vmware-keymaps) which is now a dependency.

One solution is to install vmware-keymaps with the option --overwrite usr/lib/vmware/xkeymap/\* before updating vmware-workstation. Another solution is to uninstall your current version of vmware-workstation, then build and install the new version (with vmware-keymaps dependency).

jihem commented on 2018-11-09 18:11

After the first installation, please:

1) reboot or load vmw_vmci and vmmon kernel modules (modprobe -a vmw_vmci vmmon)

2) Enable the services you need:

  • vmware-networks.service: to have network access inside VMs

  • vmware-usbarbitrator.service: to connect USB devices inside VMs

  • vmware-hostd.service: to share VMs on the network

jihem commented on 2018-11-09 18:09

nrth3rnlb: https://superuser.com/questions/1210758/error-one-or-more-pgp-signatures-could-not-be-verified-arch-linux

nrth3rnlb commented on 2018-11-09 15:09

Building ncurses5-compat-libs...
==> Making package: ncurses5-compat-libs 6.1-1 (Fr 09 Nov 2018 16:07:44 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found ncurses-6.1.tar.gz
  -> Found ncurses-6.1.tar.gz.sig
==> Validating source files with md5sums...
    ncurses-6.1.tar.gz ... Passed
    ncurses-6.1.tar.gz.sig ... Skipped
==> Verifying source file signatures with gpg...
    ncurses-6.1.tar.gz ... FAILED (unknown public key 702353E0F7E48EDB)
==> ERROR: One or more PGP signatures could not be verified!