Package Details: vnote 3.15.1-1

Git Clone URL: https://aur.archlinux.org/vnote.git (read-only, click to copy)
Package Base: vnote
Description: A Vim-inspired note-taking application, especially for Markdown.
Upstream URL: https://vnotex.github.io/vnote/en_us/
Keywords: markdown note qt vim
Licenses: LGPL3
Submitter: erk
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 13
Popularity: 0.076870
First Submitted: 2018-05-10 06:37 (UTC)
Last Updated: 2022-11-01 17:12 (UTC)

Latest Comments

1 2 Next › Last »

nahno commented on 2022-11-01 19:54 (UTC)

works! thanks

FabioLolix commented on 2022-11-01 17:16 (UTC) (edited on 2022-11-01 17:17 (UTC) by FabioLolix)

Fixed the pkgbuild, it is an issue which now have all pkgbuilds that use " git submodule update"

https://lists.archlinux.org/archives/list/arch-dev-public@lists.archlinux.org/thread/YYY6KN2BJH7KR722GF26SEWNXPLAANNQ/

nahno commented on 2022-11-01 16:52 (UTC) (edited on 2022-11-01 16:56 (UTC) by nahno)

Hi, unfortunately I'm again unable to build 3.15.1 Does anyone have an idea how to fix it?

==> Starting prepare()...
fatal: transport 'file' not allowed
Unable to fetch in submodule path 'libs/vtextedit'; trying to directly fetch 398ec0f8523d9c74a44cb746b5a1017741521e48:
fatal: transport 'file' not allowed
fatal: Fetched in submodule path 'libs/vtextedit', but it did not contain 398ec0f8523d9c74a44cb746b5a1017741521e48. Direct fetching of that commit failed.
==> ERROR: A failure occurred in prepare().
    Aborting...

Thanks

pingplug commented on 2022-10-19 08:59 (UTC)

maybe add mathjax2,graphviz,plantuml to optional dependencies?

nahno commented on 2022-07-20 15:36 (UTC)

ya :) was too lazy to include .1 version "3.13.1" user version "3.13.1"

FabioLolix commented on 2022-07-20 15:36 (UTC)

3.13.1 is current

nahno commented on 2022-07-20 15:35 (UTC)

I'm at 3.13 now as well. So all fine from my side.

FabioLolix commented on 2022-07-20 15:34 (UTC)

Hello nahno, when you commented on 2022-06-30 locally I already had updated to v3.13.1 and not had any problems

nahno commented on 2022-07-20 15:32 (UTC)

I was able to solve it. There is probably a better way to do it, but here's what I did: in vnote/src/vnote/build/libs/vtextedit/src/editor and vnote/src/vnote/build/libs/vtextedit/src/libs/syntax-highlighting there were many .o files which (I guess) were built with gcc 11. There are probably more files that I don't know of. I uninstalled vnote and did a new git clone. With that I was able to upgrade to 3.13. However, I think a fix could have been forcing all .o files to be recompiled with gcc 12. (Which I did not know how to do.) Hope that helps :)

nahno commented on 2022-06-30 14:28 (UTC) (edited on 2022-06-30 14:28 (UTC) by nahno)

Hi, just tried to upgrade to 3.13. but got this error

lto1: fatal error: bytecode stream in file ‘ksyntaxhighlighting_logging.o’ generated with LTO version 11.0 instead of the expected 12.0
compilation terminated.

Does anyone know how to solve it? Thanks