Package Details: vnote-bin 2.10-1

Git Clone URL: https://aur.archlinux.org/vnote-bin.git (read-only, click to copy)
Package Base: vnote-bin
Description: A Vim-inspired note-taking application that knows programmers and Markdown better
Upstream URL: https://github.com/vnotex/vnote
Keywords: markdown note qt vim
Licenses: MIT
Conflicts: vnote
Replaces: vnote
Submitter: jetm
Maintainer: XelK
Last Packager: XelK
Votes: 4
Popularity: 0.011676
First Submitted: 2018-09-23 15:12
Last Updated: 2020-11-11 16:32

Dependencies (0)

Required by (0)

Sources (1)

Latest Comments

XelK commented on 2020-11-11 16:38

@Vitrum-cnkj34kr8 .SRCINFO updated. Many thanks!

Vitrum-cnkj34kr8 commented on 2020-11-11 15:58

@XelK, could you synchronize, please, versions of the package in PKGBUILD and .SRCINFO? Otherwise, this update will never stop.

makepkg --printsrcinfo > .SRCINFO

If you need to release updated AUR package, then increase pkgrel, so pkgver will be equal to the real version of the application.

pkgver=2.10
pkgrel=2

randomgeek78 commented on 2020-10-17 18:43

To quiet down the install of the package again and again, this is what I had to do - it is a hack but it compensates for the fact that the package version is not the same as the upstream version.

diff --git a/PKGBUILD b/PKGBUILD
index 9c54597..ce9048b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@
 _name=vnote
 _pkgname=VNote
 pkgname=${_name}-bin
-pkgver=2.10
+pkgver=2.10.1
+_pkgver=2.10
 pkgrel=1
 pkgdesc='A Vim-inspired note-taking application that knows programmers and Markdown better'
 arch=('x86_64')
@@ -15,9 +16,9 @@ conflicts=("${_name}")
 replaces=("${_name}")
 options=(!strip)
 _url=https://github.com/vnotex/vnote/
-_binfile=${_pkgname}-${pkgver}-${CARCH}.AppImage
-_buildfile=${_name}-${pkgver}.AppImage
-source=("${_buildfile}::${_url}/releases/download/v${pkgver}/${_binfile}")
+_binfile=${_pkgname}-${_pkgver}-${CARCH}.AppImage
+_buildfile=${_name}-${_pkgver}.AppImage
+source=("${_buildfile}::${_url}/releases/download/v${_pkgver}/${_binfile}")
 sha256sums=('aeee6092ec86c140483db6ad5add53a13c42bf40fb575d7f0b3fc40238b2b9ee')

randomgeek78 commented on 2020-10-15 05:00

There seems to be some problem with the latest update. I am repeatedly getting asked to update even when I have the latest version. Not sure why this happens.

For example-

[user@arch-base ~]$ yay -Q vnote-bin
vnote-bin 2.10-1
[user@arch-base ~]$ yay
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 :: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
:: 1 Packages to upgrade.
1  aur/vnote-bin  2.10-1 -> 2.10.1-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==> ^C

jetm commented on 2019-04-13 14:50

@haowx: Fixed. Thank you for report it.

haowx commented on 2019-04-13 13:19

ERROR: Failure while downloading https://github.com/tamlok/vnote//releases/download/2.4/VNote-2.4-x86_64.AppImage Aborting... makepkg -sic fail, file PKGBUILD needs to be modified

Anonymous comment on 2018-12-29 11:58

VNote updated to v2.2 and added some useful new features. It would be so kind of you if you could update the aur package, too. Having trouble with other vnote aur packages on manjaro about qt5webengine version.

Vitrum-cnkj34kr8 commented on 2018-09-26 18:18

Can't switch keyboard layout (ibus) #289

It was a very nice MD editor, but without multi-language support I had to return to simple text editors T_T