Package Details: vnstatui 0.8.2-3

Git Clone URL: https://aur.archlinux.org/vnstatui.git (read-only, click to copy)
Package Base: vnstatui
Description: Basic web UI that displays traffic graphs from vnstat
Upstream URL: http://bitbucket.org/instarch/vnstat-ui
Licenses: BSD
Submitter: codekoala
Maintainer: codekoala
Last Packager: codekoala
Votes: 4
Popularity: 0.062793
First Submitted: 2017-01-03 23:59 (UTC)
Last Updated: 2021-12-28 12:19 (UTC)

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

MaximGun commented on 2024-01-11 19:59 (UTC) (edited on 2024-01-11 20:01 (UTC) by MaximGun)

Yep, working now. Thanks!

You may want to add gd as a dependency as well, since it's required for vnstati

codekoala commented on 2024-01-11 19:42 (UTC)

@MaximGun until I manage to work on something more intuitive, please check that you have updated the /etc/default/vnstatui file to include the interface(s) you wish to generate graphs for. For example (note the -i flag in the OPTS):

###############################################################################
# Configuration options for vnstatui:
#
#   -b (string): address to use when listening for requests (default "0.0.0.0")
#   -p (int): port to use when accepting new requests (default 7000)
#   -d (string): data directory for vnstat (default "/var/lib/vnstat")
#   -g (string): comma-separated list of graphs to display (default
#                "summary,hourly,daily,monthly,top")
#   -i (string): comma-separated list of interfaces to display graphs for
#
###############################################################################
OPTS="-i=br0,tailscale0"

codekoala commented on 2024-01-11 19:31 (UTC)

@MaximGun thank you for reminding me that there is a problem with this tool! I will try to work on the fix within the next few hours.

MaximGun commented on 2024-01-11 19:29 (UTC) (edited on 2024-01-11 20:05 (UTC) by MaximGun)

Are folks using this successfully? I'm getting the same error as in this issue from upstream (open since 2019): https://bitbucket.org/instarch/vnstat-ui/issues/1/unable-to-create-graph

codekoala commented on 2021-12-28 12:20 (UTC)

@syslino thanks for the report! I have updated the build to no longer require glide. It should work a bit better for you now :)

syslino commented on 2021-12-27 22:46 (UTC) (edited on 2021-12-27 22:48 (UTC) by syslino)

make: the '-j' option requires a positive integer argument
go-bindata -ignore=\.swp templates/...
go build -ldflags '-s -X main.VERSION=0.8.2 -X main.BUILD=g6bb9ad7' -o vnstatui
go: cannot find main module, but found glide.lock in     /tmp/makepkg/vnstatui/src/go/src/bitbucket.org/instarch/vnstat-ui
to create a module there, run:
go mod init
make: *** [Makefile:5: build] Error 1

codekoala commented on 2018-12-07 22:57 (UTC)

@simona I've just pushed some changes to the PKGBUILD after experimenting on a "fresh" Arch system. Would you try again and report any errors please?

codekoala commented on 2018-12-07 22:09 (UTC)

@simona I was able to build it locally just now, so I would like to figure out what I need to adjust in the PKGBUILD to get it to build for you. What errors do you see when you try to build this package?

simona commented on 2018-12-07 21:23 (UTC)

do not compile