Package Details: vo-aacenc 0.1.3-1

Git Clone URL: https://aur.archlinux.org/vo-aacenc.git (read-only)
Package Base: vo-aacenc
Description: VisualOn Advanced Audio Coding (AAC) encoder
Upstream URL: http://sourceforge.net/projects/opencore-amr/
Licenses: Apache
Submitter: DrZaius
Maintainer: justin8
Last Packager: justin8
Votes: 60
Popularity: 1.670609
First Submitted: 2011-04-13 18:04
Last Updated: 2015-07-08 22:08

Latest Comments

DrZaius commented on 2012-10-24 02:58

Works for me in ffmpeg with the addition of "vo-aacenc" to depends and "--enable-libvo-aacenc --enable-version3" to configure. If you can provide enough information so this can be easily duplicated then I can look into it more.

ekce commented on 2012-10-24 02:40

You do need --enable-shared in order for ffmpeg to compile with --enable-libvo-aacenc. I tried to compile several times and kept getting a build error late in the compile process until I changed it to shared. This may be the case for other libraries like vo-amrwbenc and fdk-aac but I have not tested building with them yet. It is noteworthy that vo-aacenc and vo-amrwbenc are both Apache License Version 2, which means that they may be bundle-able (unlike the non-free fdk-aac).

daimonion commented on 2012-02-25 11:19

Again, why did you disable shared lib?!

DrZaius commented on 2011-07-07 00:44

Sorry, but you will have to add "--enable-shared" to the PKGBUILD locally if you want it for your modified/mixed/personal mplayer2 package. The good news is that vo-aacenc doesn't seem to have many updates upstream.

sl1pkn07 commented on 2011-06-26 22:12

mixed AUR package (mplayer2-git) with my own package (only add install ffmpeg (now libav) from mplayer2 git repository)

DrZaius commented on 2011-06-26 19:09

Which mplayer2 package? From AUR, ABS, your own package?

sl1pkn07 commented on 2011-06-26 08:46

without shared mplayer2 (with ffmpeg/libav) not compile (or enable shared or active -fPIC, i prefer active shared)

DrZaius commented on 2011-06-25 21:35

Why do you want this this shared? I'm receptive to feature requests, but the reason why you want it to be shared would be nice.

sl1pkn07 commented on 2011-06-25 20:26

enable shared plox

DrZaius commented on 2011-06-23 03:47

Removed gcc-libs as dependency (nothing should have gcc-libs listed in depends). Updated PKGBUILD to use package() function.

DrZaius commented on 2011-05-05 01:58

Updated to 0.1.1.