Package Details: vobsub2srt-git v1.0pre7.11.g0ba6e25-1

Git Clone URL: https://aur.archlinux.org/vobsub2srt-git.git (read-only, click to copy)
Package Base: vobsub2srt-git
Description: Convert IDX/SUB subtitles into SRT text subtitles
Upstream URL: https://github.com/ruediger/VobSub2SRT
Licenses: GPL
Submitter: None
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 32
Popularity: 0.000008
First Submitted: 2011-06-20 16:38
Last Updated: 2019-02-10 14:01

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3

Anonymous comment on 2012-06-11 19:52

@swanson: edit your file .idx like this: "id: --, index: 0" → "id: en, index: 0" and try:
vobsub2srt --lang eng --tesseract-data /usr/share/tessdata --blacklist '|\/`_~<>' filename.idx

swanson commented on 2012-06-11 08:20

I get a lot of blank lines, just timestamps. When dumping images all *.pgm images seem ok in picturevier. Some 5 % of the lines are there the rest are empty with time stamps only in the .srt. This is from several idx/sub files with only english in them, so character reading and conversion should be the simplest of all. I'm using 'vobsub2srt --lang en FILENAME'. This has been going on for a couple of months now, can't say when it started. Here's snip of an idx;"# VobSub index file, v7 (do not modify this line!)
size: 720x576
org: 0, 0
scale: 100%, 100%
alpha: 100%
smooth: OFF
fadein/out: 0, 0
align: OFF at LEFT TOP
time offset: 0
forced subs: OFF
palette: 000060, 1f1f1f, 434320, 67671f, b0b020, ebeb20, 8c8c1f, d5d51f, 404040, 626262, 848484, a6a6a6, c8c8c8, eaeaea, 1e4242, 1e6866
custom colors: OFF, tridx: 1000, colors: 600000, 101010, ffffff, a9a9a9
langidx: 0
id: --, index: 0

timestamp: 00:00:26:814, filepos: 000000000
... "

The only errors I get are:
ERROR in id: --, index: 0
No matching VOBSUB language found!
No matching language for 'en' found! (Trying to use default)

And the srt file looks like this snippet;
1
00:00:26,814 --> 00:00:30,375



2
00:00:30,374 --> 00:00:33,617



3
00:00:33,614 --> 00:00:36,618


(snip)

swanson commented on 2012-06-11 08:13

I get a lot of blank lines, just timestamps. When dumping images all *.pgm images seem ok in picturevier. Some 5 % of the lines are there the rest are empty with time stamps only in the .srt. This is from several idx/sub files with only english in them, so character reading and conversion should be the simplest of all. I'm using 'vobsub2srt --lang en FILENAME'. This has been going on for a couple of months now, can't say when it started. Here's snip of an idx;"# VobSub index file, v7 (do not modify this line!)
size: 720x576
org: 0, 0
scale: 100%, 100%
alpha: 100%
smooth: OFF
fadein/out: 0, 0
align: OFF at LEFT TOP
time offset: 0
forced subs: OFF
palette: 000060, 1f1f1f, 434320, 67671f, b0b020, ebeb20, 8c8c1f, d5d51f, 404040, 626262, 848484, a6a6a6, c8c8c8, eaeaea, 1e4242, 1e6866
custom colors: OFF, tridx: 1000, colors: 600000, 101010, ffffff, a9a9a9
langidx: 0
id: --, index: 0

timestamp: 00:00:26:814, filepos: 000000000
... "

Anonymous comment on 2012-03-31 21:09

@Huulivoide: PKGBUILD corrected. Thanks.

Huulivoide commented on 2012-03-31 12:50

'|| return 1' statements are deprecated, please remove them from the PKGBUILD

Anonymous comment on 2011-11-21 05:23

Thanks gillux.
PKGBUILD updated with the patch.

gillux commented on 2011-11-21 01:53

Quick fix for the Tesseract_LIBRARIES error.

Edit /tmp/yaourt-tmp-*/aur-vobsub2srt-git/src/VobSub2SRT/CMakeModules/FindTesseract.cmake
and replace the line:

find_library(Tesseract_LIBRARIES NAMES tesseract_full tesseract_api

by:

find_library(Tesseract_LIBRARIES NAMES tesseract

garion, please make a patch!

Anonymous comment on 2011-11-20 21:00

I have the same error. The pb is due to the new version of tesseract.
I will try to report the pb if I have the time. Nevertheless, you can use the old version of tesseract (3.00) available here:
http://arm.konnichi.com/search/

elifarley commented on 2011-11-20 12:48

Got an error:

[...]
-- Found Tesseract: Tesseract_LIBRARIES-NOTFOUND;/usr/lib/libtiff.so
-- vobsub2srt version: ca53a18
-- dpkg not found: No package generation.
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Tesseract_LIBRARIES (ADVANCED)
linked by target "vobsub2srt" in directory /var/abs/local/vobsub2srt-git/src/VobSub2SRT/src

-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().