Package Details: vobsub2srt-git v1.0pre6.62.g9283345-1

Git Clone URL: https://aur.archlinux.org/vobsub2srt-git.git (read-only)
Package Base: vobsub2srt-git
Description: Convert IDX/SUB subtitles into SRT text subtitles
Upstream URL: https://github.com/ruediger/VobSub2SRT/blob/master/README.org
Licenses: GPL
Submitter: None
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 27
Popularity: 0.003210
First Submitted: 2011-06-20 16:38
Last Updated: 2015-06-08 19:06

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Anonymous comment on 2015-05-10 09:09

Hello,

Sorry for the delay.
As I am leaving ArchLinux, feel free to adopt this package ;)

Best Regards.

Anonymous comment on 2014-10-05 20:55

@cfinnberg: Thanks for signal. Dependencies removed.

cfinnberg commented on 2014-10-05 19:48

Why are ffmpeg and mplayer dependencies? It seems to work ok for me without them. From the project readme file I get that it uses/copies code from those programs but I don´t see that it actually needs them.

stqn commented on 2013-07-26 19:45

tesseract-data-eng is already an optdepend of tesseract.

mamamia88 commented on 2013-07-26 18:00

Needs tesseract-data-eng for english and other data for other languages i would presume. Maybe add those as optdepends? I mean the app won't even work without them so they aren't really optional but if you are a noob like me you need them.

Anonymous comment on 2013-04-13 07:24

PKGBUILD updated with the new CVS PKGBUILD features:
https://wiki.archlinux.org/index.php/Arch_CVS_%26_SVN_PKGBUILD_guidelines#Git

You should update manually due to the new format of the package version.

Anonymous comment on 2013-02-26 21:44

@Marty_Stoopid: PKGBUILD corrected.

Funkin-Stoopid commented on 2013-02-26 15:23

I have this error:
install: cannot stat ‘usr/local/INSTALL_MAN_DIR/vobsub2srt.1.gz’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build vobsub2srt-git

Anonymous comment on 2012-07-28 08:33

@swanson: Thanks for reporting this bug. It seems that it is a tesseract bug.
There has been reported on the bugs tracking: https://bugs.archlinux.org/task/30882

swanson commented on 2012-07-28 07:32

New error; "vobsub2srt: error while loading shared libraries: libwebp.so.2: cannot open shared object file: No such file or directory
"

Tried to reinstall libwebp and then leptonica but no success. Resinstalled tesseract too and then tried to reinstall vobsub2srt but now it won't even build. Error: "Linking CXX executable ../bin/vobsub2srt
/usr/bin/ld: warning: libwebp.so.2, needed by /usr/lib/gcc/i686-pc-linux-gnu/4.7.1/../../../libtesseract.so, not found (try using -rpath or -rpath-link)"

I'm sure it has to do with the arch move of glibc (/lib). Did do sudo ldconfig as well.

swanson commented on 2012-07-28 07:20

New error; "vobsub2srt: error while loading shared libraries: libwebp.so.2: cannot open shared object file: No such file or directory
"

Tried to reinstall libwebp and then leptonica but no success. I'm sure it has to do with the arch move of glibc (/lib). Did do sudo ldconfig as well.

Anonymous comment on 2012-06-20 19:25

@swanson: Well... If you want, you can send me the idx/sub files by e-mail (it is in the PKGBUILD).
Nevertheless, I am not a developper of vobsub2srt, just an user. So, I am not sure I can help you,
but I can try... You can also report this issue : https://github.com/ruediger/VobSub2SRT/issues

swanson commented on 2012-06-20 08:56

@Garion; did as you suggested but same problem. Even with the update today. Must conclude that it is bad .sub files? Error;
Selected VOBSUB language: 0 language: en
SPUasm: invalid fragment
spudec: Error determining control type 0xb1. Skipping -6 bytes.
SPUasm: packet too short
SPUasm: invalid fragment
SPUasm: invalid fragment
...
and more of the same. Still a lot of empty lines - timestamps only ok. Even reinstalled tesseract!

Anonymous comment on 2012-06-19 20:01

@felixonmars: PKGBUILD corrected. Thanks.

felixonmars commented on 2012-06-19 09:30

does not package() now:
install: cannot stat ‘usr/local/share/man/man1/vobsub2srt.1’: No such file or directory

Anonymous comment on 2012-06-11 19:52

@swanson: edit your file .idx like this: "id: --, index: 0" → "id: en, index: 0" and try:
vobsub2srt --lang eng --tesseract-data /usr/share/tessdata --blacklist '|\/`_~<>' filename.idx

swanson commented on 2012-06-11 08:20

I get a lot of blank lines, just timestamps. When dumping images all *.pgm images seem ok in picturevier. Some 5 % of the lines are there the rest are empty with time stamps only in the .srt. This is from several idx/sub files with only english in them, so character reading and conversion should be the simplest of all. I'm using 'vobsub2srt --lang en FILENAME'. This has been going on for a couple of months now, can't say when it started. Here's snip of an idx;"# VobSub index file, v7 (do not modify this line!)
size: 720x576
org: 0, 0
scale: 100%, 100%
alpha: 100%
smooth: OFF
fadein/out: 0, 0
align: OFF at LEFT TOP
time offset: 0
forced subs: OFF
palette: 000060, 1f1f1f, 434320, 67671f, b0b020, ebeb20, 8c8c1f, d5d51f, 404040, 626262, 848484, a6a6a6, c8c8c8, eaeaea, 1e4242, 1e6866
custom colors: OFF, tridx: 1000, colors: 600000, 101010, ffffff, a9a9a9
langidx: 0
id: --, index: 0

timestamp: 00:00:26:814, filepos: 000000000
... "

The only errors I get are:
ERROR in id: --, index: 0
No matching VOBSUB language found!
No matching language for 'en' found! (Trying to use default)

And the srt file looks like this snippet;
1
00:00:26,814 --> 00:00:30,375



2
00:00:30,374 --> 00:00:33,617



3
00:00:33,614 --> 00:00:36,618


(snip)

swanson commented on 2012-06-11 08:13

I get a lot of blank lines, just timestamps. When dumping images all *.pgm images seem ok in picturevier. Some 5 % of the lines are there the rest are empty with time stamps only in the .srt. This is from several idx/sub files with only english in them, so character reading and conversion should be the simplest of all. I'm using 'vobsub2srt --lang en FILENAME'. This has been going on for a couple of months now, can't say when it started. Here's snip of an idx;"# VobSub index file, v7 (do not modify this line!)
size: 720x576
org: 0, 0
scale: 100%, 100%
alpha: 100%
smooth: OFF
fadein/out: 0, 0
align: OFF at LEFT TOP
time offset: 0
forced subs: OFF
palette: 000060, 1f1f1f, 434320, 67671f, b0b020, ebeb20, 8c8c1f, d5d51f, 404040, 626262, 848484, a6a6a6, c8c8c8, eaeaea, 1e4242, 1e6866
custom colors: OFF, tridx: 1000, colors: 600000, 101010, ffffff, a9a9a9
langidx: 0
id: --, index: 0

timestamp: 00:00:26:814, filepos: 000000000
... "

Anonymous comment on 2012-03-31 21:09

@Huulivoide: PKGBUILD corrected. Thanks.

Huulivoide commented on 2012-03-31 12:50

'|| return 1' statements are deprecated, please remove them from the PKGBUILD

Anonymous comment on 2011-11-21 05:23

Thanks gillux.
PKGBUILD updated with the patch.

gillux commented on 2011-11-21 01:53

Quick fix for the Tesseract_LIBRARIES error.

Edit /tmp/yaourt-tmp-*/aur-vobsub2srt-git/src/VobSub2SRT/CMakeModules/FindTesseract.cmake
and replace the line:

find_library(Tesseract_LIBRARIES NAMES tesseract_full tesseract_api

by:

find_library(Tesseract_LIBRARIES NAMES tesseract

garion, please make a patch!

Anonymous comment on 2011-11-20 21:00

I have the same error. The pb is due to the new version of tesseract.
I will try to report the pb if I have the time. Nevertheless, you can use the old version of tesseract (3.00) available here:
http://arm.konnichi.com/search/

elifarley commented on 2011-11-20 12:48

Got an error:

[...]
-- Found Tesseract: Tesseract_LIBRARIES-NOTFOUND;/usr/lib/libtiff.so
-- vobsub2srt version: ca53a18
-- dpkg not found: No package generation.
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Tesseract_LIBRARIES (ADVANCED)
linked by target "vobsub2srt" in directory /var/abs/local/vobsub2srt-git/src/VobSub2SRT/src

-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().