Package Details: voiphopper 2.04-1

Git Clone URL: https://aur.archlinux.org/voiphopper.git (read-only)
Package Base: voiphopper
Description: A security validation tool that tests to see if a PC can mimic the behavior of an IP Phone. It rapidly automates a VLAN Hop into the Voice VLAN.
Upstream URL: http://voiphopper.sourceforge.net/
Licenses: GPLv3
Submitter: fnord0
Maintainer: bidulock
Last Packager: bidulock
Votes: 5
Popularity: 0.003212
First Submitted: 2010-08-23 12:41
Last Updated: 2015-07-14 06:26

Latest Comments

hisi commented on 2016-02-26 14:28

Does not build anymore as it tries to do touch stuff in $pkgdir during build() instead of package().

paraxor commented on 2013-05-12 15:20

I have adopted and updated this package.

oliv commented on 2013-03-06 14:58

Version 2.04 released.

You need to patch dhcpclient.h to build successfully the package:

sed -i "s%<linux/if_ether.h>%<netinet/if_ether.h>%" -i src/dhcpclient.h
sed -i "s%<linux/if_tr.h>%<netinet/if_tr.h>%" -i src/dhcpclient.h

oliv commented on 2013-03-06 14:55

Version 2.04 released.

You need to patch dhcpclient.h to build successfully the package:

sed -i "s%<linux/if_ether.h>%<netinet/if_ether.h%" -i src/dhcpclient.h

oliv commented on 2011-08-17 14:57

Version 2.00 has been released.

To build you can change the PKGBUILD:

build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr --mandir=/usr/share/man --libexecdir=/usr/lib || return 1
make || return 1
}

package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install || return 1

install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/voiphopper/LICENSE || return 1
}

P.S. I don't know where is the MAN page in this version. Maybe they considered voiphopper -h is sufficient...;