Package Details: volti 0.2.3-5

Git Clone URL: https://aur.archlinux.org/volti.git (read-only)
Package Base: volti
Description: GTK+ mixer application for controlling alsa audio volume from system tray
Upstream URL: https://github.com/gen2brain/volti
Licenses: GPL3
Submitter: alium
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 78
Popularity: 0.488456
First Submitted: 2010-01-12 08:55
Last Updated: 2016-04-10 19:23

Dependencies (4)

Required by (0)

Sources (2)

Latest Comments

carstene1ns commented on 2016-04-10 19:25

@arruhs: Sorry for the delay... This version check was unneeded and has been removed upstream.
I have applied the patch now, this should let it start again.

arruhs commented on 2016-03-24 14:48

installed succesfully but don't works."This program needs dbus-python 0.80.0 or higher

Exiting" Weird. python2-dbus 1* installed

confusedfla commented on 2015-04-14 05:56

sry - ignore my comment about python2-pyalsaaudio, it was a horrible connection. The upstream url change is still valid tough ;-)

confusedfla commented on 2015-04-14 05:54

==> Downloading python2-pyalsaaudio PKGBUILD from AUR...
==> ERROR: python2-pyalsaaudio not found in AUR.

and the URL changed to https://github.com/gen2brain/volti

carstene1ns commented on 2014-12-30 23:04

@kiarash: BadAccess generally means that the hotkey is already assigned[1]. Do you have any other software running that might use the configured keys? Depending on the keys you want to use, this includes your window manager, browser, music player, etc. I suggest to close/reconfigure this software first and to try other hotkeys.
Also, install 'python2-xlib-svn', it includes some bugfixes as the last release is from 2009. If the problem persists, you can file a bug against volti upstream or ask for help on the forums.

[1]: http://stackoverflow.com/a/22727832

kiarash commented on 2014-12-30 13:48

Hi. My keyboard shortcuts don't work. I get this error on startup.
<class 'Xlib.error.BadAccess'>: code = 10, resource_id = 157, sequence_number = 10, major_opcode = 33, minor_opcode = 0
X protocol error:
<class 'Xlib.error.BadAccess'>: code = 10, resource_id = 157, sequence_number = 11, major_opcode = 33, minor_opcode = 0
X protocol error:
<class 'Xlib.error.BadAccess'>: code = 10, resource_id = 157, sequence_number = 12, major_opcode = 33, minor_opcode = 0

carstene1ns commented on 2014-06-02 18:22

Adopted and fixed.
FYI: I changed optdep python2-xlib-svn → python2-xlib, as it is in the repos and provides the python2 version again.

carstene1ns commented on 2014-05-23 19:19

Adopted and fixed.

carstene1ns commented on 2014-05-17 15:52

The optdepends field should be changed as this is a python2 tool: python-xlib-svn → python2-xlib-svn
Thanks!

willemw commented on 2013-07-12 11:07

The 'sed ...' line is not necessary. Setup.py already does this.

gothmog.todi commented on 2013-06-08 09:13

@ben0mega: I had the same problem, can be fixed by using https://aur.archlinux.org/packages/python2-xlib-svn/ instead.

ben0mega commented on 2013-06-05 19:12

I believe python-xlib is no longer shipping python2 xlib libraries (or it may be that my install is messed up).

Anonymous comment on 2012-09-13 19:05

Fix for dbus-python:
--- PKGBUILD 2011-02-21 10:34:14.000000000 +0100
+++ PKGBUILD-mod 2012-09-13 20:58:59.121242168 +0200
@@ -7,7 +7,7 @@
arch=('any')
url="http://code.google.com/p/volti/"
license=('GPL3')
-depends=('pygtk' 'python-pyalsaaudio' 'dbus-python')
+depends=('pygtk' 'python-pyalsaaudio' 'python-dbus-common')
optdepends=('python-xlib: Multimedia keys support')
source=(http://volti.googlecode.com/files/volti-$pkgver.tar.gz)
md5sums=('f6e934527a4838058ece4de28433a564')

Anonymous comment on 2011-04-21 19:54

Should modify PKGBUILD to add depends=('librsvg') for the mixer GUI

Aectann commented on 2010-10-30 12:29

To properly build with python2 you need:

new volti PKGBUILD: http://aur.pastebin.com/b8YyTEgK
new python-pyalsaaduio PKGBUILD: http://aur.pastebin.com/WrDvWjY1

grubber commented on 2010-10-20 10:31

Also:

diff -ur volti-0.2.2.orig/volti volti-0.2.2/volti
--- volti-0.2.2.orig/volti 2010-10-20 12:25:26.000000000 +0200
+++ volti-0.2.2/volti 2010-10-20 12:25:34.000000000 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2

# -*- coding: utf-8 -*-

diff -ur volti-0.2.2.orig/volti-mixer volti-0.2.2/volti-mixer
--- volti-0.2.2.orig/volti-mixer 2010-10-20 12:25:27.000000000 +0200
+++ volti-0.2.2/volti-mixer 2010-10-20 12:25:39.000000000 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2

# -*- coding: utf-8 -*-

cdemoulins commented on 2010-10-19 11:58

Need a little fix with last python update:
use python2 instead of python to exec setup.py

And i suggest you to use arch=('any')

alium commented on 2010-09-28 18:55

I'm going away for a longer period of time. I can no longer care about the PKGBUILD :(

alium commented on 2010-09-03 14:03

now with internal mixer :-)

na12 commented on 2010-07-19 12:41

I get
volti.main.toggle_mixer: [Errno 13] Permission denied
when I try to click Show Mixer,what is the problem?