Package Details: voltron-git 20170212-2

Git Clone URL: https://aur.archlinux.org/voltron-git.git (read-only)
Package Base: voltron-git
Description: UI for GDB, LLDB and Vivisect's VDB
Upstream URL: https://github.com/snare/voltron
Licenses: beerware
Conflicts: python-ptrace, voltron
Provides: voltron
Submitter: atweiden
Maintainer: atweiden (Zigsaz, potatoe)
Last Packager: atweiden
Votes: 4
Popularity: 0.001325
First Submitted: 2015-03-09 04:56
Last Updated: 2017-03-12 17:09

Latest Comments

potatoe commented on 2017-03-08 03:39

In case anyone else runs into this: Installing python-ptrace from the AUR breaks voltron, if they're both installed to /usr/. /usr/bin/voltron tries to "import gdb" to test if it's running inside gdb or standalone. Except now there's python-ptrace's /usr/bin/gdb.py sitting beside it, which will always be imported when standalone and is not the internal GDB API voltron is expecting, causing unhandled exceptions. If you want both packages installed as packages, you can either edit python-ptrace to rename /usr/bin/gdb.py or edit voltron to install voltron elsewhere.

potatoe commented on 2017-02-15 04:57

voltron seems to have added a requirement for the pysigset module, https://pypi.python.org/pypi/pysigset/

The gdb import continues to work, but the client script won't run without it.

alex.forencich commented on 2016-04-12 18:22

Getting the following error:

-> Fixing placement of dbgentry.py...
mv: cannot stat '/tmp/yaourt-tmp-alex/aur-voltron-git/pkg/voltron-git/usr/dbgentry.py': No such file or directory
==> ERROR: A failure occurred in package().

aperez commented on 2016-01-08 21:06

I think there is a dependency missing on “python-flask-restful”. Without that package installed, GDB will print out this error message:

Exception <class 'ImportError'> raised while loading Voltron: No module named 'flask_restful'
/home/aperez/.gdbinit:5: Error in sourced command file:
Undefined command: "voltron". Try "help".

Please consider adding it in “depends” :-)

bchretien commented on 2015-11-18 04:31

This needs to be updated for Python 3.5.

atweiden commented on 2015-09-18 23:20

Just made you a co-maintainer. Feel free to upload a split package.

Zigsaz commented on 2015-09-18 22:06

This package only works with python3.x, but lldb seems to use python2.x as its interpreter. I've created AUR packages python2-rl, python2-scruffy, and voltron-python2-git to allow an install in a python2.x environment (the other dependencies are already packaged).
I realize after the fact that I probably should have asked if you could upgrade said packages to support both, but oh well.

Also, I will be submitting a Pull Request upstream to clean up the way setup.py installs voltron as currently the tests/ and examples/ directories conflict with other site-packages. dbgentry.py will (hopefully) also be moved to be in the package itself.

Thanks.