Package Details: vpn-unlimited 4.23-3

Git Clone URL: https://aur.archlinux.org/vpn-unlimited.git (read-only)
Package Base: vpn-unlimited
Description: VPN Unlimited client application
Upstream URL: https://www.vpnunlimitedapp.com
Keywords: unlimited-vpn unlimitedvpn vpn vpn-unlimited vpnunlimited
Licenses: custom:"Copyright (c) 2017 KeepSolid Inc."
Submitter: aytekinar
Maintainer: aytekinar
Last Packager: aytekinar
Votes: 4
Popularity: 0.213871
First Submitted: 2017-07-24 14:08
Last Updated: 2018-10-23 08:22

Latest Comments

1 2 3 Next › Last »

tri1976 commented on 2018-11-16 13:59

I remove this package, clean orphan packages, and then reinstall it and it's working. Thanks for maintaining this.

aytekinar commented on 2018-11-07 08:35

@tri1976, it seems to me that you are still using the previous version of this package. Have you tried updating it? I have dropped the dependency on libcurl-openssl-1.0, and replaced it with libcurl-compat from community. Even so, you are having a warning from the curl library, which I believe does not have much to do with the memory corruption error you are experiencing. Please try upgrading this package, and using sudo pacman -Rscn $(pacman -Qtdq) (on bash) to get rid of the orphan packages from your system. Otherwise, I cannot help much, as the package seems to be running for me and a bunch of other people in this thread.

tri1976 commented on 2018-11-06 21:57

I updated Arch yesterday and it broke this program. It required qt5-webengine now. I got the following messages when trying to run it

/usr/share/vpn-unlimited/vpn-unlimited: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/lib/libvpnu_private_sdk.so.1) Translation file loaded: ":/translations/translations/VPN_Unlimited_English.qm" Translation file loaded: ":/translations/translations/VPN_SDK_English.qm" malloc(): memory corruption

Any idea how to fix it?

aytekinar commented on 2018-10-30 11:52

@Ray, sorry for the inconvenience.

If you followed the posts here, you must have realized that I needed to bump the package version due to the consistent out-of-date flagging of the package from users. Moreover, this application seems to be a bit fragile to install on Arch Linux. I must admit that I am not an expert in Linux systems in general, and definitely not in Arch Linux, either. I needed to write a PKGBUILD file for my own use, and I just wanted to share it here on AUR, when I noticed that it was working on my system. Below, you would see a lot of posts complaining that the package results in crashes of different sort for different users. What I did when I created this PKGBUILD was to try to translate the Ubuntu dependencies to those available in Arch Linux, and wrap them inside an Arch-friendly PKGBUILD file.

Having said, both this version and the previous one, 4.23-2, do work on my machines. I think you can follow one of the two alternatives:

  1. If you have not already cleared your pacman cache, you could try searching for the corresponding file under /var/cache/pacman/pkg. Then, pacman -U <filename_of_the_version_you_want> should downgrade the package back to what was working on your machine,
  2. You could simply download this package and build from the previous tag. To do so, try the following:
git clone https://aur.archlinux.org/vpn-unlimited /tmp/vpn-unlimited
cd /tmp/vpn-unlimited
git checkout -b install b8c30453eda69a5976de04ee280bac67bd08969e
makepkg --syncdeps --clean --cleanbuild --rmdeps --install

Upon succesful build of the package, pacman should ask you if you would like to downgrade. Later, you can add this package to the IgnorePkg line of /etc/pacman.conf to disable updates to the package until you choose to do so.

P.S: Both this version and the previous version, i.e., 4.23-2, are the same versions of the upstream VPN Unlimited App. You should still be fine with the previous version of this package.

alkalien commented on 2018-10-28 21:28

@aytekinar, Not bumping the version numbers when the package itself has been changed is indeed stupid. That was my bad, I am new to AUR in general, so I thought mere flagging would have worked.

Ray commented on 2018-10-27 07:25

I installed this package to update my previous vpn-unlimited 4.23-2 package that I had successfully installed from AUR. The new version will not run at all. VPN Unlimited starts, but crashes immediately. Any suggestions on how to fix this? Where can I find the previous version? I can reinstall that.

If it works, I'll most certainly avoid updating something that isn't broken

aytekinar commented on 2018-10-23 18:04

@pizzapower, I have already updated the package. That line has been removed and the dependency on libcurl-openssl-1.0 has been replaced with libcurl-compat provided by the community.

pizzapower commented on 2018-10-23 17:59

How I fixed the latest problem:

  • edit /usr/bin/vpn-unlimited (it's a shell script)

  • comment the second line

#export LD_PRELOAD=libcurl-openssl-1.0.so

Now it works.

aytekinar commented on 2018-10-23 08:29

@alkalien, you could have written the reason(s) in your very first message.

Obviously, the developers do not want to give support for Linux distributions other than the Ubuntu family. When I use some version of the package, and it works, and it does not show a "new version" when I check for updates, I see no reason to update the package. According to your diff, they have changed the dependency, which could have been enough for them to bump their versions in some way... such as, e.g., semver. Where do we draw the line? If they release Ubuntu XYZ deb files with the same version every week, should I need to follow this upstream? I just fire up the package and check for updates there.

Anyways, the package is updated. However, us being on a rolling release does not have anything to do with this package. When I look at their version numbers and check the program's own "Check for update" functionality, I can clearly see that both Trusty and Bionic versions are the same, which pisses me off and which was the main reason for me to stick with the version already working on my machine. If the upstream cares enough, they can bump their version and let us know through the package rather than sharing this info privately via emails.

alkalien commented on 2018-10-21 22:47

@aytekinar they are not the same, the package build you provide doesn't work on my machine, but at the same time the 4.23-bionic installed via debtap works flawlessly, i e-mailed the developers and they too advised me not to install the older 4.23-trusty.

And since we are all on a rolling release distro, i don't see any reason not to update it, which is why i have flagged the package as out-of-date, why do you want to stick with the older trusty version, any reasons in particular ??

----START-DIFF----

--- /tmp/tmpdiff/control_old    Mon Oct 22 04:26:53 2018
+++ /tmp/tmpdiff/control_new    Mon Oct 22 04:27:20 2018
@@ -1,12 +1,12 @@

-Depends: libc6 (>= 2.9), libqt5network5 (>= 5.2.1), libqt5script5 (>= 5.2.1), libqt5widgets5 (>= 5.2.1), libqt5core5a (>= 5.2.1), libqt5gui5 (>= 5.2.1), libqt5concurrent5 (>= 5.2.1), libqt5webkit5 (>= 5.1.1), libstdc++6 (>= 4.4.15), zlib1g (>=1.2.0), libcurl3 (>=7.22.0), libc-ares2(>=1.10.0), resolvconf, liblzo2-2, libssl1.1 | libssl1.0.0 | libssl1.0.2, iproute, net-tools, strongswan, libstrongswan-extra-plugins | libcharon-extra-plugins | strongswan-plugin-eap-mschapv2, openvpn, libcharon-extra-plugins | strongswan-plugin-eap-mschapv2
+Depends: libc6 (>= 2.9), libqt5network5 (>= 5.2.1), libqt5script5 (>= 5.2.1), libqt5widgets5 (>= 5.2.1), libqt5core5a (>= 5.2.1), libqt5gui5 (>= 5.2.1), libqt5concurrent5 (>= 5.2.1), libqt5webkit5 (>= 5.1.1), libstdc++6 (>= 4.4.15), zlib1g (>=1.2.0), libcurl4, libqt5webengine5, libqt5webenginewidgets5, libc-ares2(>=1.10.0), resolvconf, liblzo2-2, libssl1.1 | libssl1.0.0 | libssl1.0.2, iproute2, net-tools, strongswan, libstrongswan-extra-plugins | libcharon-extra-plugins | strongswan-plugin-eap-mschapv2, openvpn, libcharon-extra-plugins | strongswan-plugin-eap-mschapv2

-Installed-Size: 17280
+Installed-Size: 17664

----END-DIFF----