Package Details: vpn-unlimited 4.23-3

Git Clone URL: https://aur.archlinux.org/vpn-unlimited.git (read-only)
Package Base: vpn-unlimited
Description: VPN Unlimited client application
Upstream URL: https://www.vpnunlimitedapp.com
Keywords: unlimited-vpn unlimitedvpn vpn vpn-unlimited vpnunlimited
Licenses: custom:"Copyright (c) 2017 KeepSolid Inc."
Submitter: aytekinar
Maintainer: aytekinar
Last Packager: aytekinar
Votes: 6
Popularity: 0.151307
First Submitted: 2017-07-24 14:08
Last Updated: 2018-10-23 08:22

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

alkalien commented on 2018-09-29 19:48

@aytekinar, could you update this package so as to be in sync with the 4.23 bionic release ?

aytekinar commented on 2018-07-09 09:07

Hi @victorbrca. Unfortunately, I do not seem to have such an error. I do not blindly push changes to AUR; instead, I first install the latest version on my machine, try connecting to different servers via VPN Unlimited, and finally push the version to AUR. On my system with Linux KTH-5435 4.17.4-1-ARCH #1 SMP PREEMPT Tue Jul 3 15:45:09 UTC 2018 x86_64 GNU/Linux and i3-wm 4.15-1, the program is running properly. I have just tested it. Unfortunately, because I cannot reproduce the same problem, I cannot help you in this case. By the way, when debugging, I noticed that I needed to add lsb-release as a dependency, which seems to be already installed on your machine. I will push the pkgrel=2 version to AUR soon, which I doubt would help you in your specific issue. Sorry...

victorbrca commented on 2018-07-08 03:29

Installed the new one (4.22) but it doesn't seem to work. The UI locks up and I get the following:

$ vpn-unlimited 
/usr/share/vpn-unlimited/vpn-unlimited: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/lib/libvpnu_private_sdk.so.1)
Translation file loaded:  ":/translations/translations/VPN_Unlimited_English.qm" 
Translation file loaded:  ":/translations/translations/VPN_SDK_English.qm" 
Icon theme "papirus" not found.
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
Icon theme "gnome" not found.
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
free(): invalid pointer
corrupted size vs. prev_size

Tried on two different machines and the same issue.

papa33 commented on 2018-02-02 05:10

The solution for me : I had Oracle Java Runtime Environment (jre 9.0.4-1) installed. I removed it and now it works.

aytekinar commented on 2018-01-31 15:13

Hello @papa33. Are you sure you are running the latest version, i.e., vpn-unlimited 4.16-1? On my machine, everything seems to be working well. You should sudo systemctl start vpn-unlimited-daemon.service and then simply start the program. Sorry, I cannot reproduce the problem you have experienced.

papa33 commented on 2018-01-31 15:07

Hello!

I can launch it but it almost immediately crashes :

vpn-unlimited /usr/share/vpn-unlimited/vpn-unlimited: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/lib/libvpnu_private_sdk.so.1) Translation file loaded: ":/translations/translations/VPN_Unlimited_English.qm" Translation file loaded: ":/translations/translations/VPN_SDK_English.qm" libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile free(): invalid pointer

I am out of ideas...

aytekinar commented on 2018-01-07 18:35

"... until I ran the package in sudo."

I do not think you definitely need sudo access for the package to run. I can run it without the sudo access, but I am not so sure. Maybe some of our settings are different from each other :)

"Updated pkgsums as requested but I'm only a user, I have no write access into the AUR :)"

The thing is that I am the package maintainer right now. If this package is abandoned, then someone else can take it over, as far as I know :) Otherwise, you can simply use this chat to reach me and/or I would be more than happy to add you to the maintainers list, if I can at all :)

Dinoraptor101 commented on 2018-01-07 17:42

Hello Aytekinar! Wow it worked the warning message was stopping operation until I ran the package in sudo.

  • sudo systemctl enable vpn-unlimited-daemon
  • reboot
  • sudo vpn-unlimited (for sighning in. required admin access)

Afterwards it worked fine :)

<hr>

Updated pkgsums as requested but I'm only a user, I have no write access into the AUR :)

md5sums_x86_64=('8623605b1bef9eda0f451a9b4447629f' 'eec970693be55274ff2e85e596407f20' '713c98161060b81c5c963e9aa51d1d82') md5sums_i686=('8623605b1bef9eda0f451a9b4447629f' 'eec970693be55274ff2e85e596407f20' '998dbdc5c67644c0adbb40584d5f62ca')

aytekinar commented on 2018-01-05 14:14

Thank you, Dinoraptor101, for your help :) After bumping the version, you need to run updpkgsums and makepkg --printsrcinfo > .SRCINFO to make the changes valid for submitting to AUR. Please see the Wiki for more information, and let me know if the bumped version works for you.

nikolak and alphancioglu, please confirm if the bumped version works for you two. The /usr/bin/vpn-unlimited-daemon: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/lib/libvpnu_private_sdk.so.1) warning message does persist, but I do not seem to have any error messages and/or failures when I run the desktop app.

Dinoraptor101 commented on 2017-12-30 00:56

VPN 4.16 was released. I edited the version in the package but it's failing hash validation :) help is appreciated! sorry for noob-ness!