Package Details: vpp 18.10-1

Git Clone URL: https://aur.archlinux.org/vpp.git (read-only)
Package Base: vpp
Description: FD.io Vector Packet Processing
Upstream URL: https://fd.io/
Licenses: Apache
Provides: dpdk, vpp
Submitter: seglberg
Maintainer: seglberg
Last Packager: seglberg
Votes: 0
Popularity: 0.000000
First Submitted: 2018-09-25 20:49
Last Updated: 2018-11-01 22:35

Latest Comments

nplanel commented on 2018-12-14 01:46

Could you add these changes on the next release

1/ PKGBUILD a/

-makedepends=('ninja' 'patchelf') +makedepends=('git' 'cmake' 'ninja' 'patchelf' 'python2-setuptools' 'asciidoc' 'xmlto')

b/ prepare() { @@ -27,6 +29,7 @@ prepare() { # This forces DPDK to download dependencies # A quick pass did not reveal a clean make target for this. cd ${srcdir}/${pkgname} + patch -p1 -i ${srcdir}/Wno-error-unittest-plugin.patch make build-release || \ echo "Failure Caught, Patching" && \ patch -Np0 -i ${srcdir}/nasmlib.patch @@ -35,6 +38,7 @@ prepare() {

build() { # (1) Build Release + cd ${srcdir}/${pkgname} make build-release }

2/ it's a workaround to avoid compilation failure on unittest plugin due to strncpy tests and gcc 8.2.1 --- vpp/src/plugins/unittest/CMakeLists.txt.np +++ vpp/src/plugins/unittest/CMakeLists.txt @@ -22,3 +22,6 @@ tcp_test.c unittest.c ) + +target_compile_options(unittest_plugin PRIVATE -Wno-error) +