Package Details: vtk6 6.3.0-12

Git Clone URL: https://aur.archlinux.org/vtk6.git (read-only)
Package Base: vtk6
Description: A software system for 3D computer graphics, image processing, and visualization. Legacy 6.3 version.
Upstream URL: https://www.vtk.org/
Licenses: BSD
Submitter: bluewind
Maintainer: gbs
Last Packager: gbs
Votes: 5
Popularity: 0.023396
First Submitted: 2018-03-22 09:48
Last Updated: 2018-12-25 10:30

Dependencies (38)

Required by (3)

Sources (8)

Latest Comments

1 2 3 Next › Last »

fbrennan commented on 2018-12-25 10:22

@VP1: That's a simple fix. Just replace the corresponding hash line in the PKGBUILD with 'SKIP'. If using an AUR helper, revert to the manual process to affect this change.

VP1 commented on 2018-11-13 01:52

I am having the following error while installing. Please help as this is also a dependency in another package that I want.

-> Found gcc6.patch ==> Validating source files with sha1sums... VTK-6.3.0.tar.gz ... Passed VTKData-6.3.0.tar.gz ... Passed VTKLargeData-6.3.0.tar.gz ... Passed remove-vtkxdmf3.patch ... Passed find-libxml2.patch ... FAILED ffmpeg3_compat.patch ... Passed gdal2.patch ... Passed gcc6.patch ... Passed ==> ERROR: One or more files did not pass the validity check!

qqqwerrt commented on 2018-07-15 17:17

Same here, I got exactly the same error. Has anyone figured out how to fix this yet?

alberto2000 commented on 2018-07-04 09:32

I have the exact same issue as @anponteg - Java is missin but found at the same time...?

anponteg commented on 2018-06-27 10:16

I have a problem building this package:

==> Starting build()...

[...]

CMake Error at /usr/share/cmake-3.11/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find Java (missing: Java_JAR_EXECUTABLE Java_JAVAC_EXECUTABLE
  Java_JAVAH_EXECUTABLE Java_JAVADOC_EXECUTABLE) (found version "1.8.0_172")
Call Stack (most recent call first):
  /usr/share/cmake-3.11/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.11/Modules/FindJava.cmake:326 (find_package_handle_standard_args)
  Wrapping/Java/CMakeLists.txt:1 (find_package)

[...]

-- Configuring incomplete, errors occurred!

levara commented on 2018-06-11 19:12

Workaround for qt5_use_modules error: It seems that only examples use this command. If you turn off building of the examples, compilation is successful.

Change -DBUILD_EXAMPLES:BOOL=ON \ to OFF in the PKGBUILD file

This is the easiest way to get it to compile and install. At least until the patch comes out which will change the CMAKE files to not use qt5_use_modules.

levara commented on 2018-06-10 00:52

@gbs: It seems that qt5 is updated to 5.11. and qt5_use_modules is removed. This causes the build to fail with:

CMake Error at Examples/GUI/Qt/Events/CMakeLists.txt:50 (qt5_use_modules):

Unknown CMake command "qt5_use_modules".

What can be done about it?

gbs commented on 2018-05-30 16:39

martin3141: I cannot reproduce your error with a clean chroot and JDK9. But it seems you already found a workaround.

martin3141 commented on 2018-05-29 14:25

update - setting java-environment=8 results in an error-free build

martin3141 commented on 2018-05-29 13:39

I'm having a similar problem to kikislater. Am using cmake version 3.11.2 and got the same result when setting java-environment=9 dep. Error below:

Could NOT find Java (missing: Java_JAR_EXECUTABLE Java_JAVAC_EXECUTABLE Java_JAVAH_EXECUTABLE Java_JAVADOC_EXECUTABLE) (found version "1.8.0_172") Call Stack (most recent call first): /usr/share/cmake-3.11/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.11/Modules/FindJava.cmake:326 (find_package_handle_standard_args) Wrapping/Java/CMakeLists.txt:1 (find_package)

CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: JAVA_INCLUDE_PATH (ADVANCED) used as include directory in directory /tmp/yaourt-tmp-martin/aur-vtk6/src/VTK-6.3.0/Common/Core ...