Package Details: vulkan-nouveau-git 24.2.branchpoint.r28.g149e8bf-1

Git Clone URL: https://aur.archlinux.org/vulkan-nouveau-git.git (read-only, click to copy)
Package Base: vulkan-nouveau-git
Description: Nouveau Vulkan (NVK) Mesa driver with some additions (Git version)
Upstream URL: https://gitlab.freedesktop.org/mesa/mesa
Licenses: MIT AND BSD-3-Clause AND SGI-B-2.0
Conflicts: vulkan-nouveau
Provides: vulkan-driver
Submitter: DodoGTA
Maintainer: DodoGTA
Last Packager: DodoGTA
Votes: 9
Popularity: 0.37
First Submitted: 2023-11-10 17:58 (UTC)
Last Updated: 2024-07-20 07:38 (UTC)

Required by (54)

Sources (1)

Pinned Comments

DodoGTA commented on 2023-11-14 08:12 (UTC) (edited on 2023-12-16 09:27 (UTC) by DodoGTA)

The Meson 1.3.0rc2 requirement for NAK can for now be satisfied by the meson-rust package which I'll push soon: https://aur.archlinux.org/packages/meson-rust

Edit: Meson 1.3.0 has been released in the Arch repos (so you can reinstall normal Meson)

Update: The pipeline caching patch has been causing some segfaults (which I need to debug when I'm back on nouveau)

Latest Comments

1 2 3 4 Next › Last »

ZephyrCheez commented on 2024-04-03 02:10 (UTC)

Request to add vulkan-nouveau to the provides field

ZephyrCheez commented on 2024-03-31 02:38 (UTC)

For now the vulkan-nouveau packages in official repos are only 24.0 versions that don't include some of the newer stuff i.e. Vulkan 1.3 conformance

ngoquang2708 commented on 2024-03-25 16:56 (UTC)

FYI: vulkan-nouveau and lib32-vulkan-nouveau packages are available in official repo as of now.

RashadGasimli commented on 2024-03-25 15:21 (UTC)

@vlad1.96 thank you but not needed because new update is working very well.

callmejoe commented on 2024-03-18 15:06 (UTC)

new update builds successfully and working well

vlad1.96 commented on 2024-03-12 14:56 (UTC) (edited on 2024-03-12 14:58 (UTC) by vlad1.96)

@xiota @RashadGasimli @callmejoe as i can see, something patches was merged. Try delete nak-iadd3-imad.patch, "rm ..vk_shader.h || true" from the PKGBUILD and try again. Maybe need to delete nvk-memory-budget.patch

UPD https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27832 i think, need to try mesa-git yet

nyae commented on 2024-03-12 14:49 (UTC)

Yup, same over here, I can't compile it

callmejoe commented on 2024-03-11 21:54 (UTC)

same error here as @RashadGasimli

RashadGasimli commented on 2024-03-11 10:00 (UTC) (edited on 2024-03-11 10:00 (UTC) by RashadGasimli)

can't compile

==> Starting prepare()... patching file src/nouveau/vulkan/nvk_device_memory.c Reversed (or previously applied) patch detected! Skipping patch. 4 out of 4 hunks ignored -- saving rejects to file src/nouveau/vulkan/nvk_device_memory.c.rej patching file src/nouveau/vulkan/nvk_physical_device.c Reversed (or previously applied) patch detected! Skipping patch. 2 out of 2 hunks ignored -- saving rejects to file src/nouveau/vulkan/nvk_physical_device.c.rej patching file src/nouveau/vulkan/nvk_physical_device.h Hunk #1 FAILED at 39. 1 out of 1 hunk FAILED -- saving rejects to file src/nouveau/vulkan/nvk_physical_device.h.rej ==> ERROR: A failure occurred in prepare(). Aborting...