Package Details: vundle-git

Git Clone URL: (read-only)
Package Base: vundle-git
Description: Plug-in manager for Vim
Upstream URL:
Licenses: MIT
Conflicts: vundle
Provides: vundle
Submitter: None
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 71
Popularity: 0.896718
First Submitted: 2012-02-20 00:26
Last Updated: 2016-09-21 15:38

Latest Comments

anthraxx commented on 2015-04-04 00:23

package cleaned up and typo fixed accordingly. thanks for pointing it out.

wil93 commented on 2015-04-03 14:41

As already stated by @th-fr there is a typo in vundle.install file:

echo "To use vundle, please check the file /usr/share/vundle/vimrc.vundle"

should be:

echo "To use vundle, please check the file /usr/share/vundle/vimrc.sample"

th-fr commented on 2014-02-19 09:15

vundle.install: post_install():
the path of the example vimrc file is /usr/share/vundle/vimrc.sample

Anonymous comment on 2013-04-18 22:19

There is also some help in the vundle github page...

Anonymous comment on 2013-04-18 22:18

Ok, the vimrc.sample is the sample file that specified how you should set up vundle in your .vimrc and how to use vundle in order to update and download all of your plugins.
In short, vundle needs:

set nocompatible " be iMproved
filetype off " required!

call vundle#rc() <= This will initialize vundle

And at the end...

filetype plugin indent on " required!

Also, vundle can install plugins from github, vim-scripts (using the github repository from vim-scripts) and from other git repositories.

So that file /usr/share/vundle/vimrc.vundle, explains how you should set up vundle and how to use its methods.

paladin commented on 2013-04-18 21:00

hi, after install there is this text:

Updating vim help tags...done.
To use vundle, please check the file /usr/share/vundle/vimrc.vundle
and update your ~/.vimrc file, accordingly

while file should be vimrc.sample

Anonymous comment on 2013-04-03 10:02

A new pacman has hit the stores (it is in the testing repo), and since this changes the way VCS packages are built, here is a new release to use the new shiny new pacman and in this case makepkg.

P.S.: For the ones still using the old pacman, there is an version of the old script with the name PKGBUILD.old that should be used in those cases.

P.S.2: I've updated the package to use sha512 instead of md5, since md5 has been exploited in a multiple number of unfun and dangerous ways, and sha512 is safer (for now...)

Anonymous comment on 2013-02-13 22:18

Sorry, I forget that I've changed my mail... The new package should contain the correct license, and install it to the correct location.

beatgammit commented on 2013-02-13 20:43

License is MIT.

Anonymous comment on 2012-02-20 00:28

Since I didn't yet find vundle in aur or in the official repositories, here it is...

Be sure, to update your ~/.vimrc file after you install this package...

Also, the license of this package is unknown, since there is no info about it in the official website nor in the sources, but I've already contacted the developer so as soon as the license is known the package will get updated.