Package Details: vysor-git r128.f18c57c-2

Git Clone URL: https://aur.archlinux.org/vysor-git.git (read-only, click to copy)
Package Base: vysor-git
Description: Vysor lets you view and control your Android on your computer. Easy peasy.
Upstream URL: https://github.com/koush/electron-chrome
Licenses: MIT
Conflicts: vysor
Provides: vysor
Submitter: merrickluo
Maintainer: None
Last Packager: merrickluo
Votes: 1
Popularity: 0.000001
First Submitted: 2018-04-16 06:19
Last Updated: 2018-06-08 09:21

Latest Comments

diabonas commented on 2020-02-26 15:24

The package works fine on my machine, so I suspect the problem is that this package is missing some dependencies that are installed on my machine (and bundled in the AppImage), but not on yours. Building the package in a clean chroot and running namcap on the resulting package complains about the following missing libraries:

vysor-git W: Referenced library 'libX11.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libnss3.so' is an uninstalled dependency
vysor-git W: Referenced library 'libasound.so.2' is an uninstalled dependency
vysor-git W: Referenced library 'libXfixes.so.3' is an uninstalled dependency
vysor-git W: Referenced library 'libXdamage.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libstdc++.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libXrandr.so.2' is an uninstalled dependency
vysor-git W: Referenced library 'libX11-xcb.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libm.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libnspr4.so' is an uninstalled dependency
vysor-git W: Referenced library 'libGLESv2.so' is an uninstalled dependency
vysor-git W: Referenced library 'libgcc_s.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libatk-1.0.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libpangocairo-1.0.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libxcb.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'ld-linux-aarch64.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libnssutil3.so' is an uninstalled dependency
vysor-git W: Referenced library 'libpthread.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libXcomposite.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libc.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libXss.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libXtst.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libXi.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libffmpeg.so' is an uninstalled dependency
vysor-git W: Referenced library 'libXext.so.6' is an uninstalled dependency
vysor-git W: Referenced library 'libXcursor.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libXrender.so.1' is an uninstalled dependency
vysor-git W: Referenced library 'libcairo.so.2' is an uninstalled dependency
vysor-git W: Referenced library 'libgdk_pixbuf-2.0.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libsmime3.so' is an uninstalled dependency
vysor-git W: Referenced library 'libcups.so.2' is an uninstalled dependency
vysor-git W: Referenced library 'libgdk-3.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libpango-1.0.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libatk-bridge-2.0.so.0' is an uninstalled dependency
vysor-git W: Referenced library 'libgtk-3.so.0' is an uninstalled dependency
[...]
vysor-git E: Dependency dbus detected and not included (libraries ['usr/lib/libdbus-1.so.3'] needed in files ['opt/vysor-git/node_modules/electron/dist/electron'])
vysor-git E: Dependency glib2 detected and not included (libraries ['usr/lib/libgobject-2.0.so.0', 'usr/lib/libglib-2.0.so.0', 'usr/lib/libgio-2.0.so.0'] needed in files ['opt/vysor-git/node_modules/electron/dist/electron'])

Try installing electron, which should cover most of these. If that fixes your problem, please report back so that this AUR package can be fixed.

cschmid commented on 2019-12-12 09:16

With this I have always had the black screen issue. With the new package 'vysor-appimage' it works just fine. Do other people have the same behaviour? If yes, I suggest deleting this package in favour of 'vysor-appimage'.

Edit: Since nobody had objected, I've file a request for deletion.

simona commented on 2019-10-10 09:57

nuuu orphan

merrickluo commented on 2018-06-08 09:22

sorry for missing the message, fixed.

pizzaman commented on 2018-05-17 05:54

On run:

/usr/bin/vysor: line 3: cd: /opt/vysor/: No such file or directory

/usr/bin/vysor: line 5: ./node_modules/.bin/electron: No such file or directory

You just need to modify /usr/bin/vysor

cd /opt/vysor/ --> cd /opt/vysor-git/