Package Details: wargus 2.3.0-1

Git Clone URL: https://aur.archlinux.org/wargus.git (read-only)
Package Base: wargus
Description: Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine
Upstream URL: http://wargus.sourceforge.net/
Licenses: GPL
Submitter: Marvn
Maintainer: Thaodan
Last Packager: Thaodan
Votes: 11
Popularity: 0.000000
First Submitted: 2010-02-07 14:21
Last Updated: 2016-10-28 09:41

Latest Comments

Retro_Gamer commented on 2013-11-13 10:10

Fails due to error: "target not found: toluapp"

It indicates its being built from AUR, but fails and gives that error. I couldn't find that package “toluapp” to install it and seems to be the only dependency I'm missing. Any work around for this or is the package broken because its out of date?

Thaodan commented on 2013-03-23 16:58

I have no issue building wargus if lua52 is installed too.

Thaodan commented on 2013-03-23 16:35

You used the right directory, there's something with wartool or with your game data.

aphirst commented on 2013-03-23 16:31

I got this to install along with stratagus by making sure only lua51 was installed, and I've run wartool to extract my game data to /usr/share/games/stratagus/wargus, but if I run wargus it just spits out:

Maybe you need to specify another gamepath with '-d /path/to/datadir'?

I've tried manually running stratagus, feeding it the directory, but I can't get the damn thing to actually run. Is there something I might have missed, or need to check?

Anonymous comment on 2012-12-19 07:42

Sorry sbout that I thought it may of applied to both the PKGBUILD and the version of the source. I'll not do that next time, i'm still new around here..

Thaodan commented on 2012-12-18 23:25

I think its an upstream issue idk how to fix it. We need to fix stratagus until we can fix wargus etc.

Thaodan commented on 2012-12-18 23:01

This package is not out of date, it need some changes but its actual please mark only packages out of date that are out of date.

Anonymous comment on 2012-12-18 22:50

It currently won't build with lua 5.2

error: ‘LUA_GLOBALSINDEX’ was not declared in this scope

Needs an update to the PKGBUILD.

Thaodan commented on 2012-08-30 15:17

Updated it, no without any patches that were needed to build.

Xaseron commented on 2012-04-25 19:32

I've found my problem. I had to recompile stratagus against libpng15. Now it runs :-)

Xaseron commented on 2012-04-22 22:11

i remove libpng14 bevore i recompiled wargus.
ldd shows that it links correctly against libpng 15.
libpng15.so.15 => /usr/lib/libpng15.so.15 (0x00007f287a868000)

Thaodan commented on 2012-04-22 15:58

Is your stratagus built with libpng14?

Xaseron commented on 2012-04-22 10:50

Yes, it compiles with libpng15. But when i try to run it, it still complains about the missing libpng14:

wargus: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory

Thaodan commented on 2012-04-17 14:32

replaced patch from gentoo that made us able to compile wartool with libpng >15 with the offical patch from: https://bugs.launchpad.net/wargus/+bug/963210.
@Xaseron with the applyed patch wartool can compiled with libpng 14 or greater-

Xaseron commented on 2012-04-16 17:46

libpng14 should be added as dependency

Thaodan commented on 2012-03-03 05:30

Updated to 2.2.6 and inclued patch from gentoo

Thaodan commented on 2012-03-03 05:25

My pkg build with patch from gentoo:



# Contributor: Marvn <mistrmarvn@gmail.com>

pkgname=wargus
pkgver=2.2.6
pkgrel=1
pkgdesc="Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine"
arch=("i686" "x86_64")
url="http://wargus.sourceforge.net/"
license=('GPL')
depends=('stratagus' 'ffmpeg2theora' 'cdparanoia' 'timidity++')
source=("http://launchpad.net/wargus/trunk/2.2.6/+download/${pkgname}_${pkgver}.orig.tar.gz"
"http://bazaar.launchpad.net/~stratagus/wargus/trunk/diff/1622" "http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/games-strategy/wargus/files/wargus-2.2.5.5-libpng.patch")
md5sums=('fd39631339e8daa9e8c7de46916ad33a'
'fa6cc7983d6d19cd3acdb4f5e4624c98' '28efe2d83e8a48257094720f4ed68926'
)

build()

{
cd $srcdir/${pkgname}_$pkgver.orig
patch -p0 <../1622
patch < ../wargus-2.2.5.5-libpng.patch
mkdir build
cd build

cmake .. -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make || return 1

make DESTDIR="${pkgdir}" install
cd $pkgdir
mv usr/games/wargus usr/bin
rmdir usr/games

msg2 "run sudo wartool -m -v -r /media/cdrom/data /usr/share/games/stratagus/wargus to convert& copy original date"
msg2 "only works with originial dos cd"
}

Xaseron commented on 2011-12-27 02:17

my first approach. but i can't run wargus. i get this error:

[string "/usr/share/games/stratagus/wargus/scripts/f..."]:31: error in function 'New'.
argument #3 is 'nil'; 'number' expected.

stack traceback:
[C]: in function 'New'
[string "/usr/share/games/stratagus/wargus/scripts/f..."]:31: in main chunk
[C]: in function 'Load'
[string "/usr/share/games/stratagus/wargus/scripts/s..."]:367: in main chunk



my PKGBUILD

# Contributor: Marvn <mistrmarvn@gmail.com>

pkgname=wargus
pkgver=2.2.6
pkgrel=1
pkgdesc="Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine"
arch=("i686" "x86_64")
url="http://wargus.sourceforge.net/"
license=('GPL')
depends=('stratagus' 'ffmpeg2theora' 'cdparanoia' 'timidity++')
source=("http://launchpad.net/wargus/trunk/2.2.6/+download/${pkgname}_${pkgver}.orig.tar.gz"
"http://bazaar.launchpad.net/~stratagus/wargus/trunk/diff/1622")
md5sums=('fd39631339e8daa9e8c7de46916ad33a'
'fa6cc7983d6d19cd3acdb4f5e4624c98')

build()

{
cd $srcdir/${pkgname}_$pkgver.orig
patch -p0 <../1622
mkdir build
cd build

cmake .. -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make || return 1

make DESTDIR="${pkgdir}" install
cd $pkgdir
mv usr/games/wargus usr/bin
rmdir usr/games

msg2 "run sudo wartool -m -v -r /media/cdrom/data /usr/share/games/stratagus/wargus to convert& copy original date"
msg2 "only works with originial dos cd"
}

zwastik commented on 2011-12-26 16:46

This PKGBUILD no longer works.
Now program site is at https://launchpad.net/wargus

quantax commented on 2010-08-15 19:05

The hd2u package in [extra] also provides a dos2unix command: http://www.archlinux.org/packages/extra/i686/hd2u/