Package Details: wayland-chromium 1.21.0-3

Git Clone URL: https://aur.archlinux.org/wayland-chromium.git (read-only, click to copy)
Package Base: wayland-chromium
Description: A computer display server protocol (chromium version)
Upstream URL: https://wayland.freedesktop.org/
Licenses: MIT
Conflicts: wayland
Provides: libwayland-client.so, libwayland-cursor.so, libwayland-egl.so, libwayland-server.so, wayland
Submitter: mars
Maintainer: mars
Last Packager: mars
Votes: 0
Popularity: 0.000000
First Submitted: 2023-06-09 17:36 (UTC)
Last Updated: 2023-12-06 16:02 (UTC)

Required by (591)

Sources (8)

Latest Comments

Szymon01 commented on 2024-06-15 11:28 (UTC)

That could be a good idea, thanks for suggesting this. I just wanted to note that I'm no longer using the package. I was using it as a dependency for chromium-vaapi that was used as a workaround for hardware acceleration on chromium running on native wayland. It seems like the latest version of google-chrome-stable does support hardware video acceleration on wayland so I guess this package has lost its use-case.

I don't know which features of the package you were using but I no longer depend on it.

DodoGTA commented on 2024-06-15 11:15 (UTC)

I'm thinking of updating the Wayland version (while keeping the 2 remaining Chromium patches) if I get maintainer access to this package (or the current maintainer can do that if they come back)

Szymon01 commented on 2024-03-06 22:35 (UTC)

@mars It seems like the package is no longer compatible with the latest version of sway. I recently upgraded to 1.9 and launching sway with this version of wayland gives the following error:

00:00:00.076 [wlr] [wayland] wl_global_create: implemented version for 'wl_compositor' higher than interface version (6 > 5)
zsh: segmentation fault (core dumped)  sway -d

It seems like the new wayland version: 1.22.0-1 is required by the latest version of sway.

How expensive is it to rebuild your package so that it is compatible with the latest version of wayland?

MarsSeed commented on 2023-09-08 18:42 (UTC)

@mars, thanks for pointing this out. I've unflagged the package.

mars commented on 2023-09-08 17:46 (UTC)

@MarsSeed v1.21.0 is the version used by upstream (chromium), even in main branch (v119)

mars commented on 2023-06-10 02:07 (UTC)

@yochananmarqos Nothing wrong with official package. It is required by https://aur.archlinux.org/packages/chromium-wayland-vaapi

yochananmarqos commented on 2023-06-09 18:29 (UTC)

Why do we need this package?

If the official package is broken or is lacking a feature, then please file a bug report.

-- https://wiki.archlinux.org/title/AUR_submission_guidelines#Rules_of_submission