Package Details: wayvnc-git 0.6.0-1

Git Clone URL: (read-only, click to copy)
Package Base: wayvnc-git
Description: VNC server for wlroots-based Wayland compositors
Upstream URL:
Keywords: remote vnc wayland wlroots
Licenses: custom:ISC
Conflicts: wayvnc
Provides: wayvnc
Submitter: chron
Maintainer: any1
Last Packager: any1
Votes: 0
Popularity: 0.000000
First Submitted: 2020-01-14 14:05 (UTC)
Last Updated: 2023-01-23 12:26 (UTC)

Required by (2)

Sources (1)

Latest Comments

ony commented on 2023-07-01 21:03 (UTC) (edited on 2023-07-01 21:04 (UTC) by ony)

In my case aur/aml-git is 0.2.0-1 and results in that error about missing aml_unstable_abi_version symbol. Replacing it with extra/aml which is 0.3.0-1 makes build succeed.

lack commented on 2023-01-22 04:42 (UTC)

I think the aml dependency needs to be changed to aml-git as well.

xiliuya commented on 2022-12-11 04:05 (UTC) (edited on 2022-12-11 04:06 (UTC) by xiliuya)


../wayvnc/src/main.c:1451:13: error: ‘aml_unstable_abi_version’ undeclared (first use in this function)
 1451 |         if (aml_unstable_abi_version != AML_UNSTABLE_API)
      |             ^~~~~~~~~~~~~~~~~~~~~~~~

1ace commented on 2020-11-08 14:22 (UTC)

As a reminder, the philosophy on Arch is to only support the current version. If you didn't update something, it's your responsibility to update it.

That said, I have pushed a pkgver bump on neatvnc-git to force everyone to update, which will prevent your mistake from happening to anyone else (this time).

1ace commented on 2020-11-08 13:43 (UTC)

@davvore33: as indicated in the error message you posted when flagging the package as out-of-date, the issue is that your installed neatvnc is too old:

 wayvnc/ ERROR: Invalid version of dependency, need 'neatvnc' ['>=0.3.0'] found '0.1.0'.

Simply updating your neatvnc will fix it :)

davvore33 commented on 2020-11-08 09:49 (UTC)

Lately wayvnc requires neatvnc 0.3, you can see that when you try to recompile this package, the PKGBUILD has to be updated