Package Details: weasis-bin 3.6.1-1

Git Clone URL: https://aur.archlinux.org/weasis-bin.git (read-only, click to copy)
Package Base: weasis-bin
Description: Weasis is a multipurpose DICOM viewer with a highly modular architecture
Upstream URL: https://nroduit.github.io/
Licenses: EPL-2.0
Submitter: Junker
Maintainer: Junker
Last Packager: Junker
Votes: 10
Popularity: 0.57
First Submitted: 2019-02-20 13:00
Last Updated: 2020-08-17 14:03

Latest Comments

ggnoredo commented on 2021-04-21 16:37

error: failed to parse srcinfo for 'weasis-bin-3.6.1-1': key 'groups' requires a value: Line 7: groups =

wcasanova commented on 2021-04-13 00:20

@junker it works please update the version and sha512sum as well since it is not the same

the .desktop is needed for the dicomizer binary

[Desktop Entry]
Version=1.0
Name=Dicomizer
Comment=Build DICOM files from images
Exec=/opt/weasis/bin/Dicomizer
Icon=/opt/weasis/lib/Dicomizer.png
Terminal=false
Type=Application
Categories=Viewer;MedicalSoftware;Graphics;

Junker commented on 2021-02-20 04:12

version 3.7.0 is crashing.. : [1] 570046 abort (core dumped) ./Weasis

check somebody please this PKGBUILD, if you don't have a segfault, i will update it.

pkgname=weasis-bin
pkgver=3.7.0
pkgrel=1
pkgdesc="Weasis is a multipurpose DICOM viewer with a highly modular architecture"
arch=('any')
url="https://nroduit.github.io/"
license=('EPL-2.0')
groups=('')
options=('!strip' '!emptydirs')
source=("https://github.com/nroduit/Weasis/releases/download/v${pkgver}/weasis_${pkgver}-1_amd64.deb")
sha512sums=('c7d2644b10f994bd6f641c079785c8cfddbbea0b24f887e9a62463c19ee84a0e535b0faf3029ccaedc4a37aa2f3e1c799fc2bd921ae24ac79484a0ce9bdd3482')

package(){
        tar -xJC "${pkgdir}" -f data.tar.xz

        mkdir -p "${pkgdir}/usr/bin"
        ln -s "/opt/weasis/bin/Weasis" "$pkgdir/usr/bin/weasis"

        install -Dm 644 ${pkgdir}/opt/weasis/lib/weasis-Weasis.desktop ${pkgdir}/usr/share/applications/Weasis.desktop
}

Junker commented on 2019-09-17 06:14

fixed.

hakim commented on 2019-09-17 01:34

Fresh install of Manjaro and the weasis-bin installer fails

install: cannot stat '/opt/Weasis/bin/Weasis.desktop': No such file or directory ==> ERROR: A failure occurred in package(). Aborting...

Any thoughts on how to install?

nroduit commented on 2019-08-25 16:30

From the version 3.5.3, the native installers (msi, deb, rpm, pkg) replace the weasis-portable.zip package and no longer requires Java to be installed on the system. It also serves as a basis for launching Weasis from a web context using the weasis protocol (https://nroduit.github.io/en/getting-started/weasis-protocol/).

See also https://groups.google.com/d/msg/dcm4che/3C84sscQqkQ/W2nvWma7AQAJ

Junker commented on 2019-08-21 12:40

updated to 3.5.3 version. works with java-11

arkoprovo1996 commented on 2019-08-21 11:59

Please add the line

JAVACMD=/usr/lib/jvm/java-10-openjdk/bin/java

in file 'viewer-linux.sh' (/opt/weasis-bin/viewer-linux.sh)

before the final line $JAVACMD ...

mzecher commented on 2019-05-21 01:59

Thanks for the package. It does however not work with jre11. I got it to run with jre10-openjdk

Tetrapyle commented on 2019-04-18 16:45

Please, I think you should replace:

source=('<https://netcologne.dl.sourceforge.net/project/dcm4che/Weasis/>${pkgver}/weasis-portable.zip'

by:

source=("<https://netcologne.dl.sourceforge.net/project/dcm4che/Weasis/>${pkgver}/weasis-portable.zip"

in the PKGBUILD.