Package Details: weather 2.1-1

Git Clone URL: https://aur.archlinux.org/weather.git (read-only)
Package Base: weather
Description: CLI tool which shows weather forecasts from METAR data
Upstream URL: http://fungi.yuggoth.org/weather/
Licenses: custom:BSD2
Submitter: None
Maintainer: keenerd
Last Packager: keenerd
Votes: 34
Popularity: 0.216669
First Submitted: 2007-10-19 09:56
Last Updated: 2016-09-16 03:13

Latest Comments

keenerd commented on 2016-09-16 03:04

You can simply hit the flag out of date button.

There is no reason to create a patch unless there is something really bizarre with the update that you think the maintainer isn't smart enough to figure out.

ra1nb0w commented on 2016-09-15 17:44

new version 2.1
I haven't found another way to send the patch; if it exists, please indicate me how. thanks.

diff --git a/PKGBUILD b/PKGBUILD
index 8902657..a81ed09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,18 @@
# Contributor: Abhishek Dasgupta <abhidg@gmail.com>

pkgname=weather
-pkgver=2.0
-pkgrel=3
+pkgver=2.1
+pkgrel=1
pkgdesc="CLI tool which shows weather forecasts from METAR data"
arch=('any')
url="http://fungi.yuggoth.org/weather/"
depends=('python2')
license=("custom:BSD2")
source=(http://fungi.yuggoth.org/weather/src/$pkgname-$pkgver.tar.gz)
-#md5sums=('a15517825595f73dc06ccd6628c4c2f6')
-# checksums seem to be changing every hour or something weird
-md5sums=('be49f38f2da59dfc4716e2370f029a65')
+md5sums=('51ddb7bc5e9e36d01e615834cc0442dd')

prepare() {
cd "$srcdir/$pkgname-$pkgver"
- # remove on verions 2.1
- sed -i 's|weather.noaa.gov/pub|tgftp.nws.noaa.gov|' {airports,overrides.conf,places,slist,stations,weather.py,weatherrc.5,zctas,zlist,zones}
}

build() {

keenerd commented on 2016-08-25 20:49

No, but I can backport the patch.

Lerentis commented on 2016-08-25 18:25

The developer has updated the package to fix a 404 for some stations, but did not release a new tar ball. could you provide a clone directly from his repository? Thanks in advance

keenerd commented on 2010-11-21 03:58

Fixed.

Anonymous comment on 2010-11-21 01:27

Got an error during build:

File "<string>", line 1
import sys ; print [p for p in sys.path if p.startswith('/usr/lib/python2.')][0]

SyntaxError: invalid syntax

keenerd commented on 2010-11-19 10:38

Adopted and fixed up. Changes:

Installs the weatherrc file.
Works with any python2, not just 2.6.

Anonymous comment on 2010-10-27 20:45

After update:
[ ~ ] weather
File "/usr/bin/weather", line 25
if get_bool("list"): print weather.list_aliases(selections.config)
^
SyntaxError: invalid syntax

Probably this problem with python3

Anonymous comment on 2010-07-25 07:11

The file /usr/bin/weather conflicts with a file of the same name in [extra] expect-5.44.1.15-1