Package Details: webkit2gtk-unstable 2.43.4-1

Git Clone URL: https://aur.archlinux.org/webkit2gtk-unstable.git (read-only, click to copy)
Package Base: webkit2gtk-unstable
Description: Web content engine for GTK
Upstream URL: https://webkitgtk.org/
Keywords: gtk webkit
Licenses: custom
Conflicts: webkitgtk-6.0
Provides: libjavascriptcoregtk-6.0.so, libwebkitgtk-6.0.so, webkitgtk-6.0
Submitter: vesath
Maintainer: xiota
Last Packager: xiota
Votes: 4
Popularity: 0.000000
First Submitted: 2016-08-02 22:18 (UTC)
Last Updated: 2024-02-26 06:29 (UTC)

Required by (26)

Sources (2)

Pinned Comments

xiota commented on 2024-03-17 01:57 (UTC)

I don't use this package anymore, but will continue to bump/update upon request.

Feel free to use flags for all issues that don't require debugging or explanation (eg, version bumps, depends updates, other housekeeping).

Latest Comments

1 2 Next › Last »

xiota commented on 2024-03-17 01:57 (UTC)

I don't use this package anymore, but will continue to bump/update upon request.

Feel free to use flags for all issues that don't require debugging or explanation (eg, version bumps, depends updates, other housekeeping).

kode54 commented on 2023-03-16 04:03 (UTC)

This somehow conflicts with webkit2gtk-4.1, does it actually provide 4.1?

dr460nf1r3 commented on 2022-06-18 08:52 (UTC) (edited on 2022-06-18 08:52 (UTC) by dr460nf1r3)

wayland-protocols was needed to fix the error I posted earlier. It should be at least a makedep.

vesath commented on 2021-11-09 18:02 (UTC)

If I recall correctly the wayland build failed with some strange error. Since I don't use it myself I found it easier to just disable it. Cheers.

swiftscythe commented on 2021-11-09 10:49 (UTC)

@vesath thank you! Why did you disable wayland?

dr460nf1r3 commented on 2021-11-06 15:27 (UTC) (edited on 2021-11-06 15:28 (UTC) by dr460nf1r3)

libavif seems to be missing in makedepends :) Also, there seems to be another issue: ninja: error: '/unstable/pointer-constraints/pointer-constraints-unstable-v1.xml', needed by 'WebKit2Gtk/DerivedSources/pointer-constraints-unstable-v1-protocol.c', missing and no known rule to make it

vesath commented on 2021-10-25 20:23 (UTC) (edited on 2021-11-09 06:18 (UTC) by vesath)

Here's a slightly modified version that builds with libsoup3:

https://fenua.org/gaetan/tmp/webkit2gtk-unstable-2.34.1-1.src.tar.gz

Yay, we finally we get HTTP/2 support!

This version also includes a few fixes for minor issues: libavif being a required dependency, and ninja being a makedepends but not actually used for building.

Enjoy!

archblue commented on 2021-04-28 12:09 (UTC)

Compile error, webkit2gtk-unstable/src/webkitgtk-2.31.91/Source/JavaScriptCore/runtime IntlSegmenter.cpp:128:77: 错误:‘ubrk_safeClone_69’ was not declared in this scope; did you mean ‘ucol_safeClone_69’?

vesath commented on 2019-02-18 22:30 (UTC)

Thanks a lot for your response and for merging my proposed changes. Cheers!