Package Details: weboob-git 3.0.r73.gfd7610aaa-1

Git Clone URL: https://aur.archlinux.org/weboob-git.git (read-only, click to copy)
Package Base: weboob-git
Description: Core library and modules for Web Outside of Browsers
Upstream URL: https://weboob.org
Licenses: LGPL3
Conflicts: weboob-headless
Provides: weboob-headless
Replaces: weboob-headless
Submitter: maturain
Maintainer: CoiledSpring
Last Packager: CoiledSpring
Votes: 29
Popularity: 0.000000
First Submitted: 2010-08-06 22:51 (UTC)
Last Updated: 2021-05-01 15:49 (UTC)

Latest Comments

Archange commented on 2020-02-14 14:42 (UTC)

@cgirard: Indeed, so I’ll merge this back into weboob-git instead (no point in an headless version anymore).

marco44 commented on 2020-01-16 17:54 (UTC)

python2-google-api-python-client just disappeared from aur…

cgirard commented on 2020-01-15 15:07 (UTC)

In addition to my previous comment, the no-qt and no-xdg options are no longer available: https://git.weboob.org/weboob/weboob/commit/6e729c213ab63d4a130012b6bd4bb3927bcf6465

ahuillet commented on 2020-01-12 18:11 (UTC)

Please, update to take laurentb's latest comment into account, or orphan so somebody else can do it.

laurentb commented on 2019-12-23 16:06 (UTC)

We have split weboob in two repositories now, since it created more problems than it solved to have the --qt options.

So there is weboob and weboob-qt.

There should be a new weboob-qt-git package here, and weboob-git being only for weboob without the graphical applications.

mathieu.clabaut commented on 2019-12-23 11:10 (UTC)

For information, after a system update I've got the following error.

==> Starting package()...
usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: setup.py --help [cmd1 cmd2 ...]
   or: setup.py --help-commands
   or: setup.py cmd --help

error: option --qt not recognized

cgirard commented on 2019-10-24 20:49 (UTC)

Hi, could you add provide for weboob-headless as well? kresus requires it.

Archange commented on 2019-09-29 15:29 (UTC)

Thanks @laurentb, I’ve updated and also switched to python3.

laurentb commented on 2019-09-12 08:59 (UTC)

Also, the new git URL is https://git.weboob.org/weboob/weboob.git (the old one still works, it's a redirect)

laurentb commented on 2019-09-12 08:57 (UTC)

The hildon support has been removed a while ago, it was for the Nokia N900.

The solution is to remove the --no-hildon from the instructions.

coincoincanard commented on 2019-09-12 08:49 (UTC)

In build(), the --no-hildon option is causing the setup to fail.

laurentb commented on 2019-01-06 20:57 (UTC)

Hello, python2-mechanize is no longer a dependency.

laurentb commented on 2019-01-01 17:24 (UTC)

Hello,

The official repository has been moved to git+https://git.weboob.org/weboob/weboob

There should be a redirect so the old one will work for a while.

sputnick commented on 2018-10-28 18:58 (UTC)

Not sure I get the point, can you describe what's wrong ?

Do you want me to remove pkgrel=1 ?

The version from the PKGBUILD is pkgver=1.3_1664_gf813a6265

mickael9 commented on 2018-10-27 17:59 (UTC)

Can you change the pkgver in the PKGBUILD so that it matches the actual pkgver() (1.3.1664.gf813a6265) to avoid update loops?

sputnick commented on 2017-10-19 21:26 (UTC)

@mickael9, DONE

mickael9 commented on 2017-10-19 19:56 (UTC)

Can you add the missing python2-unidecode dependency? File "/usr/lib/python2.7/site-packages/weboob/capabilities/bank.py", line 24, in <module> from unidecode import unidecode

sputnick commented on 2017-05-25 13:57 (UTC)

Fixed PKGBUILD, tested OK

garfi commented on 2017-05-17 20:59 (UTC) (edited on 2017-05-17 20:59 (UTC) by garfi)

Error to make pkg: ==> Extraction des sources... ==> Lancement de pkgver()... /tmp/yaourt-tmp-lolop/aur-weboob-git/./PKGBUILD: ligne 45 : cd: /tmp/yaourt-tmp-lolop/aur-weboob-git/src/weboob-git: N'est pas un dossier

sputnick commented on 2017-01-11 20:14 (UTC)

DONE, thanks for information

laurentb commented on 2017-01-11 18:10 (UTC)

python2-gdata should be replaced by python2-google-api-python-client python2-elementtidy support has been removed a while ago

sputnick commented on 2017-01-09 22:13 (UTC)

Updated PKGBUILD : - python2-setuptools modified in PKGBUILD - bash completion added - was stuck with 1.1 because of the link git://git.symlink.me/pub/weboob/devel.git corrected to https://git.weboob.org/weboob/devel.git, now 1.2 is OK

Spheerys commented on 2017-01-09 17:12 (UTC)

I can't install this git version because setuptools, as said before. By the way, the 1.2 is out but the git version is still pointing to the 1.1

laurentb commented on 2016-09-08 19:02 (UTC)

It should be python2-setuptools, according to the non-git package. It is useful, you can't install weboob without it.

ryuta commented on 2016-09-08 17:45 (UTC)

setuptools dependence does not exists. Is it useful ?

laurentb commented on 2016-02-13 22:58 (UTC)

Weboob 1.1 just got released, you might want to use that instead of -git. New dependency: python2-futures Otherwise, for the git version (and upcoming 1.2), we now use Qt5, so replace python2-pyqt4 by python2-pyqt5 and phonon-qt4 by phonon-qt5. Thanks!

Busyvar commented on 2016-02-13 21:01 (UTC) (edited on 2016-02-17 12:59 (UTC) by Busyvar)

pkgver can't contain - anymore , please replace it by something else. Add dependency : python2-pyqt5

cyberic commented on 2015-08-09 18:56 (UTC)

Thx for this PKGBUILD. Would it be possible to add 'make' to the makedepends? I think it is needed. Thanks

sputnick commented on 2014-10-20 15:55 (UTC)

Automatic update on new versions fixed (was broken).

sputnick commented on 2014-09-22 11:12 (UTC)

PKGBUILD updated

laurentb commented on 2014-05-23 18:13 (UTC)

You should also update the dependencies from the latest 0.i. https://aur.archlinux.org/packages/weboob/

ianux commented on 2014-05-22 15:58 (UTC)

This PKGBUILD is outdated (stuck on 0.d branch). Here is an up-to-date version: http://pastebin.com/GRZG8t4q

sputnick commented on 2013-10-15 20:34 (UTC)

pkgver() added. PKGBUILD will be updated only on versions changes.

Scimmia commented on 2013-10-11 22:04 (UTC)

For the pacman 4.1 updates, I mean the link josephgbr gave you months ago: https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines Short version: stop doing the clone manually and add a pkgver function. As for the automated update, why?!?!? That does nothing but annoy your users, you only need to update the PKGBUILD when something important changes. I know that if I was a user, I would have abandoned this package months ago and just maintained my own locally.

sputnick commented on 2013-10-11 09:26 (UTC)

@Scimmia: this is an automated update. What do you mean by "still not updated for pacman 4.1" ?

Scimmia commented on 2013-10-11 07:03 (UTC)

So two useless updates later, still no response.

Scimmia commented on 2013-10-09 05:20 (UTC)

I see this in the recent packages feed all of the time and have to ask, why is the package updated so often? Dep changes? And why is it still not updated for pacman 4.1?

sputnick commented on 2013-08-05 22:00 (UTC)

I don't find any remplacement for python2-qt, it was removed. Feel free to update the thread if something's missing.

twister commented on 2013-08-05 21:43 (UTC)

python2-qt can't be find. I think this packet have been renamed or replaced, could someone update the PKGBUILD with the correct dependency ?

sputnick commented on 2013-04-22 12:54 (UTC)

@josephgbr : DONE

rafaelff commented on 2013-04-22 05:19 (UTC)

Please update PKGBUILD to be compatible with pacman 4.1 https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines

sputnick commented on 2013-01-30 14:31 (UTC)

@ianux, DONE.

ianux commented on 2013-01-25 00:04 (UTC)

You should add python2-cssselect which is required (at least) by some videoob backends.

sputnick commented on 2012-11-18 15:03 (UTC)

PKGBUILD reviewed accordingly to linkmauve's proposal

linkmauve commented on 2012-10-26 16:20 (UTC)

python-clientform isn’t needed anymore by weboob since python2-mechanize replaces it, all the other python- packages can be finally replaced by their python2- equivalent, pyxdg by python2-xdg, pyqt by python2-pyqt, only pygtk stays like that since gtk3 has a much better builtin bindings system (the same as gtk2 actually, pygtk was just there before). Also, the list of dependencies is pretty big, while most of them aren’t needed for some backends, so it would make sense to put them as optdepends instead, with the list of modules requiring each one listed in the description of the optdepend.

linkmauve commented on 2012-07-22 15:49 (UTC)

python-nose and python-routes should now be called python2-nose and python2-routes in their python2 version.

vnoel commented on 2012-02-06 08:38 (UTC)

Actually, I don't want to take care of this package anymore, if someone is interested, I'm leaving my space :) I updated for the dependency, but I'm pretty sure it is not the only one missing…

vnoel commented on 2012-02-06 08:36 (UTC)

ok, thanks :)

Francois_B commented on 2012-02-04 19:05 (UTC)

mimms is missing as dep. It is needed for downloading (at least for francetelevision backend)

vnoel commented on 2011-05-14 14:10 (UTC)

Thank you, done :)

commented on 2011-05-14 13:29 (UTC)

python-yaml should be python2-yaml

vnoel commented on 2011-04-14 07:17 (UTC)

updated dependency python-feedparser to python2-feedparser

vnoel commented on 2011-01-21 07:21 (UTC)

renamed dependency pyqt to python2-qt

vnoel commented on 2010-11-15 08:37 (UTC)

So, here is an up to date version, I will also uploid a weboob-stable-git version :)

vnoel commented on 2010-11-15 08:36 (UTC)

@AlexS: seems it was disown, I just adopted it :)

commented on 2010-11-15 00:27 (UTC)

vnoel: unless I'm wrong, this package is not maintained, so you should ask the admins to give you access to its maintenance. It would be nice if you could do it.

vnoel commented on 2010-11-14 12:51 (UTC)

Hi, if you cannot take care of the package, I would be happy to maintain it :)

vnoel commented on 2010-11-10 09:30 (UTC)

Hi, I updated the package python-prettytable and the python2 version is now available as python2-prettytable: http://aur.archlinux.org/packages.php?ID=43260 python-prettytable is for python 3!!

vnoel commented on 2010-11-08 20:57 (UTC)

Hi, here is a working PKGBUILD with python2 dependency. I did not include the change for the stable branch. I also added all the dependencies that can be found in the debian packages... ! pkgname=weboob-git pkgrel=1 pkgver=20101108 pkgdesc="python web tool: Web Out Of Browsers" url="http://weboob.org" license=('GPL') arch=('i686' 'x86_64') depends=('python2' 'python-dateutil' 'python-mechanize' 'pyxdg' 'python2-elementtidy' 'python-html2text' 'python-yaml' 'python-lxml' 'python-html5lib' 'python-clientform' 'python-feedparser' 'python-gdata' 'python-nose' 'python2-prettytable' 'python-mako' 'python-routes' 'python2-webob' 'python-imaging' 'pygtk' 'pyqt' 'pywebkitgtk' 'python-pysqlite' 'python-simplejson') makedepends=('git' 'setuptools') conflicts=('weboob') provides=('weboob') _gitroot="git://git.symlink.me/pub/romain/weboob.git" _gitname=weboob build() { cd ${srcdir} msg "Connecting to GIT server...." if [ -d ${srcdir}/$_gitname ] ; then cd $_gitname && git pull origin msg "The local files are updated." else git clone $_gitroot fi msg "GIT checkout done or server timeout" cd $srcdir/$_gitname python2 setup.py install --root=$pkgdir || return 1 }

commented on 2010-11-08 12:14 (UTC)

Hi, here is a patch to use the stable branch and python2 at the installation. http://aur.pastebin.com/Rdr8jWR7

vnoel commented on 2010-11-08 09:40 (UTC)

Hi, use python2 :) Or maybe report a bug at weboob so that they support python3.

maturain commented on 2010-09-11 18:33 (UTC)

added pyqt

commented on 2010-09-04 00:19 (UTC)

also missing python-qt, that lack leads an installation failure (complains about the lack of pyuic4)

maturain commented on 2010-08-10 16:24 (UTC)

thanks. the following dependencies have been added : python-mako python-routes python-webob

commented on 2010-08-09 22:13 (UTC)

Hi, it seems that python-routes is a missing dependency. http://aur.pastebin.com/nPaDG58e