Package Details: weboob 1.5-1

Git Clone URL: https://aur.archlinux.org/weboob.git (read-only)
Package Base: weboob
Description: Web Out Of Browsers provides several applications to interact with a lot of websites.
Upstream URL: http://weboob.org/
Licenses: LGPL3
Submitter: hamelg
Maintainer: hamelg
Last Packager: hamelg
Votes: 15
Popularity: 0.008441
First Submitted: 2016-02-16 21:40
Last Updated: 2019-02-27 19:53

Latest Comments

1 2 Next › Last »

laurentb commented on 2019-01-14 14:15

Looks like there's a bug in setup.py :(

Under Python 2 it actually looks for python3-pyuic5 and not python2-pyuic5. The fix is pretty simple: https://git.weboob.org/laurentb/weboob/commit/31dac680af872b8d0d65d447151608530eb4cdcb

edit: it's fixed in 1.5

Spheerys commented on 2019-01-14 14:08

I can't install this package because : [code]running build_qt Building Qt applications... Could not find executable: pyuic5 Install missing component(s) (see above) or disable Qt applications (with --no-qt). [/code] I don't find any resource on this pyuic5 and I want to use qt GUI...

laurentb commented on 2019-01-06 20:57

Hello, Weboob 1.4 has been released! https://git.weboob.org/weboob/weboob/uploads/08dad6b2a68fd618ba8c87c627393d06/weboob-1.4.tar.gz https://pypi.org/project/weboob/1.4/#files

python2-mechanize is no longer required.

Note: Weboob 2.0 is planned to switch to Python 3 fully (mechanize being the only dependency that did not work under Python 3).

laurentb commented on 2019-01-01 17:23

Hello,

The source URL has changed: https://git.weboob.org/weboob/weboob/uploads/e8c77b143e84c97fca354579575d18e9/weboob-1.3.tar.gz

It's still the same tarball, so no hash change.

laurentb commented on 2018-01-06 19:27

Indeed, some backported modules now require unidecode. It will also be required by weboob 1.4.

fallanck commented on 2017-12-31 18:50

Weboob needs the python2-unidecode package, too.

laurentb commented on 2017-09-20 17:05

Yes, the website actually takes its news from https://symlink.me/projects/weboob/news.atom but hasn't been updated yet.

edit: The website is now up to date! Thanks for looking and updating the package.

hamelg commented on 2017-09-20 16:52

is it official ?
I don't see that here :
http://weboob.org/news

laurentb commented on 2017-09-20 13:52

1.3 released. New dependency: six.

laurentb commented on 2017-01-11 18:06

Since 1.2:

python2-gdata is not needed anymore (replaced by python2-google-api-python-client)
Switched from Qt4 to Qt5.

Also, you might want to do:
sed -i "s/exclude=\['modules'\]/exclude=['modules', 'modules.*']/" setup.py

Because of a bug that slipped in the release (git is patched).