Package Details: wesnoth-devel 1.13.13-1

Git Clone URL: https://aur.archlinux.org/wesnoth-devel.git (read-only)
Package Base: wesnoth-devel
Description: development version of a turn-based strategy game on a fantasy world
Upstream URL: https://www.wesnoth.org/
Keywords: game strategy
Licenses: GPL
Submitter: valdar
Maintainer: valdar
Last Packager: valdar
Votes: 60
Popularity: 0.000134
First Submitted: 2007-02-28 22:40
Last Updated: 2018-06-11 10:21

Dependencies (25)

Required by (0)

Sources (8)

Latest Comments

« First ‹ Previous ... 11 12 13 14 15 16

vcap commented on 2010-09-24 00:58

As noted by emericn6k, you can remove lua from the dependencies (they are now using an in-tree version[1]).

Also, you can drop all the '|| return 1'; current makepkg does it automatically.


[1] btw, namcap could have told you.

valdar commented on 2010-09-23 01:07

Updated to version 1.9.1
[many tnx to clmates]
[sorry for the delay]

feufochmar commented on 2010-09-18 11:01

Version 1.9.1 is available.

valdar commented on 2010-08-29 20:37

I will look at this package next week when I'll be back home.

emericn6k commented on 2010-08-24 17:08

@clmates: With your pkgbuild, it failed once (don't know why).
So I read wesnoth forum thread and found that lua dependency could be deleted.

=> a pkgbuild that worked for me is : http://aur.pastebin.com/CT2TL3h2

Anonymous comment on 2010-08-23 19:20

Hi I have adapted the PKGBUILD and it seems to work with 1.9.0

changes:

Adapted the version and release
Adapted the md5sum for the new 1.9 file
Commented out the patch file, md5 of patch file and patch instructions

here are my changed PKGBUILD


#Contributor:Andrea Tarocchi <valdar@email.it>
pkgname=wesnoth-devel
pkgver=1.9.0
pkgrel=1
pkgdesc="development version of a turn-based strategy game on a fantasy world"
arch=('i686' 'x86_64')
url="http://www.wesnoth.org/"
license=('GPL')
depends=('lua' 'pango' 'sdl_ttf' 'sdl_net' 'sdl_mixer' 'sdl_image' 'boost' 'fribidi' 'ruby' 'dbus-core')
install=${pkgname}.install
source=(http://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2 \
${pkgname}.desktop \
wesnoth_editor-devel.desktop \
wesnoth-devel-icon.xpm \
wesnoth-devel_editor-icon.xpm)
md5sums=('c4e7ba80c6212cb58c3ff96d10f417ae'
'a906eae5d541a51de77038469b1f794b'
'36c3cbe51dedaa07d2f16b35338664a5'
'b73f4fdefd3e7daa158cce278f11be64'
'931e7443fe37b2862ca59f65ded74a0b')

build() {

#CONFIGURING
cd "${srcdir}/wesnoth-$pkgver"
./autogen.sh || return 1
./configure --prefix=/usr --enable-tools --enable-editor --enable-server \
--with-preferences-dir=.wesnoth-devel --program-suffix=-devel --with-datadir-name=wesnoth-devel \
--enable-campaign-server --with-fifodir=/var/run/wesnothd-devel --docdir=/usr/share/doc/wesnoth-devel \
--mandir=/usr/share/man/wesnoth-devel || return 1
#--disable-strict-compilation || return 1

#PATCHING for libpng compatibility
#cd ..
#patch -p0 < ../libpng_compatibility_patch.patch || return 1

#MAKING datarootdir=/usr/share datadir=/usr/share || return 1 might be another useful otion
cd "${srcdir}/wesnoth-$pkgver"
make || return 1

# make pkgpythondir=${pkgdir}/usr/lib/python`python -c \
# "import sys; print '%d' % (sys.version_info[0]);" \
# `.`python -c "import sys; print '%d' % (sys.version_info[1]);" \
# `/site-packages/wesnoth DESTDIR="${pkgdir}" install || return 1

make DESTDIR="${pkgdir}" install || return 1

#INSTALLING of menu entry and icons:
install -D -m644 ../../wesnoth-devel.desktop ${pkgdir}/usr/share/applications/wesnoth-devel.desktop
install -D -m644 ../../wesnoth-devel-icon.xpm ${pkgdir}/usr/share/pixmaps/wesnoth-devel-icon.xpm
install -D -m644 ../../wesnoth-devel-icon.xpm ${pkgdir}/usr/share/icons/wesnoth-devel-icon.xpm

install -D -m644 ../../wesnoth_editor-devel.desktop ${pkgdir}/usr/share/applications/wesnoth_editor-devel.desktop
install -D -m644 ../../wesnoth-devel_editor-icon.xpm ${pkgdir}/usr/share/pixmaps/wesnoth-devel_editor-icon.xpm
install -D -m644 ../../wesnoth-devel_editor-icon.xpm ${pkgdir}/usr/share/icons/wesnoth-devel_editor-icon.xpm

chmod +x ${pkgdir}/var/run/wesnothd-devel
chmod o+r ${pkgdir}/var/run/wesnothd-devel

rm -f ${pkgdir}/usr/share/applications/wesnoth.desktop
rm -f ${pkgdir}/usr/share/applications/wesnoth_editor.desktop
rm -f ${pkgdir}/usr/share/icons/wesnoth-icon.png
rm -f ${pkgdir}/usr/share/icons/wesnoth_editor-icon.png
}

feufochmar commented on 2010-08-21 14:24

1.9.0 development version is available.

valdar commented on 2010-08-05 08:58

wesnoth 1.8 is the latest stable release not the development one!

valdar commented on 2010-04-03 23:48

wesnoth 1.8 is the latest stable release not the development one!