Package Details: wesnoth-devel 1.13.13-1

Git Clone URL: https://aur.archlinux.org/wesnoth-devel.git (read-only)
Package Base: wesnoth-devel
Description: development version of a turn-based strategy game on a fantasy world
Upstream URL: https://www.wesnoth.org/
Keywords: game strategy
Licenses: GPL
Submitter: valdar
Maintainer: valdar
Last Packager: valdar
Votes: 60
Popularity: 0.000163
First Submitted: 2007-02-28 22:40
Last Updated: 2018-06-11 10:21

Dependencies (25)

Required by (0)

Sources (8)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

einsiedlerkrebs commented on 2014-10-13 14:53

md5sum wesnoth-1.11.17.tar.bz2
7fb94158acec98cbc930cb6146f5cb89

cockatricehunter commented on 2014-10-12 18:40

@valdar. Works like a charm.

Thanks

valdar commented on 2014-10-12 13:46

Uploaded to support latest boost releae (1.56.0)

@cockatricehunter
can you try this new version and let me know?

cockatricehunter commented on 2014-10-03 23:32

@valdar
boost 1.56.0-1
icu 53.1-1

valdar commented on 2014-10-03 23:15

@cockatricehunter
Can you give me the exact icu and boost version that you are using?
Anyway, I'm away from my arch machines till next saturday... I'll look in to it ASAP.

cockatricehunter commented on 2014-10-03 22:46

After a recent boost and icu update wesnoth-devel no longer works. While downgrading boost is fine, downgrading icu affects other programs (ex. firefox). Normally I would try to reinstall/re-compile but this time I came across this error:

g++ -o wesnoth -pthread -Wl,-O1,--sort-common,--as-needed,-z,relro build/release/game.o build/release/libwesnoth_extras.a build/release/lua/liblua.a build/release/libwesnoth_core.a build/release/libwesnoth_sdl.a build/release/libwesnoth.a build/release/libwesnoth_extras.a build/release/lua/liblua.a -L/usr/lib -lm -lboost_iostreams -lSDL -lSDL_net -lpthread -lboost_system -lpangocairo-1.0 -lpango-1.0 -lgobject-2.0 -lcairo -lfontconfig -lfreetype -lboost_program_options -lboost_regex -lSDL_ttf -lSDL_mixer -lvorbisfile -lSDL_image -lX11 -ldbus-1 -lfribidi -lglib-2.0
build/release/libwesnoth_extras.a(multiplayer_connect_engine.o): In function `mp::connect_engine::start_game_commandline(commandline_options const&)':
multiplayer_connect_engine.cpp:(.text+0xd7c9): undefined reference to `std::basic_ostream<char, std::char_traits<char> >& boost::operator<< <char, std::char_traits<char>, std::string>(std::basic_ostream<char, std::char_traits<char> >&, boost::optional<std::string> const&)'
collect2: error: ld returned 1 exit status
scons: *** [wesnoth] Error 1
scons: building terminated because of errors.

Any ideas? Is there a way to build this so that boost updates don't break this?
Thanks

valdar commented on 2014-07-17 18:00

Updated to 1.11.16

valdar commented on 2014-06-30 08:05

@TrialnError

ok I try what you suggested!

valdar commented on 2014-06-13 07:43

@TrialnError

Yep!
That does make sense, at first glance.
I overlooked the difference beetween /run/wesnothd and /var/run/wesnothd.
I'll figure out how to set the fifodir in scons building and update the package afther that.

Thank you!

TrialnError commented on 2014-06-12 15:42

One thing. I looked into the case with /var/run. Luckily there was a bugreport which I could use as a stepstone.

/var/run is a symlink to /run which is a tmpfs.

So, you added wesnothd-devel.tmpfiles.conf which points to /run.
In the PKGBuild the fifodir should be reflect this. See the change the [community] package made[0].
So the chmod part could be nuked, the fifodir should be changed and a .install file be added if I see it correctly.
________
[0]https://projects.archlinux.org/svntogit/community.git/commit/trunk?h=packages/wesnoth&id=1ca53ec31ea0f4a426fcb801d0ab3bac7abb8caa