Package Details: weston-git 1.9.90.5002.cd9bb71-1

Git Clone URL: https://aur.archlinux.org/weston-git.git (read-only)
Package Base: weston-git
Description: Reference implementation of a Wayland compositor
Upstream URL: http://wayland.freedesktop.org
Licenses: MIT
Conflicts: weston
Provides: weston
Submitter: klusark
Maintainer: klusark
Last Packager: klusark
Votes: 27
Popularity: 0.213824
First Submitted: 2012-01-04 20:31
Last Updated: 2015-11-24 20:54

Latest Comments

klusark commented on 2016-03-23 15:38

shoober420, feel free to copy this package, add the patches, and upload it under a new name (such as weston-git-nvidia). I'm going to keep this package as it is upstream.

Scimmia commented on 2016-03-23 15:03

Once they're accepted upstream, they'll be available here automatically. I don't think it's wise to include patches before they're accepted.

shoober420 commented on 2016-03-23 14:38

Would it be possible to add the NVIDIA patches that are posted on the Weston mailing list to this package so we can launch Weston natively with NVIDIA proprietary drivers?

klusark commented on 2015-11-24 20:54

@linkmauve, done.

linkmauve commented on 2015-11-24 16:13

Hi, Weston now depends on wayland-protocols, I packaged it earlier, please pull this repository which contains the necessary fixes to this PKGBUILD:
https://git.collabora.com/git/user/emmanuel/weston-git.git

klusark commented on 2015-03-12 01:51

@linkmauve, done. Thanks for the suggestions.

linkmauve commented on 2015-03-11 19:12

Hi, --enable-libinput-backend isn’t needed anymore, since it’s the default now. You can also drop the >=0.4 for the libinput dependency, we are at 0.12 now and it’s very unlikely to break again before 1.0.

Scimmia commented on 2014-09-02 15:41

libinput>=0.4 is future-proof. When libinput is updated in the repos, libinput>=0.4 still works, where making it depend on on libinput-git forces another update to the PKGBUILD when libinput is updated.

klusark commented on 2014-08-28 16:03

ecloud: I'd do that if it depended on the version that is currently in git, but 0.4.0 and even 0.5.0 have been released, so installing either of those would work as well. The arch package just has not been updated yet. I think it'll be updated when the next version of Gnome is out (which I think might be in September).

ecloud commented on 2014-08-28 15:47

Please make it depend on libinput-git not libinput>=0.4, unless I'm missing something and that's available somewhere.

All comments