Package Details: whatsapp-desktop 0.4.2-2

Git Clone URL: https://aur.archlinux.org/whatsapp-desktop.git (read-only)
Package Base: whatsapp-desktop
Description: Unofficial whatsapp web desktop client. Build with Electron.
Upstream URL: https://github.com/Enrico204/Whatsapp-Desktop
Licenses: MIT
Provides: whatsapp-desktop=0.4.2
Submitter: bil-elmoussaoui
Maintainer: bil-elmoussaoui
Last Packager: bil-elmoussaoui
Votes: 42
Popularity: 6.969547
First Submitted: 2017-01-06 15:08
Last Updated: 2018-01-06 00:24

Latest Comments

erikw commented on 2018-01-14 10:12

@bil-elmoussaoui thanks that would be great

Note. I accidentally removed my comment here but it basically reported the same problem that @el_jsho also have, that dunst got replaced.

bil-elmoussaoui commented on 2018-01-10 17:32

@erikw @el_jsho i will mark the notify-osd as an optional dependency.

el_josho commented on 2018-01-06 23:34

Why exactly is notify-osd a dependency? This was for me the reason to remove the package because notify-osd automatically replaces dunst which I use as notification daemon.

bil-elmoussaoui commented on 2018-01-05 22:28

@grayk79 The issue is due to the exact filename for the tarballs. I have requested to add a version number suffix to fix it. See https://github.com/Enrico204/Whatsapp-Desktop/issues/92

ToxygeneB commented on 2018-01-05 22:08

@grayk79 I got around it by deleting my AUR helper's cache of whatsapp-desktop with:

$ rm -rf .cache/pacaur/whatsapp-desktop

grayk79 commented on 2018-01-04 06:32

The last update did not update the sha256.

==> Validating source files with sha256sums...
    WhatsApp-linux-x64.tar.gz ... FAILED
    whatsapp-desktop.desktop ... Passed
    whatsapp-desktop.png ... Passed
==> ERROR: One or more files did not pass the validity check!

bil-elmoussaoui commented on 2018-01-03 19:08

Updated to v0.4.2 which should the node-gettext issue.

DrTebi commented on 2018-01-03 17:37

@bil-elmoussaoui: Replacing lib32-libxss with libxss was the right call. No need to enable multilib. I already have libxss installed anyway.

Thanks for doing that.

zarere commented on 2018-01-03 14:28

@ryanfox

The workarond as written in https://github.com/Enrico204/Whatsapp-Desktop/issues/81

from user tkerst is

npm install node-gettext
npm install

in /opt/Whatsapp/resources/app. The first command installs the missing module while the second one installs the dependencies that are defined in the package.json. Those were missing too in my case (Arch Linux via aur/whatsapp-desktop).

bil-elmoussaoui commented on 2018-01-03 11:58

@ryanfox Please report that upstream

All comments