Package Details: whipper-eaclogger-git 3.a9c7ea5-1

Git Clone URL: https://aur.archlinux.org/whipper-eaclogger-git.git (read-only)
Package Base: whipper-eaclogger-git
Description: whipper logger meant to mimic EAC style logs
Upstream URL: https://github.com/JoeLametta/morituri-eaclogger
Licenses: GPL3
Provides: morituri-whatcd
Submitter: Shardz
Maintainer: Shardz
Last Packager: Shardz
Votes: 4
Popularity: 0.008340
First Submitted: 2016-07-02 18:13
Last Updated: 2016-12-21 21:51

Latest Comments

ArchangeGabriel commented on 2017-01-21 14:24

morituri is now dead and gone anyway. ;)

Shardz commented on 2016-12-21 21:52

Alright, I updated the package since I suspect most people are going to be using whipper, not morituri.

ArchangeGabriel commented on 2016-12-21 14:27

Well, this is the strange case where a package can depend on two others that do not provide the same thing.

The correct solution is for both morituri and whipper to provide a third non-existent package (like morituri-like-ripper), and for whipper-eac-logger to depends on this last one.

Another solution might be getting ride of the dependency, since technically it does not strictly depends on it (not needed for compiling or running), thought it serves no purpose without one or the other.

Or, finally, just replace morituri with whipper, morituri being dead anyway and having AFAIK no advantage over whipper.

BoBeR182 commented on 2016-12-21 02:16

https://aur.archlinux.org/packages/whipper-git/ Refuses to make the needed change.

Shardz commented on 2016-11-04 17:12

whipper-git should 'provide' morituri, no?

BoBeR182 commented on 2016-11-04 12:31

:: whipper-eaclogger-git: installing whipper-git (0.2.3.r112.g5a59f3c-1) breaks dependency 'morituri'