Package Details: wildfly 27.0.1-1

Git Clone URL: https://aur.archlinux.org/wildfly.git (read-only, click to copy)
Package Base: wildfly
Description: Wildfly Application Server.
Upstream URL: http://www.wildfly.org/
Keywords: jakartaee java javaee
Licenses: LGPL
Conflicts: wildfly-devel
Submitter: nachtwandler
Maintainer: morealaz (stick)
Last Packager: morealaz
Votes: 29
Popularity: 0.001800
First Submitted: 2013-05-30 13:14 (UTC)
Last Updated: 2022-12-17 06:34 (UTC)

Dependencies (3)

Required by (0)

Sources (3)

Latest Comments

1 2 3 4 5 6 Next › Last »

morealaz commented on 2022-03-25 06:30 (UTC)

@davispuh: done. thanks!

davispuh commented on 2022-03-21 00:55 (UTC)

FYI: looks like PIDFile in .service file needs to updated

/usr/lib/systemd/system/wildfly.service:11: PIDFile= references a path below legacy directory /var/run/, updating /var/run/wildfly/wildfly.pid → /run/wildfly/wildfly.pid; please update the unit file accordingly.

morealaz commented on 2022-01-07 19:25 (UTC)

@stick: yes. I think that we could also simply delete wildfly-systemd. Go for it as you want. You are still co-maintainer of wildfly. I made some changes to this package. Fill free to review these changes.

morealaz commented on 2022-01-07 18:29 (UTC)

I adopt this package and changed it to use upstream systemd service.

stick commented on 2022-01-07 16:11 (UTC)

@morealaz, would you like to do the merger now?

stick commented on 2021-11-23 01:27 (UTC)

@morealaz I concur, but I am hesitant without assent from @hrauch.

morealaz commented on 2021-11-07 11:43 (UTC)

@stick: I think others simply did not care which service file to use, so I think there is no need to vote. Just delete wildfly-systemd and update this package to use upstream service file. Since this package name is simply wildfly, It should be as close as to upstream release as possible. If someone need a patched version to use another service file, they should make a custom package like wildfly-something to reflect this change.

stick commented on 2021-11-06 13:13 (UTC)

@morealaz: I think that would be a superior solution to what we do now, but others disagree.

morealaz commented on 2021-11-06 06:30 (UTC)

@stick: Since upstream provided a systemd service, why not merging this package with wildfly-systemd to provide a single package with systemd support?

stick commented on 2019-05-10 00:36 (UTC)

@Khaithang this package uses systemd-wrapper.sh, which is not a part of wildfly upstream. The wildfly-systemd package makes use of the systemd scripts provided by upstream.