Package Details: wilink 2.4.906-2

Git Clone URL: https://aur.archlinux.org/wilink.git (read-only, click to copy)
Package Base: wilink
Description: Instant messaging client and SIP softphone for Wifirst customers
Upstream URL: https://github.com/jlaine/wilink
Licenses: GPL3
Submitter: Spike29
Maintainer: Spike29
Last Packager: Spike29
Votes: 2
Popularity: 0.000000
First Submitted: 2011-11-04 20:24
Last Updated: 2016-05-13 09:53

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Spike29 commented on 2012-03-08 19:42

Updated to 2.2.2-3.

Fixed the ugly icon.

Spike29 commented on 2012-03-08 19:21

Updated to version 2.2.2 on 08/03/12.

Source link is now redirected to the official Wifirst archives, since cmake's bug is no longer an issue with version 2.8.7-2.
Qt > 4.7.4 is now needed.

There's just a little GUI issue : the new GNU/Linux icon looks ugly (it's a 32x32 xpm file).
Maybe I will just replace it later by the old 64x64 PNG file, in an update.

Spike29 commented on 2011-12-30 17:21

Updated to pkgrel 3 on 30/12/11.

Fixed arch from 'any' to 'i686' and 'x86_64' and changed the location of the .tar.gz archive on another Dropbox public link.

Spike29 commented on 2011-11-06 20:00

@speps: Here is a pastebin link for the full log of the faulty build --> http://pastebin.com/raw.php?i=9KTW5CQP
Actually, the issue is the following : "Invalid Qt version string given: "4.7.0", major version 4 is required, e.g.
"4.0.1""
There is already a bug report for this (it's cmake 2.8.5 on the bug report, but with cmake 2.8.6 the issue is still there) --> https://bugs.archlinux.org/task/25107

Spike29 commented on 2011-11-06 12:49

@speps: Here is a pastebin link for the full log of the faulty build --> http://pastebin.com/raw.php?i=9KTW5CQP
Actually, the issue is the following : "Invalid Qt version string given: "4.7.0", major version 4 is required, e.g.
"4.0.1""
I think I will re-open this bug, which hasn't been fixed with cmake 2.8.6 --> https://bugs.archlinux.org/task/25107

speps commented on 2011-11-06 02:29

@Spike29 Well done! Btw the original source correctly builds and works for me with qt 4.7.4, no errors with cmake.
Can you please link a full log of your faulty build on a pastebin site? Tnx

Spike29 commented on 2011-11-05 09:59

@speps: Thanks for your help ! :)

I included most of your fixes in PKGBUILD, except for the source (the original CMakeLists file requires qt>=4.7... but with qt 4.7.4 cmake encounters a bug and refuses to compile).
I also added your wilink.install file.

Cheers.

speps commented on 2011-11-05 01:11

@Spike29 Hi, and good luck for your AUR package maintainer career ;)
Here is an even more improved PKGBUILD > http://paste.pocoo.org/raw/503123/
and the relative missing wilink.install > http://paste.pocoo.org/raw/503121/

PKGBUILD: fixed source, added missing dependencies (libnotify and libgphoto2), fixed license (GPL3), fixed package description,
added install directive (for desktop file), build in a ad hoc directory (cmake common practice), added desktop file and icon.

For any question reply here, cheers.

Spike29 commented on 2011-11-04 22:06

It should work now.

Spike29 commented on 2011-11-04 21:40

Thanks for your help ! (it's my first package on AUR).
I'm trying again with your fix.