Package Details: windowmaker-git 0.95.6.r304.gb295a20-1

Git Clone URL: (read-only)
Package Base: windowmaker-git
Description: An X11 window manager with a NEXTSTEP look and feel
Upstream URL:
Keywords: floating windowmanager X11
Licenses: GPL, custom
Conflicts: windowmaker
Provides: windowmaker
Submitter: drcouzelis
Maintainer: bidulock
Last Packager: bidulock
Votes: 6
Popularity: 0.000000
First Submitted: 2011-10-26 02:28
Last Updated: 2015-06-11 04:36

Required by (6)

Sources (2)

Latest Comments

bidulock commented on 2014-10-10 09:01

I do not encounter the problem you describe. Perhaps you have a variable set in your shell environment that is messing things up?

mrbrklyn commented on 2014-10-10 06:54

There is a bug in the package. As it is,it is crippled. WPref is being built into /usr/Local instead of /usr/local > I tried to fix the Makefile but when I makepkg it just blow away my file. The fix needs to be make uptstream. My guess is that the error is in the m4 files. I seem to think I can remember this bug existing in the source code a few years ago.


kass commented on 2013-08-28 15:35

GIFlib patch:
Thanks Paulo Andrade.

bidulock commented on 2013-08-21 06:00

20120222-1 no longer builds due to giflib upgrade. I will mail you a src package that includes the necessary patch and updates to proper Archlinux git handling. The maintainer of extra/windowmaker should have upstreamed their patch.

ise commented on 2012-02-22 12:25

Adopt package and maintain it further. Thanks Dave for the work so far.

drcouzelis commented on 2011-10-26 02:32

This is the active development version of Window Maker. You can install the latest version of Window Maker at any time by re-installing this package.

You can watch for updates here:

Or follow the development mailing list here: