Package Details: wine-staging-git 9.9.r5.g68925c8f-1

Git Clone URL: https://aur.archlinux.org/wine-staging-git.git (read-only, click to copy)
Package Base: wine-staging-git
Description: A compatibility layer for running Windows programs (staging branch, git version)
Upstream URL: https://www.wine-staging.com/
Keywords: staging windows wine
Licenses: LGPL-2.1-or-later
Conflicts: wine, wine-wow64
Provides: wine, wine-staging, wine-wow64
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 18
Popularity: 0.000000
First Submitted: 2016-03-27 06:19 (UTC)
Last Updated: 2024-05-23 02:09 (UTC)

Required by (377)

Sources (4)

Latest Comments

1 2 3 4 5 6 7 Next › Last »

Kakadus commented on 2024-06-04 23:36 (UTC)

Thank you very much, I updated it

dbermond commented on 2024-06-02 04:23 (UTC)

@Kakadus You have an outdated makepkg.conf and should update your LDFLAGS format to the latest version (using separated '-Wl' options for each flag, instead of combining all of them in a single '-Wl' option). Update your makepkg.conf to match what is used in the latest pacman version and it should work. You can see the same problem happening with another user in wine-git package, see also the discussion there. When using the changes that you mentioned, we lose the other flags in LDFLAGS, since it is being totally redefined, while we only need to get rid of the unsupported '-z' flags.

Kakadus commented on 2024-06-01 21:18 (UTC) (edited on 2024-06-01 21:22 (UTC) by Kakadus)

Thanks @dbermond ^^

Now I have the problem that the CROSSLDFLAGS bash pattern matching fails. My LDFLAGS seem to be -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now and that is not replaced correctly with this line:

export CROSSLDFLAGS="${LDFLAGS//-Wl,-z*([^[:space:]])/}"

Instead, I'd suggest export CROSSLDFLAGS="${LDFLAGS//?(-Wl?(,)|-z,*([^[:space:],])?(,))/}" which should be more robust

edit: I just saw https://gitlab.archlinux.org/archlinux/packaging/packages/wine-staging/-/merge_requests/3 which also fixes the same issue

dbermond commented on 2024-05-23 02:10 (UTC)

@Kakadus fixed. Now building fine with gcc 14. Thanks for reporting.

Kakadus commented on 2024-05-19 23:26 (UTC)

Hi,

the build recently broke for me, because wine-staging does not support gcc 14 yet. "-Wno-error=incompatible-pointer-types" as CFLAGS is needed for me to pass the build. Tracked upstream by https://bugs.winehq.org/show_bug.cgi?id=56692

diff --git a/PKGBUILD b/PKGBUILD
index 7992506..1e6e811 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Daniel Bermond <dbermond@archlinux.org>

 pkgname=wine-staging-git
-pkgver=8.2.r7.g7b0d44f8
+pkgver=9.9.r4.g791a70fa
 pkgrel=1
 pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
 arch=('x86_64')
@@ -105,7 +105,7 @@ pkgver() {

 build() {
     # does not compile without remove these flags as of 4.10
-    export CFLAGS="${CFLAGS/-fno-plt/}"
+    export CFLAGS="${CFLAGS/-fno-plt/} -Wno-error=incompatible-pointer-types"
     export LDFLAGS="${LDFLAGS/,-z,now/}"

     # build wine-staging 64-bit

dbermond commented on 2023-02-25 13:43 (UTC)

@cysp74 AUR PKGBUILDS needs to follow the Arch Wiki recommendations, hence we do not to list dependencies from base-devel here. And AUR users are supposed to have knowledge of the Arch Wiki. Thanks for pointing patchinstall changes in upstream code.

cysp74 commented on 2023-02-20 22:41 (UTC)

@dbermond that's right, however no wired logic for base-devel in PKGBUILD, dunno if aur packages supposed to be foolproof, basically doc says "Note: Packages in the AUR assume that base-devel is installed in the build environment.".

Anyway, here is another patch, since https://gitlab.winehq.org/wine/wine-staging/-/commit/c1b4af92f74d7bd330003d39d0bb1f966fdb70a9 commit deco'd patchinstall.sh and superseded by patchinstall.py


diff --git a/PKGBUILD b/PKGBUILD
index cc07ce5..bc12dda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Daniel Bermond <dbermond@archlinux.org>

 pkgname=wine-staging-git
-pkgver=8.1.r3.g87f33695
+pkgver=8.2.r1.g1f76f7fa
 pkgrel=1
 pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
 arch=('x86_64')
@@ -91,11 +91,11 @@ prepare() {
     # change back to the wine upstream commit that this version of wine-staging is based in
     printf '%s\n' '  -> Changing wine HEAD to the wine-staging base commit...'
     git -C wine config --local advice.detachedHead false
-    git -C wine checkout "$(wine-staging/patches/patchinstall.sh --upstream-commit)"
+    git -C wine checkout "$(wine-staging/staging/patchinstall.py --upstream-commit)"

     # apply all wine-staging patches
     printf '%s\n' '  -> Applying wine-staging patches...'
-    wine-staging/patches/patchinstall.sh DESTDIR="${srcdir}/wine" --all
+    wine-staging/staging/patchinstall.py DESTDIR="${srcdir}/wine" --all
 }

 pkgver() {

dbermond commented on 2023-02-13 18:55 (UTC)

@cysp74 flex and bison are members of the base-devel group. Members of this group are prequesites for building packages and do not need to be listed at makedepends, as you must already have them installed.

cysp74 commented on 2023-02-13 09:48 (UTC)

Hi, thanks for updates. However I had to put back flex+bison to PKGBUILD, they're still needed for build.


diff --git a/PKGBUILD b/PKGBUILD
index cc07ce5..f1f8a9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Daniel Bermond <dbermond@archlinux.org>

 pkgname=wine-staging-git
-pkgver=8.1.r3.g87f33695
+pkgver=8.1.r9.g33674908
 pkgrel=1
 pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
 arch=('x86_64')
@@ -20,6 +20,7 @@ depends=(
     'desktop-file-utils'
 )
 makedepends=('git' 'perl' 'mingw-w64-gcc'
+    'flex'                  'bison'
     'giflib'                'lib32-giflib'
     'gnutls'                'lib32-gnutls'
     'libxinerama'           'lib32-libxinerama'

dbermond commented on 2023-02-11 16:06 (UTC)

@cysp74 Package updated with latest base package changes and other improvements.