Package Details: wingpanel-bzr 1:r126-1

Git Clone URL: https://aur.archlinux.org/wingpanel-bzr.git (read-only)
Package Base: wingpanel-bzr
Description: The Pantheon Panel
Upstream URL: https://launchpad.net/wingpanel
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: wingpanel
Provides: libwingpanel-2.0.so, wingpanel
Submitter: flamelab
Maintainer: alucryd
Last Packager: alucryd
Votes: 37
Popularity: 0.123357
First Submitted: 2010-12-21 23:19
Last Updated: 2016-05-16 08:17

Required by (27)

Sources (1)

Latest Comments

alucryd commented on 2014-07-15 23:33

We've been talking about this for weeks, if not for months, on the pantheon forum thread. wingpanel now needs a recent libindicator and gtk3-ubuntu, thus is essentially useless on arch linux until further notice. And no I'm not going to endorse/promote patched packages like gtk3-ubuntu. The last working version of wingpanel-bzr can be found on my repo but you're better off using another panel until the situation changes anyway.

iRy1989 commented on 2014-07-15 21:25

Same Error here
http://pastebin.com/embed_js.php?i=n4aAmEJU --- DETAILED INFORMATION

iRy1989 commented on 2014-07-15 20:47

Same problem here

CMakeFiles/Makefile2:91: recipe for target 'CMakeFiles/wingpanel.dir/all' failed
make[1]: *** [CMakeFiles/wingpanel.dir/all] Error 2
Makefile:147: recipe for target 'all' failed
make: *** [all] Error 2

lw4z commented on 2014-07-09 13:50

CMakeFiles/Makefile2:91: recipe for target 'CMakeFiles/wingpanel.dir/all' failed
make[1]: *** [CMakeFiles/wingpanel.dir/all] Error 2
Makefile:147: recipe for target 'all' failed
make: *** [all] Error 2

xenatt commented on 2014-04-17 21:19

I got error same problem.

IndicatorFileModel.vala:68: Unable to read indicators: Böyle bir dosya ya da dizin yok

How to solve it.

Your repo is too old and wont work

alucryd commented on 2013-10-24 10:58

https://wiki.archlinux.org/index.php/Pantheon#Installation

sleepforlife commented on 2013-10-24 10:45

$wingpanel
[_LOG_LEVEL_INFO 13:44:58.888473] Application.vala:77: Wingpanel version: 0.2.5
[_LOG_LEVEL_INFO 13:44:58.888643] Application.vala:79: Kernel version: 3.11.6-1-ARCH
[_LOG_LEVEL_WARN 13:44:58.986409] IndicatorFileModel.vala:68: Unable to read indicators: Böyle bir dosya ya da dizin yok
İzleme/kesme noktası yakalayıcı (core dumped)

grvrulz commented on 2013-03-31 11:14

Please change vala-016 to vala0.16 in makedepends. There's no such package as vala-016

Ner0 commented on 2012-12-06 15:35

Right, forgot about that

alucryd commented on 2012-12-06 15:25

@Ner0: You need to add -DVALA_EXECUTABLE="$(type -p valac-0.16)" to the cmake options otherwise it uses 0.18.

alucryd commented on 2012-12-06 15:08

Thx for the answers both of you, I will test it now. BTW, you forgot a quote at the end of line 7 in your install file Ner0.

alucryd commented on 2012-12-06 15:04

Thx for the answers both of you, I will test it now.

n00b commented on 2012-12-05 22:28

for me with this pkgbuild http://pastebin.com/dcbtrFkm, il build e run fine even with the indicators

n00b commented on 2012-12-04 12:10

i tried to compile with vala 0.16.1 it compile and run fine, even with the indicator, so i think that vala-016 should be added as compile dependency

Ner0 commented on 2012-11-26 15:34

I think this is due GTK 3.6. Elementary OS still uses GTK 3.4 and vala 0.16 so there are conflicts.

alucryd commented on 2012-11-26 15:24

wingpanel is unable to load any indicator for me. It launches fine, along with slingshot, but as soon as I install indicator-session or indicator-sound, it crashes at launch, saying it can't load lib***.so. Can somebody reproduce this?

Ner0 commented on 2012-03-15 19:52

Ok, i've added libindicator3 and hicolor-icon-theme deps.
I'm getting the same warnings as you, but have no problems with slingshot.
Are your dependencies stable (glib2, gtk3, vala)?
Also, try installing the latest libindicator3: http://aur.pastebin.com/0Gk7khS5

Anonymous comment on 2012-03-15 17:47

Okay, I managed to get round this by installing libindicator3 from the AUR

However, now I'm getting some issues with GTK. Please see the below screenshots and terminal output:

This is for wingpanel (you can see just below it that there are some GTK issues: http://oi42.tinypic.com/9k321f.jpg

And here's what happens when I click 'Applications' to launch slingshot: http://oi41.tinypic.com/6h59he.jpg

Here's the terminal output: http://pastebin.com/n1NePbGS

Anonymous comment on 2012-03-15 17:10

I'm getting glib schema errors when trying to build: http://pastebin.com/QxpwvWP4

Any idea how to get this working?

Anonymous comment on 2012-01-05 22:36

Shouldn't granite-bzr be added as a dependency? I had to install it to get wingpanel to install.

Anonymous comment on 2011-12-31 01:01

Package builds but won't run. This is the output when I try to run it: http://aur.pastebay.com/148654

Anonymous comment on 2011-09-28 21:18

Are you attempting to build through a pacman wrapper? I do not have this error, and I built the package a few minutes ago.

skull-y commented on 2011-09-11 11:01

I got the same error like vis. I think there is something to add to the PKGBUILD

Ner0 commented on 2011-08-10 14:27

This works:
PKGBUILD: http://pastebin.com/5Psyqbn6
wingpanel-bzr.install: http://pastebin.com/HZ5PTGLJ

Anonymous comment on 2011-08-06 17:40

I'm having this error:

http://pastebin.com/87Fx0MCX

Anonymous comment on 2011-06-12 13:52

libunique should be added as a dependency

Anonymous comment on 2011-05-08 19:14

[1/9] valac: wingpanel-panel.vala CompositedWindow.vala wingpanel-config.vala wingpanel-indicator-file-model.vala wingpanel-object-entry.vala log.vala cardapio.vala -> _build_/wingpanel-panel.c _build_/CompositedWindow.c _build_/wingpanel-config.c _build_/wingpanel-indicator-file-model.c _build_/wingpanel-object-entry.c _build_/log.c _build_/cardapio.c
/tmp/yaourt-tmp-dinth/aur-wingpanel-bzr/src/wingpanel/wingpanel-panel.vala:36.9-36.33: warning: Wingpanel.Panel.screen hides inherited field `Gtk.Window.screen'. Use the `new' keyword if hiding was intentional
/tmp/yaourt-tmp-dinth/aur-wingpanel-bzr/src/wingpanel/cardapio.vala:5.9-5.38: warning: method `Cardapio.dbus.show_hide' never used
/tmp/yaourt-tmp-dinth/aur-wingpanel-bzr/src/wingpanel/cardapio.vala:7.9-7.49: warning: method `Cardapio.dbus.show_hide_near_mouse' never used
/tmp/yaourt-tmp-dinth/aur-wingpanel-bzr/src/wingpanel/wingpanel-panel.vala:301.27-301.67: error: duplicating Display instance, use unowned variable or explicitly invoke copy method

** (valac:32629): CRITICAL **: vala_ccode_base_module_get_cvalue_: assertion `value != NULL' failed

** (valac:32629): CRITICAL **: vala_ccode_function_add_assignment: assertion `right != NULL' failed
Waf: Leaving directory `/tmp/yaourt-tmp-dinth/aur-wingpanel-bzr/src/wingpanel/_build_'
Build failed
-> task failed (exit status 1):
{task 43107536: valac wingpanel-panel.vala,CompositedWindow.vala,wingpanel-config.vala,wingpanel-indicator-file-model.vala,wingpanel-object-entry.vala,log.vala,cardapio.vala -> wingpanel-panel.c,CompositedWindow.c,wingpanel-config.c,wingpanel-indicator-file-model.c,wingpanel-object-entry.c,log.c,cardapio.c}
''

caspian commented on 2011-01-04 10:59

I don't have PULSE because I can't configure it to work on my laptop. There are no errors when running wingpanel. I simply can't control volume via the indicator. You can see the indicator icon here (it doesn't even look as it should to me):
http://img402.imageshack.us/img402/6214/selection003v.png

When I click it the mute option is grayed out. Can wingpanel contain notification bar for applications?

Anonymous comment on 2011-01-04 10:54

why when I press refresh button in my browser, the messages doubles?

Anonymous comment on 2011-01-04 10:53

I've got installed both of pulseaudio and ALSA.
What errors do you have about indicator-sound, when starting wingpanel?

Anonymous comment on 2011-01-04 10:51

I've got installed both of pulseaudio and ALSA.
What errors do you have about indicator-sound, when starting wingpanel?

caspian commented on 2011-01-04 10:41

Thanks for the connmand tip. Indicator-sound starts normaly for me, but I can't control volume with it. Do you use pulseaudio or ALSA?

Anonymous comment on 2011-01-04 10:40

sorry, it was the bug of this site (
unfortunately, there's no battary indicator for wingpanel

Anonymous comment on 2011-01-04 10:39

network-indicator isn't use networkmanager. Replace networkmanager module in yaour rc.conf with "connmand"
I managed to start inidicator-sound normally, when I recompilled my schemas again ;)

Anonymous comment on 2011-01-04 10:39

network-indicator isn't use networkmanager. Replace networkmanager module in yaour rc.conf with "connmand"
I managed to start inidicator-sound normally, when I recompilled my schemas again ;)

Anonymous comment on 2011-01-04 10:39

network-indicator isn't use networkmanager. Replace networkmanager module in yaour rc.conf with "connmand"
I managed to start inidicator-sound normally, when I recompilled my schemas again ;)

Anonymous comment on 2011-01-04 10:38

network-indicator isn't use networkmanager. Replace networkmanager module in yaour rc.conf with "connmand"
I managed to start inidicator-sound normally, when I recompilled my schemas again ;)

caspian commented on 2011-01-04 08:19

@friver I've already updated the schemas yesterday, but forgot to post it here. After the schemas update wingpanel starts normaly. Unfortunately now I have problems with some indicators:
*network indicator: when I click on it it says that the command is missing (probably a missing dependency in the AUR package, but I don't know what could it be. I have network-manager installed)
*sound indicator: I can't control volume via it (I presume that it has something to do with pulse. I don't have it installed). I also don't have rhythmbox controls or icon under it and the rhythmbox indicator is installed and enabled under rhythmbox plugins.

If someone knows how to fix these please post. One more thing; which indicator should I install to have power manager icon in wingpanel?

Anonymous comment on 2011-01-04 02:02

I used this command to update schemas:
glib-compile-schemas /usr/share/glib-2.0/schemas
good luck ;)

caspian commented on 2011-01-03 15:50

I've managed to build all the packages from ayatana-ubuntu, but the wingpanel still doesn't work. Now at least it dies with the following error:
http://aur.pastebin.com/k6iP7ZTR

I've shecked the indicator-datetime package and it contains the above required schema:
/usr/share/glib-2.0/schemas/org.ayatana.indicator.datetime.gschema.xml

I have no ideas on where to go from here :S

flamelab commented on 2011-01-03 14:10

Same problem here. I think we have to have ayatana-ubuntu installed (all of these packages), but libindicate fails to be built (in my system) and I can't run them, unfortunatelly.

caspian commented on 2011-01-03 13:58

Thanks for the quick response. I've installed it but when I run it nothing is shown on my desktop and "ps xa" shows that the /usr/bin/wingpanel process is running. I'm using compiz and I've removed gnome-panel completely. Any suggestions?

flamelab commented on 2011-01-03 10:38

Fixed !

caspian commented on 2011-01-03 09:27

install: cannot stat `./_build_/wingpanel': No such file or directory
Aborting...

flamelab commented on 2011-01-03 09:00

PKGBUILD updated, many thanks friver !

Anonymous comment on 2011-01-03 04:08

branch files were changed.
now PKGBUILD should be like this one: http://aur.pastebin.com/Mwu7DnDV