Package Details: wingpanel-git r386.44b5f49-1

Git Clone URL: https://aur.archlinux.org/wingpanel-git.git (read-only)
Package Base: wingpanel-git
Description: Stylish top panel that holds indicators and spawns an application launcher
Upstream URL: https://github.com/elementary/wingpanel
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: wingpanel
Provides: libwingpanel-2.0.so, wingpanel
Submitter: alucryd
Maintainer: alucryd
Last Packager: alucryd
Votes: 41
Popularity: 0.645343
First Submitted: 2017-04-30 15:25
Last Updated: 2019-02-01 16:59

Required by (54)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

gnuns commented on 2018-12-13 13:34

Please update to remove CMAKE and add Meson

build() { cd wingpanel meson build --prefix=/usr cd build ninja }

package() { cd wingpanel/build

DESTDIR="${pkgdir}" ninja install }

https://github.com/elementary/wingpanel#building-and-installation

jmaris commented on 2018-09-11 16:56

I am able to build wingpanel, however after installing the wingpanel-indicator-*-git indicators, they do not display in the panel :(

btd1337 commented on 2018-06-23 02:09

Not provided: libgranite.so=4-64 but needed by wingpanel-git-r347.7157201-1

pantheon/granite-git 5.0.r21.4e84fc7-1 (pantheon-unstable) [installed]

quequotion commented on 2018-04-25 15:10

Wingpanel has the same broken libdir in pkgconfig as switchboard

https://aur.archlinux.org/cgit/aur.git/tree/fix-libdir.patch?h=wingpanel-standalone-git

alucryd commented on 2017-12-27 21:04

Fixed, thanks.

SolarAquarion commented on 2017-11-14 18:38

Package wingpanel-git not found in repositories, trying AUR...
:: resolving dependencies...
:: no results found for gala-bzr (dependency tree: wingpanel-git gala-bzr)

alucryd commented on 2017-05-31 21:21

No it does not, it has always compiled and still builds fine in clean chroots as part of my nightlies without the extra elementary cmake modules. The only 2 things that need them right now are the 2 agents.

quequotion commented on 2017-05-31 04:57

You could replace 'cmake' in makedepends() with 'cmake-elementary-bzr'. It is required to build this (wingpanel needs gala's cmake package) and it in turn depends on 'cmake' itself.

*accidentally deleted; reposting*

alucryd commented on 2014-07-15 23:33

We've been talking about this for weeks, if not for months, on the pantheon forum thread. wingpanel now needs a recent libindicator and gtk3-ubuntu, thus is essentially useless on arch linux until further notice. And no I'm not going to endorse/promote patched packages like gtk3-ubuntu. The last working version of wingpanel-bzr can be found on my repo but you're better off using another panel until the situation changes anyway.

iRy1989 commented on 2014-07-15 21:25

Same Error here
http://pastebin.com/embed_js.php?i=n4aAmEJU --- DETAILED INFORMATION