Package Details: wingpanel 0.3.0.2-1

Git Clone URL: https://aur.archlinux.org/wingpanel.git (read-only)
Package Base: wingpanel
Description: The Pantheon Top Panel
Upstream URL: https://launchpad.net/wingpanel
Licenses: GPL3
Groups: pantheon
Submitter: alucryd
Maintainer: alucryd
Last Packager: alucryd
Votes: 7
Popularity: 0.000000
First Submitted: 2012-11-21 11:26
Last Updated: 2016-02-14 14:59

Dependencies (8)

Required by (0)

Sources (1)

Latest Comments

alucryd commented on 2014-06-19 10:14

jeeves: I'd say you're better off using wingpanel-bzr, because pantheon is moving fast, and stable wingpanel is getting very old. But, wingpanel-bzr has become unusable because it now depends on ubuntu-gtk3... I have given up on wingppanel for now, you can easily replace it with other panel alternatives, like xfce4-panel for example.

jeeves commented on 2014-05-20 22:22

I'm also getting a segfault when running wingpanel:
[_LOG_LEVEL_INFO 15:18:03.907068] Application.vala:77: Wingpanel version: 0.2.5
[_LOG_LEVEL_INFO 15:18:03.907206] Application.vala:79: Kernel version: 3.14.3-1-chromebook
[_LOG_LEVEL_FATAL 15:18:04.030383] [GLib] g_error_free: assertion 'error != NULL' failed
[_LOG_LEVEL_FATAL 15:18:04.030443] Wingpanel will not function properly.
[_LOG_LEVEL_FATAL 15:18:04.033942] IndicatorFileModel.vala:91: Unable to load /usr/lib/indicators3/7/libsession.so
[_LOG_LEVEL_FATAL 15:18:04.033997] Wingpanel will not function properly.
[_LOG_LEVEL_WARN 15:18:04.049837] [LIBDBUSMENU-GLIB] Unable to get session bus: Operation was cancelled
[_LOG_LEVEL_WARN 15:18:04.050047] [LIBDBUSMENU-GLIB] Unable to get session bus: Operation was cancelled
[1] 6710 segmentation fault (core dumped) wingpanel

alucryd commented on 2014-04-02 19:24

ainola: What's the point of writing something and delete it right afterwards? Or maybe you realized that saying "one should always quote variables in sh" is utterly wrong. I happen to know what I'm doing and there's absolutely no need to quote variables that do not contain whitespaces.

ainola commented on 2014-04-02 18:33

Thanks very much for the package.

Just a friendly reminder, one should always quote variables in sh. :)

http://www.tldp.org/LDP/abs/html/quotingvar.html

RibShark commented on 2014-02-04 17:57

Segfaults on my machine:
[_LOG_LEVEL_INFO 17:55:56.865775] Application.vala:77: Wingpanel version: 0.2.5
[_LOG_LEVEL_INFO 17:55:56.865851] Application.vala:79: Kernel version: 3.12.9-2-ARCH
[_LOG_LEVEL_FATAL 17:55:56.920914] [GLib] g_error_free: assertion 'error != NULL' failed
[_LOG_LEVEL_FATAL 17:55:56.920964] Wingpanel will not function properly.
[_LOG_LEVEL_FATAL 17:55:56.921889] IndicatorFileModel.vala:91: Unable to load /usr/lib/indicators3/7/libsession.so
[_LOG_LEVEL_FATAL 17:55:56.921932] Wingpanel will not function properly.
[_LOG_LEVEL_WARN 17:55:56.948675] [LIBDBUSMENU-GLIB] Unable to get session bus: Operation was cancelled
[_LOG_LEVEL_WARN 17:55:56.948758] [LIBDBUSMENU-GLIB] Unable to get session bus: Operation was cancelled
[1] 10677 segmentation fault (core dumped) wingpanel

Does not segfault when compiling with the changes I described. Strange how it happens for me but not for you...

RibShark commented on 2014-02-04 17:56

Segfaults on my machine:
[_LOG_LEVEL_INFO 17:55:56.865775] Application.vala:77: Wingpanel version: 0.2.5
[_LOG_LEVEL_INFO 17:55:56.865851] Application.vala:79: Kernel version: 3.12.9-2-ARCH
[_LOG_LEVEL_FATAL 17:55:56.920914] [GLib] g_error_free: assertion 'error != NULL' failed
[_LOG_LEVEL_FATAL 17:55:56.920964] Wingpanel will not function properly.
[_LOG_LEVEL_FATAL 17:55:56.921889] IndicatorFileModel.vala:91: Unable to load /usr/lib/indicators3/7/libsession.so
[_LOG_LEVEL_FATAL 17:55:56.921932] Wingpanel will not function properly.
[_LOG_LEVEL_WARN 17:55:56.948675] [LIBDBUSMENU-GLIB] Unable to get session bus: Operation was cancelled
[_LOG_LEVEL_WARN 17:55:56.948758] [LIBDBUSMENU-GLIB] Unable to get session bus: Operation was cancelled

Does not segfault when compiling with the changes I described. Strange how it happens for me but not for you...

alucryd commented on 2014-02-04 17:53

RibShark: Wingpanel has been compatible with our vala for quite some time now, it does not segfault here.

RibShark commented on 2014-02-04 17:48

Can you replace vala with vala0.16 in makedeps, and add -DVALA_EXECUTABLE='$(type -p valac-0.16)' to cmake flags, otherwise wingpanel segfaults when started.

alucryd commented on 2013-08-11 18:50

No shit... You know, when copying PKGBUILDs, forgetting to remove some things happens... No need to be so condescending about it...

alium commented on 2013-08-11 17:47

you need NOT 'bzr' for making the package... (you need 'bzr' for wingpanel-bzr only)