Package Details: winswitch 0.12.22-1

Git Clone URL: https://aur.archlinux.org/winswitch.git (read-only)
Package Base: winswitch
Description: Window-Switch is a client server tool to start and control virtual desktops
Upstream URL: https://winswitch.org/
Licenses: GPL3
Submitter: fzerorubigd
Maintainer: bug
Last Packager: bug
Votes: 17
Popularity: 0.006916
First Submitted: 2010-12-20 16:37
Last Updated: 2016-05-04 20:44

Dependencies (13)

Required by (0)

Sources (1)

Latest Comments

speps commented on 2013-10-05 20:19

Disowning since I do not use winswitch anymore.

Citral commented on 2013-09-29 17:12

pycrypto --> python2-crypto

Citral commented on 2013-09-28 13:13

I can confirm gregor's comment. Moreover, there are more files expected in the /usr/lib/winswitch directory (such as delayed_start), so you're best off just symlinking /usr/share/winswitch to /usr/lib/winswitch to get things working with the least effort.

Citral commented on 2013-09-28 13:13

I can confirm gregor's comment. Moreover, there are more files expected in the /usr/lib/winswitch directory (such as delayed_start), so you're best off just symlinking /usr/share/winswitch to /usr/lib/winswitch to get things with the least effort.

gregorburger commented on 2013-08-20 13:03

I had troubles connecting to winswitch using xpra. After debugging I found
out that winswitch expects the script virt_server_daemonizer in /usr/lib/winswitch/ but with your package the scripts get installed into
/usr/share/winswitch. this renders xpra support unusable.

kind regards gregor

libgradev commented on 2013-07-25 08:36

0.12.19 available. Built fine here by amending the PKGBUILD.

http://winswitch.org/src/winswitch-0.12.19.src.tar.bz2

md5sum: c1024896c548c26b80a9014ff77f74ac

cmsigler commented on 2013-03-29 15:24

I've created a patch to update PKGBUILD to ver. 0.12.18-1. Please find my patch here:

http://pastebin.com/EuNMQyf2

Using this, winswitch ver. 0.12.18 does build for me. However, due to other problems I'm not able to get winswitch working so this is not a proper test. I hope this PKGBUILD can still be of use.

Clemmitt

bug commented on 2013-03-15 07:23

"Description: Window-Switch is a client server tool to start and control virtual desktops"

When creating a package description for a package, do not include the package name in a self-referencing way. For example, "Nedit is a text editor for X11" could be simplified to "A text editor for X11". Also try to keep the descriptions to ~80 characters or less.

Awebb commented on 2013-03-14 18:22

I also encountered that problem. Could it be locale related?

Dude-man commented on 2012-12-18 16:38

I get the following
[code]
[EE] 2012/18/12 17:14:53 WinSwitchServer.ready()
[ee] 2012/18/12 17:14:53 Traceback (most recent call last):
[ee] 2012/18/12 17:14:53 File "/usr/lib/python2.7/site-packages/winswitch/server/controller.py", line 316, in ready
[ee] 2012/18/12 17:14:53 self.assign_virt_utils()
[ee] 2012/18/12 17:14:53 File "/usr/lib/python2.7/site-packages/winswitch/server/controller.py", line 405, in assign_virt_utils
[ee] 2012/18/12 17:14:53 from winswitch.virt.vnc_server_util import VNCServerUtil
[ee] 2012/18/12 17:14:53 File "/usr/lib/python2.7/site-packages/winswitch/virt/vnc_server_util.py", line 16, in <module>
[ee] 2012/18/12 17:14:53 from winswitch.virt.server_util_base import ServerUtilBase
[ee] 2012/18/12 17:14:53 File "/usr/lib/python2.7/site-packages/winswitch/virt/server_util_base.py", line 40, in <module>
[ee] 2012/18/12 17:14:53 from winswitch.util.xkbmap_util import set_keymap
[ee] 2012/18/12 17:14:53 File "/usr/lib/python2.7/site-packages/winswitch/util/xkbmap_util.py", line 173
[ee] 2012/18/12 17:14:53 SyntaxError: Non-ASCII character '\xc3' in file /usr/lib/python2.7/site-packages/winswitch/util/xkbmap_util.py on line 173, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details
[/code]
editing the xkbmap_util.py on line 173 to remove the 'Non-ASCII' chars gets it working for me.

BrainDamage commented on 2012-10-16 02:16

looks like it's missing python2-utmp from the dependency list, i can install and run, but i cannot connect to the server and the log has the import module error in the log

also it seems that the internal autodetection of paths are somehow broken, i had to manually pass --winswitch_libexec_dir=/usr/share/winswitch to winswitch_server in order to get it run, i can see that pkgbuild already tampers with them but i did not dig in the code enough to see if that's the source of the problem or it needs additional arch specific path fixes

speps commented on 2012-04-30 09:41

@jongrocho Thanks for reporting this change. Md5sum updated in 0.12.13-2

Anonymous comment on 2012-04-30 08:37

The md5sum is wrong
md5sums=('052756a26235a0dd9b7586ba9b4cde00')

speps commented on 2012-03-22 17:31

@dgbaley27 Thanks for reporting, package updated to latest 0.12.12-1 with fixed dependency.

dgbaley27 commented on 2012-02-22 22:03

Please replace the pyasn1 dependency with python-pyasn1 or python2-pyasn1 as appropriate.

speps commented on 2011-12-30 00:03

@Morgan_Cox Thanks for reporting, nxproxy optional dependency added in latest version 0.12.8.

Morgan_Cox commented on 2011-12-22 12:16

Could you add 'optdepends' for nxproxy ?

fzerorubigd commented on 2011-03-03 20:47

@dserban thanks, I just edit the old one :) fixed.

dserban commented on 2011-03-03 19:27

Only rpmextract should be in makedepends.
The PKGBUILD should contain two lines like this:
makedepends=('rpmextract')
depends=('python2' 'pygtk' 'pycrypto' 'twisted' 'pyasn1')