Package Details: winusb-git r94.72aa1d9-1

Git Clone URL: https://aur.archlinux.org/winusb-git.git (read-only)
Package Base: winusb-git
Description: Simple tool to create a usb stick installer for Windows (Vista and above)
Upstream URL: http://en.congelli.eu/prog_info_winusb.html
Licenses: GPL3
Conflicts: winusb
Provides: winusb
Submitter: CarstenF
Maintainer: CarstenF
Last Packager: CarstenF
Votes: 36
Popularity: 1.451054
First Submitted: 2016-06-08 11:36
Last Updated: 2017-04-06 16:29

Latest Comments

Pietro_Pizzi commented on 2017-09-23 22:36

@mihails-strasuns That don't work for me:

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: r561.v2.1.3-46-ga6e69df
==> ERROR: Makepkg was unable to build winusb-git.

mihails-strasuns commented on 2017-09-18 09:20

Had to change build script to this to work:

build() {
cd "${srcdir}/${pkgname}"
./setup-development-environment.bash
autoreconf --force --install
./configure --prefix=/usr
make
}

sa1t commented on 2017-07-03 00:27

==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: r486.v2.1.1-4-g57a510b
==> ERROR: Makepkg was unable to build winusb-git.

borrelnoot commented on 2017-06-20 12:22

I'm getting a pkgver error:

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: r484.v2.1.1-2-gb67b343

To workaround I manually used "r484" as version.

RemoteAdmin commented on 2017-04-06 08:50

The current Package Version is currently only the abbreviated commit name and therefore does not increase with each update. I would suggest something like the following to get a higher Version for each new commit:

pkgver() {
cd ${srcdir}/${pkgname}
echo "r$(git rev-list --count HEAD).$(git describe --always)"
}

The Version would look like "r94-72aa1d9" which contains the current number of commits and the latest abbreviated commit name.

agm28011997 commented on 2017-03-16 10:07

this app should replace winusb in aur.. I have mates that tries with winusb, but not git, and winusb(not git version) give me problems for everything

Anton.Latukha commented on 2017-02-23 01:03

I've get:

$ sudo winusb -v --format /home/pyro/win.iso /dev/sdc
Formating device...
Mounting...
mount: /media/winusb_iso_1487811588_20943: mount failed: Unknown error -1
Error occured !
Syncing...
Cleaning...
Umounting and removing '/media/winusb_iso_1487811588_20943'...
umount: /media/winusb_iso_1487811588_20943: not mounted
Umounting and removing '/media/winusb_target_1487811588_20943'...
umount: /media/winusb_target_1487811588_20943: mountpoint not found

=======

GUI:

Installation failed !
Exit code: 512
Log:
Formatting device...
Wait 3 seconds for block device nodes to populate...
mkfs.fat: warning - lowercase labels might not work properly with DOS or Windows
mkfs.fat 4.0 (2016-05-06)
Mounting...
mount: /media/winusb_iso_1487812226_28311: mount failed: Unknown error -1
Error occured!
Syncing...
/usr/bin/winusb: line 78: 28322 Terminated while true; do
sleep 0.05; echo 'pulse';
done
Cleaning...
/usr/bin/winusb: line 78: 28534 Terminated while true; do
sleep 0.05; echo 'pulse';
done
Unmounting and removing '/media/winusb_iso_1487812226_28311'...
umount: /media/winusb_iso_1487812226_28311: not mounted
Unmounting and removing '/media/winusb_target_1487812226_28311'...
umount: /media/winusb_target_1487812226_28311: mountpoint not found


I try to write Windows 10 LTSB x64 v1607 RU.

Same also for winusb 1.0

What is this?

ItachiSan commented on 2017-02-01 20:12

I highly reccomend to change the version number and the pkgver() function...
I believe that any new commit starting with 'd' would not be consider as a new version...

NeoTheFox commented on 2016-11-29 13:58

localuser is right, dosfstools is missing from dependencies

dpeukert commented on 2016-10-01 20:06

There's a typo in the provides (winsub, should be winusb).

All comments